Jump to content

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Find out more here. X
X


Photo

XML in treeview


  • Please log in to reply
11 replies to this topic

#1 eltorro

eltorro

    more or less the same as the latter of the former.

  • Active Members
  • PipPipPipPipPipPip
  • 596 posts

Posted 10 January 2006 - 04:37 PM

From another discussion in Idea Lab Here is a link to an XML to treeview script.
It works with basic XML files.

I thought it would better serve the "community" by a least posting the link here.
http://www.autoitscript.com/forum/index.ph...pe=post&id=6385
http://www.autoitscript.com/forum/index.ph...pe=post&id=5983

:P

Edit: Updated link.

Edited by eltorro, 09 February 2006 - 06:42 AM.








#2 leecole

leecole

    Wayfarer

  • Active Members
  • Pip
  • 62 posts

Posted 11 January 2006 - 01:18 PM

From another discussion in Idea Lab Here is a link to an XML to treeview script.
I works with basic XML files.

I thought it would better serve the "community" by a least posting the link here.

http://www.autoitscript.com/forum/index.ph...pe=post&id=5983

:lmao:

I must be missing something.
GUICtrlGetHandle() : undefined function.
Talking Clockhttp://www.autoitscript.com/forum/index.php?showtopic=20751Talking Headlineshttp://www.autoitscript.com/forum/index.php?showtopic=20655Sometimes, I sits and thinkssometimes, I just sits

#3 SmOke_N

SmOke_N

    It's not what you know ... It's what you can prove!

  • Moderators
  • 15,863 posts

Posted 11 January 2006 - 01:38 PM

Do you have GuiTreeView.au3 in your beta include file?

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.


#4 leecole

leecole

    Wayfarer

  • Active Members
  • Pip
  • 62 posts

Posted 11 January 2006 - 07:10 PM

Do you have GuiTreeView.au3 in your beta include file?

Yes, I do, but it doesn't have GUICtrlGetHandle() in it.
Talking Clockhttp://www.autoitscript.com/forum/index.php?showtopic=20751Talking Headlineshttp://www.autoitscript.com/forum/index.php?showtopic=20655Sometimes, I sits and thinkssometimes, I just sits

#5 eltorro

eltorro

    more or less the same as the latter of the former.

  • Active Members
  • PipPipPipPipPipPip
  • 596 posts

Posted 11 January 2006 - 08:13 PM

Yes, I do, but it doesn't have GUICtrlGetHandle() in it.


GuiCtrlGetHandle() is an in built func of autoit.

Are you using a beta version?
msgbox(0,"Autoit Version",@AutoItVersion,5)


#6 leecole

leecole

    Wayfarer

  • Active Members
  • Pip
  • 62 posts

Posted 11 January 2006 - 09:47 PM

GuiCtrlGetHandle() is an in built func of autoit.

Are you using a beta version?

msgbox(0,"Autoit Version",@AutoItVersion,5)

msgbox(0,"Autoit Version",@AutoItVersion,5) says 3.1.1.91
Talking Clockhttp://www.autoitscript.com/forum/index.php?showtopic=20751Talking Headlineshttp://www.autoitscript.com/forum/index.php?showtopic=20655Sometimes, I sits and thinkssometimes, I just sits

#7 leecole

leecole

    Wayfarer

  • Active Members
  • Pip
  • 62 posts

Posted 11 January 2006 - 10:01 PM

msgbox(0,"Autoit Version",@AutoItVersion,5) says 3.1.1.91

OK, I downloaded 3.1.1.101 and installed.
I still get compile error saying GUICtrlGetHandle() is an unknown function, but if I continue, it works. Thanks! Now how do I get it to not give a compile time error? I am sure, I need to do something else.
Talking Clockhttp://www.autoitscript.com/forum/index.php?showtopic=20751Talking Headlineshttp://www.autoitscript.com/forum/index.php?showtopic=20655Sometimes, I sits and thinkssometimes, I just sits

#8 eltorro

eltorro

    more or less the same as the latter of the former.

  • Active Members
  • PipPipPipPipPipPip
  • 596 posts

Posted 12 January 2006 - 02:42 AM

If your using SciTe for Autoit, have you tried updating the defs for SciTe?

Ctrl 1, if the beta defs is selected, click on it again and it will re-update the defs.

#9 leecole

leecole

    Wayfarer

  • Active Members
  • Pip
  • 62 posts

Posted 12 January 2006 - 04:36 AM

If your using SciTe for Autoit, have you tried updating the defs for SciTe?

Ctrl 1, if the beta defs is selected, click on it again and it will re-update the defs.

OK, I did that, and it said it was updating, showed progress bar, but when it finished I tried a recompile and it still reported the function as undefined. Again if I continue, it works. I must have something set up wrong. Thanks, though for explaining how it is supposed to work, I did not know that.
Talking Clockhttp://www.autoitscript.com/forum/index.php?showtopic=20751Talking Headlineshttp://www.autoitscript.com/forum/index.php?showtopic=20655Sometimes, I sits and thinkssometimes, I just sits

#10 theguy0000

theguy0000

    Benevolent Dictator

  • Active Members
  • PipPipPipPipPipPip
  • 3,750 posts

Posted 05 February 2006 - 12:07 AM

it comes up with an error when i click the link in the first post.
The cake is a lie.www.theguy0000.com is currentlyUP images.theguy0000.com is currentlyUP all other *.theguy0000.com sites are DOWN

#11 eltorro

eltorro

    more or less the same as the latter of the former.

  • Active Members
  • PipPipPipPipPipPip
  • 596 posts

Posted 09 February 2006 - 06:43 AM

it comes up with an error when i click the link in the first post.


@'theguy0000

I updated the link in the first post.

:lmao:

#12 WeMartiansAreFriendly

WeMartiansAreFriendly

    Where's the kaboom?

  • Active Members
  • PipPipPipPipPipPip
  • 1,245 posts

Posted 09 November 2009 - 09:54 PM

both links are down.
Posted ImageDon't bother, It's inside your monitor!------GUISetOnEvent should behave more like HotKeySet()




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users