Jump to content

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Find out more here. X
X


Photo

inactive Inputbox


  • Please log in to reply
14 replies to this topic

#1 danusko

danusko

    Wayfarer

  • Active Members
  • Pip
  • 76 posts

Posted 25 July 2006 - 02:13 PM

Hi,
can you help me?
I want make script, where i use inputbox. It display Inputbox, but i need, that this input box only shows and was inactiv, till i click on them. Is it possible?
Default when i make script, if the input box shows, is immediately displayed and other windows are inactive. But i need it oposite.
thanke you







#2 NELyon

NELyon

    Do you wanna brew my avatar?

  • Active Members
  • PipPipPipPipPipPip
  • 3,526 posts

Posted 25 July 2006 - 05:12 PM

InputBox("Title", "Imput Box Test", "") WinSetState("Title", "", @SW_SHOWNOACTIVATE)

PS: This is scripts/scraps. This goes in support

#3 danusko

danusko

    Wayfarer

  • Active Members
  • Pip
  • 76 posts

Posted 26 July 2006 - 01:42 PM

InputBox("Title", "Imput Box Test", "") WinSetState("Title", "", @SW_SHOWNOACTIVATE)

PS: This is scripts/scraps. This goes in support


Thanke you, but i try this and it doesnt works. It can be because i havn´t autoit instaled?
If yes, is anything, what can i do? I want, that this funciont works. F.e. copy any autoit files somewhere or so?
Do you know please? F.e. i use GUI, but i need define path to the GUI files and it works.
thanx

#4 rambo3889

rambo3889

    It is I

  • Active Members
  • PipPipPipPipPipPip
  • 802 posts

Posted 26 July 2006 - 02:30 PM

:whistle: Not to be rude but you cant use a autoit script without autoit installed
Only autoit executabels is usable without autoit installed


Edit

It can be because i havn´t autoit instaled?
If yes, is anything, what can i do?

Yes install autoit and make a new script and then paste codemysters script into yours and compile the script

Edited by rambo3889, 26 July 2006 - 02:42 PM.

My Scripts:Radioblog Club Music DownloaderOther stuff:Fun movieIm serious read the help file it helps :PFight 'Till you drop. Never stop, You Cant give up. Til you reach the top Fight! you’re the best in town Fight!

#5 danusko

danusko

    Wayfarer

  • Active Members
  • Pip
  • 76 posts

Posted 26 July 2006 - 02:42 PM

but i cant install it because i am in work and i dont have a permission
but i like this program and i want it use in work too.
:whistle:

#6 Daniel W.

Daniel W.

    I hacked 127.0.0.1 !!!

  • Active Members
  • PipPipPipPipPipPip
  • 434 posts

Posted 26 July 2006 - 02:52 PM

start it with au3exe :whistle:
--------------------------------------------------------------------------------------------------------------------------------Scripts : _Encrypt UDF_UniquePCCode UDF MS like calculatorInstall programm *UPDATED* --------------------------------------------------------------------------------------------------------------------------------

Have you ever tried surfing the internet with a milk-carton ?This is similar to what you're trying to do.


#7 Paulie

Paulie

    Waiting for Misaki Nakahara

  • Active Members
  • PipPipPipPipPipPip
  • 5,145 posts

Posted 26 July 2006 - 06:15 PM

@danusko

Go home, copy script save it, compile it, burn to CD/Flash drive/USB stick, bring to work, use script
Simple as that

How'd you expect to use a '.au3' filetype without installing autoit?

Edited by Paulie, 26 July 2006 - 06:15 PM.

I'm still looking for my heart song.

Posted Image


#8 Helge

Helge

    Yup

  • Active Members
  • PipPipPipPipPipPip
  • 2,049 posts

Posted 26 July 2006 - 06:22 PM

Thanke you, but i try this and it doesnt works. It can be because i havn´t autoit instaled?
If yes, is anything, what can i do? I want, that this funciont works. F.e. copy any autoit files somewhere or so?
Do you know please? F.e. i use GUI, but i need define path to the GUI files and it works.
thanx

Have you ever tried surfing the internet with a milk-carton ?
This is similar to what you're trying to do.

#9 Paulie

Paulie

    Waiting for Misaki Nakahara

  • Active Members
  • PipPipPipPipPipPip
  • 5,145 posts

Posted 26 July 2006 - 06:40 PM

Have you ever tried surfing the internet with a milk-carton ?


Hey!

Whats wrong with surfing the net with a milk carton?!
:whistle: :)
I'm still looking for my heart song.

Posted Image


#10 Skrip

Skrip

    Psychonaut

  • Active Members
  • PipPipPipPipPipPip
  • 2,346 posts

Posted 26 July 2006 - 07:01 PM

Hey!

Whats wrong with surfing the net with a milk carton?!
:whistle: :)


The orange juice box works alot better...
More stability

Edited by Firestorm, 26 July 2006 - 07:02 PM.

We're trapped in the belly of this horrible machine.And the machine is bleeding to death...


#11 Richard Robertson

Richard Robertson

    Universalist

  • Active Members
  • PipPipPipPipPipPip
  • 10,333 posts

Posted 26 July 2006 - 07:12 PM

You cannot change the active status of the InputBox through code. That would have to be modified in the actual AutoIt code. The script stops while waiting for the InputBox. You could try making your own window.

You can download a Zip file containing all the necessary files for AutoIt and can run things manually. You don't need the installer, it just adds registry entries to have Windows run the au3 files.

#12 danusko

danusko

    Wayfarer

  • Active Members
  • Pip
  • 76 posts

Posted 27 July 2006 - 06:58 AM

ok,
so if i understand good,
it isnt possible make Input box inactive, because autoit cant it?
I belived, it is possible :whistle:
it is a shame

Exactly what i need is:
I have in clipboard a lot of numbers. This numbers represent identificator of any sites (i use IE). When i click on Input box OK, it is loaded a site and then show inputbox again. But i need from the site/window read some things from tool tip of links on this site. This goes only when i click on IE (because this window have to be active) and then go with mouse cursor on tool tip. Now it going so, that i have to click on IE after each OK on Input box. And it is a lot of silly clicks. :)

Knows anyone, how can i do that?

#13 Helge

Helge

    Yup

  • Active Members
  • PipPipPipPipPipPip
  • 2,049 posts

Posted 27 July 2006 - 05:04 PM

ok,
so if i understand good,
it isnt possible make Input box inactive, because autoit cant it?
I belived, it is possible :whistle:
it is a shame

Exactly what i need is:
I have in clipboard a lot of numbers. This numbers represent identificator of any sites (i use IE). When i click on Input box OK, it is loaded a site and then show inputbox again. But i need from the site/window read some things from tool tip of links on this site. This goes only when i click on IE (because this window have to be active) and then go with mouse cursor on tool tip. Now it going so, that i have to click on IE after each OK on Input box. And it is a lot of silly clicks. :)

Knows anyone, how can i do that?

Read a little bit about the GUI-functions in your helpfile...play a little bit with them
and you should get what you want.

#14 danusko

danusko

    Wayfarer

  • Active Members
  • Pip
  • 76 posts

Posted 28 July 2006 - 08:16 AM

ok
i try it
thanx

#15 danusko

danusko

    Wayfarer

  • Active Members
  • Pip
  • 76 posts

Posted 28 July 2006 - 10:00 AM

So this is my result with gui, but it doesnt work, like it worked with inputbox. I cant make work "do" and "while" together and it seems, it must use both. :whistle:


Plain Text         
AutoItSetOption ( "SendKeyDelay", 50 ) #include "d:\Documents and Settings\danusko\My Documents\My documents\docs\AutoIt\Include\GUIConstants.au3" Local $i = 1000 Local $j = 1000 Local $z = 1000 Local $y = 1000 dim $a[$i] dim $b[$j] dim $c[$z] dim $m dim $ok dim $cancel $sp = InputBox("Skreèped ","Zdaj è. sp: ","90410", "", 200, 200, 750, 200) if @error = 1 then exit ; ------------ start 1. stlpec ----------------- WinActivate("Microsoft Excel", "") $i = 0 do $i = $i + 1 send ("^c") send ("{down}") $a[$i] = ClipGet() until ( $a[$i] < 1);************* dal ANO $n = $i $m = $i $z = $i $y = $i ; ------------ end 1. stlpec ----------------- MsgBox(262145, "2. stlpec", "" ) ; ------------ start 2. stlpec ----------------- WinActivate("Microsoft", "") $j = 0 do $j = $j + 1 send ("^c") send ("{down}") $b[$j] = ClipGet() until ( $b[$j] < 1);************* dal ANO ; ------------ end 2. stlpec ----------------- MsgBox(262145, "3. stlpec", "" ) ; ------------ start 3. stlpec ----------------- WinActivate("Microsoft", "") do $z = $z - 1 send ("^c") send ("{down}") $c[$z] = ClipGet() until ( $z = 0 );************* dal ANO ; ------------ start 3. stlpec ----------------- ; doplnenny z rep1 - natahuje gauss OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO $n=0 $i = $i-1 do $n = $n + 1 $k = $n + 1 sleep (300) sleep(2000) WinWAIT("GAUSS", "") WinActivate("GAUSS", "") WinWAIT("GAUSS", "") Run ( @Comspec & " /c start <a href='http://link' class='bbc_url' title='External link' rel='nofollow external'>http://link"</a> & $a[$n] & "link" ) sleep(300) ToolTip("/" & $n & "z" & $i, 30, 690) until $n = $m-1 ;pokracuje origi $n = $n + 1     do $m = $m - 1 $k = $m + 1 $z = $z + 1 $y = $z - 1 $n = $n - 1 sleep (300) ; ClipPut ($a[$k]) ClipPut ($a[$m]) ToolTip("/" & $m & "/" & $a[$n] & "/" &  $b[$m] & "/" & $c[$z], 5, 350) ; ----------------------------------- If Not IsDeclared('WS_CLIPSIBLINGS') Then Global $WS_CLIPSIBLINGS = 0x04000000 GuiCreate("Ešte " & $m, 170, 133,(@DesktopWidth-370)/2, (@DesktopHeight-333)/2 , $WS_OVERLAPPEDWINDOW + $WS_VISIBLE + $WS_CLIPSIBLINGS + $WS_EX_TOPMOST) $ok = GuiCtrlCreateButton("OK", 10, 80, 90, 40) GUICtrlSetState( -1, $GUI_DEFBUTTON) $cancel = GuiCtrlCreateButton("Zruš", 120, 100, 40, 20) $Label_3 = GuiCtrlCreateLabel("Teraz:  " & $a[$m], 10, 10, 150, 20) $Label_4 = GuiCtrlCreateLabel("TerazII: " & $b[$m], 10, 30, 150, 20) $Label_5 = GuiCtrlCreateLabel("TerazIII: " & $c[$z], 10, 50, 150, 20) GuiSetState() While 1     $msg = GuiGetMsg()   Select Case $msg = $GUI_EVENT_CLOSE ExitLoop ; Case Else         Case  $msg = $ok     ;;;    ; EndSelect ; ------------------------------------------------------- ClipPut ($a[$m]) WinActivate("GAUSS", "") WinWAIT("GAUSS", "") send("{BS}") send ("^f") WinWaitActive ("Find", "", 1) WinActivate("Find", "") ; send ($sp) ClipPut ($sp) send ("^v") send ("{enter}") send ("{tab}") send ("{enter}") send ("{down}") ; sleep (200) WinWaitActive ("GAUSS - Prezeranie", "") ; ToolTip("/" & $m & "/" & $a[$n], 5, 620) ClipPut ($a[$k])  Case $msg = $cancel     Exit ; WEnd EndSelect wend until $m = 1 exit


what is wrong?
please can you help me?
thanx

Edited by danusko, 28 July 2006 - 10:27 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users