Sign in to follow this  
Followers 0

Chat AU3 Program

7 posts in this topic

Posted (edited)

I have found three AU3 based chat programs, including Cobra (which looks promising). The only problem is I don't know how to set those up. I'm getting a few different errors with Cobra, but only one or two errors with YaC_P and AU3Chat.

Any guidance is MUCH appreciated!! I just want to develop a intraChat (all these may very well be that)

AU3 Chat Programs I've Tried

http://cobramessenger.co.nr/

http://www.autoitscript.com/forum/index.php?showtopic=37175

http://www.autoitscript.com/forum/index.php?showtopic=28730

Edited by JohnBailey

Share this post


Link to post
Share on other sites



Posted

Well you'll want to look into the TCP functions, start by building a small server / client system and expand upon that :whistle:

Share this post


Link to post
Share on other sites

Posted

Check my thread in my signature.

Share this post


Link to post
Share on other sites

Posted

What errors are you getting with YaC-P? Please post them in the YaC-P thread and I will try and help you.

Share this post


Link to post
Share on other sites

Posted (edited)

User Client.au3(183,31) : WARNING: $UserList: possibly used before declaration.

If Not $UserList[$Count][0] Then

~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

That's what happens when I publish/compile the admin client and User client.

The user client doesn't seem to connect. It says it does, but I cannot message nor will it let me click X to close it (X is not responsive).

Edited by JohnBailey

Share this post


Link to post
Share on other sites

Posted

User Client.au3(183,31) : WARNING: $UserList: possibly used before declaration.

If Not $UserList[$Count][0] Then

~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

That's what happens when I publish/compile the admin client and User client.

You can safely ignore that warning. I have not found a good way to get rid of it. The program will still run with that warning.

The user client doesn't seem to connect. It says it does, but I cannot message nor will it let me click X to close it (X is not responsive).

Are you running this on a local network or over the Internet?

Share this post


Link to post
Share on other sites

Posted

Are you running this on a local network or over the Internet?

Just locally, and thanks for the note about ignoring the error. I am just want to do an internally only messaging. I actually would like to build one from scratch, but considering I don't know how to it would take me a long time. Besides, this one seems great - "why reinvent the wheel." :whistle: I just wanted a small IM to use on about 8 computers. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.