Sign in to follow this  
Followers 0

64bit Autoit3 Progress?

12 posts in this topic

Posted · Report post

I've been testing the beta's for x64, thanks for all the hard work you've done.

I wanted to see if you had any thing on overall progress?

How far away would you say it is for having compiled x64 binary scripts (aut2exe)?

Thanks again.

Share this post


Link to post
Share on other sites



Posted · Report post

not too much progres from what Jon post in the beta area.

May I ask to describe why you need a 64 bit version?

From my point of view the performance penalty is not so much under a Pentium Processor that support X64 for a process running in 32-bit mode

(Under an Itanium that's a little be different)

:)

Share this post


Link to post
Share on other sites

Posted · Report post

not too much progres from what Jon post in the beta area.

May I ask to describe why you need a 64 bit version?

From my point of view the performance penalty is not so much under a Pentium Processor that support X64 for a process running in 32-bit mode

(Under an Itanium that's a little be different)

:)

We use Autoit in WinPE x86 and x64, but x64 Winpe does not have a 32bit emulation mode, so I have to have 64bit binaries.

I've been running it is script mode:

AutoIt3_x64.exe scriptname.au3

But there are lots of needed dependency scripts and not all the functions are handled. And no support for DLLCall yet.

It would just be nicer to just be able to make stand alone EXE files.

Share this post


Link to post
Share on other sites

Posted · Report post

I'll try and compile a AutoItSC.bin in 64 bit mode when I do the next beta - that should then work if you overwrite the normal one in the Aut2Exe directory. Haven't even starting looking at DllCall though - it's a monster bit of assembly needed for that.

Share this post


Link to post
Share on other sites

Posted · Report post

Sweet, thanks.

Just having the ability to compile 64bit binaries would be a great help.

Share this post


Link to post
Share on other sites

Posted · Report post

I'll try and compile a AutoItSC.bin in 64 bit mode when I do the next beta - that should then work if you overwrite the normal one in the Aut2Exe directory.

How did that go, did it compile with out issues?

I saw the new Beta, but I couldn't tell is there was a new x64 BIN file or not.

Share this post


Link to post
Share on other sites

Posted · Report post

Would it help out the 64bit development, if I sent you a 64bit machine?

Share this post


Link to post
Share on other sites

Posted · Report post

Would it help out the 64bit development, if I sent you a 64bit machine?

No, I've got one, I just choose not to run it in x64 mode because of driver/software support. I believe my copy of VMware may be able to run an x64 guest even when running on a x86 host but I've not had time to set this up.

Share this post


Link to post
Share on other sites

Posted · Report post

I believe my copy of VMware may be able to run an x64 guest even when running on a x86 host but I've not had time to set this up.

Depends on your CPU. But I know vmware can handle it, because I'm currently running it like that on my system now.

Share this post


Link to post
Share on other sites

Posted · Report post

Depends on your CPU. But I know vmware can handle it, because I'm currently running it like that on my system now.

I was assuming that the host guest need to run a 64-bit OS to run 64-bit or 32-bit guest.

Are you really sure a XP 32-bit on a AMD-64 or INTEL EMT processor is doing what you are saying?

In fact as Jon can run X64 and I can't, I can be interested to have such machine. :)

I can help Jon more efficiently...

Share this post


Link to post
Share on other sites

Posted · Report post

Apparently on an x64 machine running x86 vista, with VMWare you can still create x64 guests - which is very cool.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.