Jump to content

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Find out more here. X
X


Photo

v3.0.103 Unstable - Revolutions


  • Please log in to reply
166 replies to this topic

#41 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,630 posts

Posted 13 January 2005 - 01:23 PM

Updated:
http://www.autoitscript.com/autoit3/files/beta/autoit/

- Compiled in Terminal Server Aware mode (fixes @WindowsDir problems under TS)
- Renamed AU3_Spy.exe to AU3Info.exe and changed doc references
- Added current cursor ID to the AU3Info output
- Fixed misc GUI bugs as reported in bug forum
- Misc doc updates







#42 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,630 posts

Posted 15 January 2005 - 01:38 PM

Updated:

- StringFormat \\ bug fixed
- Misc reported GUI bugs fixed
- Reported UDF typos/bugs fixed
- Helpfile examples installed in Autoit3\Examples\Helpfile (for future helpfile integration)

#43 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,630 posts

Posted 16 January 2005 - 10:27 PM

Updated:
- Colorized helpfile examples
- Some GUI OnEvent documentation
- Changed StringRegExp to return an array or true/false, depending on flag.
- Changed StringRegExp to return either the first matching string or ALL matching strings in the return array, depending on flag.
- Fixed StringRegExp for incomplete string vs. pattern. Now fails instead of hanging.
- Fixed recent TAB control bug

#44 Jos

Jos

    Je maintiendrai

  • Developers
  • 23,305 posts

Posted 16 January 2005 - 10:53 PM

Updated:
- Colorized helpfile examples

<{POST_SNAPBACK}>

The Helpfile also contains a new "Open this script" button which will only work when you have installed this beta with the available installer since it tries to open the example in from examples\helpfile\function.au3
This also means that when the helpfile is opened from an Editor, the current directory is in general set to the directory of the script being edited, so the button will also not work .

The next SciTE4Autoit3 will contain all changes for this to work again.
if you want to make the changes already now you need to do the following:

Copy this script to your autoit3 directory: http://www.autoitscript.com/fileman/users/jdeb/test/autoit3help.exe ( source: http://www.autoitscript.com/fileman/users/jdeb/test/autoit3help.au3 )
change these lines in au3.properties:
# Commands to for Help F1 #command.help.*.au3=$(CurrentWord)!$(autoit3dir)\autoit.chm #command.help.subsystem.*.au3=4 command.help.*.au3=$(autoit3dir)\Autoit3Help.exe $(CurrentWord) command.help.subsystem.*.au3=1


The AutoIthelp program can also be used by other editors to make the button work.
It uses KeyHH.exe to open the helpfile at the correct Index entry.

Enjoy,

Visit the SciTE4AutoIt3 Download page for the latest versions                                                                 Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)


#45 SlimShady

SlimShady

    AutoIt lover

  • Active Members
  • PipPipPipPipPipPip
  • 2,383 posts

Posted 16 January 2005 - 11:27 PM

Wow. The help file looks great.
That "Open this script" feature is a really nice idea.

#46 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,630 posts

Posted 16 January 2005 - 11:28 PM

Wow. The help file looks great.
That "Open this script" feature is a really nice idea.

<{POST_SNAPBACK}>

Cyberslug and JdeB are the evil geniuses behind this one :idiot:

#47 jpm

jpm

    a Real GUI/debug lover

  • Developers
  • 9,750 posts

Posted 16 January 2005 - 11:37 PM

"Un grand bravo" to Cyberslug and JdeB.
Jon say genius I would say :idiot: genius² :D

#48 Chris_1013

Chris_1013

    Universalist

  • Active Members
  • PipPipPipPipPipPip
  • 347 posts

Posted 17 January 2005 - 01:51 PM

Also... is it right that the "Open This Script" feature only opens in notepad as opposed to in the default editor?

#49 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,630 posts

Posted 17 January 2005 - 03:51 PM

Updated:
- @UserProfileDir fix
- Installer file associations tweaked
- You get an error if you try and use an undefined function for GuiSetOnEvents

#50 Jos

Jos

    Je maintiendrai

  • Developers
  • 23,305 posts

Posted 17 January 2005 - 05:40 PM

Also... is it right that the "Open This Script" feature only opens in notepad as opposed to in the default editor?

<{POST_SNAPBACK}>

The new helpfile opens the example file with the program that is associated with the extension .AU3 action "Open" .
The default with the AutoIt3 installer has been set to Notepad and the next release of the SciTE installer will associate SciTE.exe to "Open".

Visit the SciTE4AutoIt3 Download page for the latest versions                                                                 Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)


#51 edy

edy

    Wayfarer

  • Active Members
  • Pip
  • 58 posts

Posted 18 January 2005 - 07:50 AM

When i click in the button "open this script" nothing happen, why?
I have installed the last autoit-v3.0.103.exe.

Thanks

#52 CyberSlug

CyberSlug

    Overwhelmed with work....

  • MVPs
  • 3,587 posts

Posted 18 January 2005 - 01:25 PM

When i click in the button  "open this script" nothing happen, why?
I have installed the last  autoit-v3.0.103.exe.

Thanks

<{POST_SNAPBACK}>

Did you launch the Help file diretly (i.e. from the Start Menu) or from SciTE?

You need to make a change to au3.properties as JdeB describes above in order for SciTE to work fully with the new help file....
Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

#53 edy

edy

    Wayfarer

  • Active Members
  • Pip
  • 58 posts

Posted 18 January 2005 - 03:27 PM

Did you launch the Help file diretly (i.e. from the Start Menu) or from SciTE?

You need to make a change to au3.properties as JdeB describes above in order for SciTE to work fully with the new help file....

<{POST_SNAPBACK}>

with both methods do not work.

Bye

#54 bshoenhair

bshoenhair

    Universalist

  • Active Members
  • PipPipPipPipPipPip
  • 307 posts

Posted 18 January 2005 - 03:59 PM

When i click in the button  "open this script" nothing happen, why?
I have installed the last  autoit-v3.0.103.exe.

Thanks

<{POST_SNAPBACK}>

Same here, not working.

#55 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,630 posts

Posted 18 January 2005 - 05:14 PM

Updated:

- Misc docs typos
- Misc UDF fixes
- New GUI sample in the docs from CyberSlug (the one that shows all the controls)
- Better extended-ASCII support for the Send() function - previously some extended characters were missing.

(JP, can you please check the Send stuff and also my work around the diadic characters. It should attempt a diadic keystroke and only fall back to ALT+0nnn when the keyboard doesn't support it - like with english keyboards. Also could you check my changes to your key table are correct? :idiot: )

#56 Jos

Jos

    Je maintiendrai

  • Developers
  • 23,305 posts

Posted 18 January 2005 - 05:38 PM

with both methods  do not work.

<{POST_SNAPBACK}>

Same here, not working.

<{POST_SNAPBACK}>

Ok we need more info to be able to check what is happening.
First... What is the error you get ? or are you getting nothing ?
If you get the error unable to open \examples\helpfile\functoinxys.au3 then:
- is the file in the Autoit3 examples directory ?
- did you start the helpfile from AutoIt3 directory?

EDIT: oh and also check what's associated with Au3 Open task by going in the file explorer/Tools/Folder options/FileTypes/AutoIt3 scripts.

Edited by JdeB, 18 January 2005 - 06:10 PM.

Visit the SciTE4AutoIt3 Download page for the latest versions                                                                 Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)


#57 Josbe

Josbe

    Infrequent ghost ☺

  • Active Members
  • PipPipPipPipPipPip
  • 1,585 posts

Posted 18 January 2005 - 07:05 PM

@JdeB: Very nice job.(examples with syntax colored) :idiot:

Sorry, but I have the problem with button...This appears like a missing/unknown OBJECT. :D
What I need to do? (OS: Win2000)

BTW: I did like the description what you said above too.(au3 props., etc)

#58 Jos

Jos

    Je maintiendrai

  • Developers
  • 23,305 posts

Posted 18 January 2005 - 07:20 PM

@JdeB: Very nice job.(examples with syntax colored)  :idiot:

Sorry, but I have the problem with button...This appears like a missing/unknown OBJECT.  :D
What I need to do? (OS: Win2000)

BTW: I did like the description what you said above too.(au3 props., etc)

<{POST_SNAPBACK}>

The function we use is an OCX called hhctrl.ocx and the HTML code looks like:
<OBJECT id=hhctrl type="application/x-oleobject" classid="clsid:adb880a6-d8ff-11cf-9377-00aa003b7a11" width=58 height=57> <PARAM name="Command" value="ShortCut"> <PARAM name="Button" value="Text:Open this Script"> <PARAM name="Item1" value=",examples/helpfile/RegDelete.au3,">

Do you know if you have this ocx on you pc ? (should be located in system or system32.)

Visit the SciTE4AutoIt3 Download page for the latest versions                                                                 Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)


#59 CyberSlug

CyberSlug

    Overwhelmed with work....

  • MVPs
  • 3,587 posts

Posted 18 January 2005 - 07:34 PM

Hmm, I just ran the latest AutoIt installer on Windows 2000 SP4.

The "Open this Script" button did not start working until I closed and opened the help file a few times :idiot:
Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

#60 Josbe

Josbe

    Infrequent ghost ☺

  • Active Members
  • PipPipPipPipPipPip
  • 1,585 posts

Posted 18 January 2005 - 07:35 PM

The function we use is an OCX called hhctrl.ocx  and the HTML code looks like:

<OBJECT id=hhctrl type="application/x-oleobject" classid="clsid:adb880a6-d8ff-11cf-9377-00aa003b7a11" width=58 height=57> <PARAM name="Command" value="ShortCut"> <PARAM name="Button" value="Text:Open this Script"> <PARAM name="Item1" value=",examples/helpfile/RegDelete.au3,">

Do you know if you have this ocx on you pc ? (should be located in system or system32.)

<{POST_SNAPBACK}>

Yes. [version file(hhctrl.ocx): 5.2.3735.1]




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users