Jump to content

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Find out more here. X
X


Photo

MustDeclareVars


  • Please log in to reply
2 replies to this topic

#1 CyberSlug

CyberSlug

    Overwhelmed with work....

  • MVPs
  • 3,587 posts

Posted 23 January 2005 - 06:20 AM

Not really a bug, but seems related to http://www.autoitscript.com/forum/index.ph...wtopic=7606&hl=

What *should* the following code do? The current behavior make sense but is odd at first glance.
Opt("MustDeclareVars", 1) Dim $x = $x = $x MsgBox(4096,"Interesting", $x)

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!







#2 Jon

Jon

    Up all night to get lucky

  • Administrators
  • 10,420 posts

Posted 23 January 2005 - 11:09 AM

Not really a bug, but seems related to http://www.autoitscript.com/forum/index.ph...wtopic=7606&hl=

What *should* the following code do?  The current behavior make sense but is odd at first glance.

Opt("MustDeclareVars", 1) Dim $x = $x = $x MsgBox(4096,"Interesting", $x)

<{POST_SNAPBACK}>

It should fail. I'll put in in Open for next version to be fixed.

#3 Nutster

Nutster

    Developer at Large

  • Developers
  • 1,450 posts

Posted 23 June 2005 - 04:29 PM

Fix has been submitted to JP for this.

David Nuttall

Nuttall Computer Consulting

An Aquarius born during the Age of Aquarius
AutoIt allows me to re-invent the wheel so much faster.

I'm off to write a wizard, a wonderful wizard of odd...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users