Jump to content

All Activity

This stream auto-updates

  1. Today
  2. I found that the string disappears even when it is written on the GUI itself. You can confirm this phenomenon by running the Example code as it is, minimizing the GUI and restoring it back. In fact this phenomenon happens in other GDIPlus exammples for images as well. Could it be an error in GDIPlus UDF? Or is it only me experiencing this?
  3. Thanks for that, but it seems it doesn't work. I have put it under the includes and it doesn't even start the script.
  4. You shouldn't need to uninstall, but you can, I normally save any custom UDFs I have downloaded (I store mine in C:\Program Files (x86)\AutoIt3\Include) and then copy them back after installing a new package.
  5. Do I need to uninstall everything or will the latest version just over write everything?
  6. I dont know how "Solution" got turned on, not solved.
  7. ScITE4AutoIt3.exe is the full AutoIt Scite Editor, albeit old. I'm running the latest version of AutoIt and Scite4AutoIt on Windows 11 without any issue, unsure how if the older versions are compatible.
  8. I ran v14.801.2025.0-SciTE4AutoIt3.exe and ran autoit-3-3-8-1-en-win.exe on my win 11 laptop. I found these files stored away on my win 7 laptop. Would this be the full install?
  9. Did you install the Full AutoIt Scite Editor? AutoIt Script Editor Downloads - AutoIt
  10. Good evening, @Danp2 Console Output >"C:\Program Files (x86)\AutoIt3\SciTE\..\AutoIt3.exe" "C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.au3" /run /prod /ErrorStdOut /in "C:\Users\thomas.bennett\{Privacy}\Knowledge\AutoIt\Please Note!\ignore.au3" /UserParams +>21:02:58 Starting AutoIt3Wrapper (21.316.1639.1) from:SciTE.exe (4.4.6.0) Keyboard:00000409 OS:WIN_10/2009 CPU:X64 OS:X64 Environment(Language:0409) CodePage:0 utf8.auto.check:4 +> SciTEDir => C:\Program Files (x86)\AutoIt3\SciTE UserDir =>
  11. I have been using Autoit 3.3.8.1 and Scite 3.2.0 on a win 7 laptop since 2013 I just got a new laptop running Win 11 and it seems that Scite has abnormalities on my Win 11 laptop. When I start typing an existing Variable, no drop down list appears of all variables that match what I have typed so far. I am wondering if Autoit is compatible as well. Thanks for your help
  12. I tweaked your script, but it works as expected for me. Here's the revised code -- #cs ---------------------------------------------------------------- Name ..........: ignore.au3 Description ...: Testing _WD_HighlightElements SciTE 32-bit ..: Version 4.4.6 Author(s) .....: Thomas E. Bennett Date ..........: 20220929 Recommended Reading / Requirements https://www.autoitscript.com/forum/topic/191990-webdriver-udf-w3c-compliant-version-01162021/#comments https://www.autoitscript.com/wiki/WebDriver https://www.autoitscript.com/wiki/WebDriver#Installation https://www.autoitscript.
  13. Yesterday
  14. I played around with your script and found that after part #238, the script seems to lock up. I didn't see anything weird about #239 and deleting it didn't fix the problem. I'm a bit too tired to dig any deeper. I only changed the line "For $i = 0 To $oNodes.Length - 1" to "For $i = 0 To 238 ; #239 locks up the script" and added an arraydisplay right before the return. Sorry I can't be any more help tonight, but I hope it helps you troubleshoot. #include <MsgBoxConstants.au3> #include <XML.au3> #include <Array.au3> $filexml = @WorkingDir & "\test02.x
  15. #cs ---------------------------------------------------------------- Name ..........: ignore.au3 Description ...: Testing _WD_HighlightElements SciTE 32-bit ..: Version 4.4.6 Author(s) .....: Thomas E. Bennett Date ..........: 20220929 Recommended Reading / Requirements https://www.autoitscript.com/forum/topic/191990-webdriver-udf-w3c-compliant-version-01162021/#comments https://www.autoitscript.com/wiki/WebDriver https://www.autoitscript.com/wiki/WebDriver#Installation https://www.autoitscript.com/wiki/Adding_UDFs_to_AutoIt_and_SciTE https://www.autoitscript.com/autoit3/docs/intr
  16. Improved: don't need to specify how many dimensions: #include <Array.au3> Example() Func Example() Local $arr[20][20][2] = [[[12, 0], [2, 0], [7, "3d pos 0,2,1"], [8, 0], [9, 0], [5, 1], [10, 5], [9, 6], [8, 7], [7, 8], [6, 9], [6, 10], [7, 10], [8, 10], [9, 10], [10, 10], [11, 10]]] Local $hmm[20][2] = [[12, 0], [2, 0], [7, "2d pos 2,1"], [8, 0], [9, 0], [5, 1], [10, 5], [9, 6], [8, 7], [7, 8], [6, 9], [6, 10], [7, 10], [8, 10], [9, 10], [10, 10], [11, 10]] wtf($arr) ; passes $arr to function wtf($hmm) ; passes $hmm to function EndFunc Func w
  17. Actually, you are passing a multi-dimensional array to the function. One of your problems is in one call of the wtf function, you are passing a 3d array and the next, you are passing a 2d array. To fix the problem of one function reading arrays with different amount of dimensions, I added a 2nd parameter for how many dimensions. Without something like this, you will always get an error that the array is out of bounds. In both examples, I am reading the same array position with a msgbox, but from different arrays. The arrays are referenced in order of z,y,x axis. In the 2d array, the
  18. Wonderful UDF how do interface with StatusBar , I got it to work but is scrolls with everything.
  19. Google doesnt allow it, you'll have to get a google API key and use their tools. You'll probably be met with a 503 error and a Captcha if you use it too much. /edit I completely missed the point of the thread, your example caught me attention first and instantly i posted my reply above. 😛
  20. Moved to the appropriate AutoIt General Help and Support forum, as the Developer General Discussion forum very clearly states: Moderation Team
  21. I was just curious to see if OpenAI knows AutoIt and apparently it does! Input: Write code for AutoIt to open Internet Explorer using IE.au3 and navigate to google.com. Do a search for dogs and submit the form. Format the code. Output: #include <IE.au3> $oIE = _IECreate("http://www.google.com") _IESubmit($oIE) _IEQuit($oIE) I tried something a little more complex: write code for AutoIt to open FireFox using WebDriver and start on google.com. Do a search for dogs and submit the form. Then export all urls into a text file called url.txt Forma
  22. I remove this from the code as is not worked and yes I know how to tag the code today I forget to tag the code Iam so sorry, but is that anybody here than can help me how to do and give me example on add and how save?
  23. I can see nothing about this in your code. What did you try ? Where are the inputs to enter names and emails, buttons, and so on ? BTW since 2007 you still don't know how to use the <code> tag ?
  24. Maybe write a loop to paste values from the clipboard?
  25. I have several XML files that I need to load into the arrays. My code loads them, but the time is far too long in my opinion. It should be instant and it takes a few seconds for each file. Example xml attached. How to make it faster? #include <MsgBoxConstants.au3> #include <XML.au3> #include <Array.au3> $filexml = @WorkingDir & "\test02.xml" _ReadPartXML($filexml) Func _ReadPartXML($sMainXmlPath) $tTimer = TimerInit() $XML_FILE = $sMainXmlPath Local $oXmlDoc, $oNodes, $oNode Local $iPECount Enum $MPart_pid, $MPart_OAT, $M
  26. ..just in case. Y' know, "make it until you brake it" is my motto. I have a wheel mouse and I tend to spin it. Is a metal one so it rotates on its own and the momentum brakes the code. So I added If then to save the code from random OMG, wtf moments
  27. Hi everybody I need some help I can not figure it out how fix to add a new user into this listwiev and also a save button to save the new info to the test.txt file? Please if anybody could help me with this. Please see the attaced files. ; AutoIt 3.3.12.0 #include <GUIConstantsEx.au3> #include <GuiListView.au3> #include <MsgBoxConstants.au3> #include <StringConstants.au3> GUICreate("Listwiew", 300, 230) Local $idSelBtn = GUICtrlCreateButton('Select', 10, 05, 40, 20) Local $idListview = GUICtrlCreateListView("Name|Lo
  1. Load more activity
×
×
  • Create New...