All Activity

This stream auto-updates   

  1. Past hour
  2. I can't find anything on the forums through the search bar. However it is strange to me that it works in my test code but when the same exact values go into my real code is when I experience issues. When I check the values they all show up how they should, but when I divide $var3/$var2 in my actual code I get something ridiculous.
  3. Earthshine, Despite the OP's rather insulting classification of forum members as "nerds" we should still remain polite. Please refrain from adding posts such as the one above which says more about you than the OP. M23
  4. Today
  5. MsgBox( $MB_SYSTEMMODAL, "", "$var3/$var2: " + $var3/$var2 ) ;Shows 253 I typed this line incorrectly in my test code. However, I ended up restarting Scite and it started working... Not sure why it was giving me 253 for 250/100.
  6. Tumble, Welcome to the AutoIt forums. It looks like you have fallen foul of the "floating point maths" problem - it affects all computers and is not an AutoIt problem per se. Search the forum and you will find many instances of people running into the same problem - and how to solve it. M23
  7. ROBOCOPY is where anything copy is at
  8. m4rcin93, Try opening the files before playing them - this works for me: #include <Array.au3> #include <Sound.au3> $aFile = FileReadToArray("file.txt") ; Add another column _ArrayColInsert($aFile, 1) For $x = 0 To Ubound($aFile) - 1 ; Open each file before playing and store the ID $aFile[$x][1] = _SoundOpen($aFile[$x][0]) ; Now play the file _Soundplay($aFile[$x][1], 0) Sleep(1000) Next ; Close the files when terminated $iStopped = 0 Do For $x = 0 To UBound($aFile) - 1 ; Check if track ended and not already closed If ($aFile[$x][1] <> 1) And (_SoundStatus($aFile[$x][1]) = "stopped") Then ; Close the file _SoundClose($aFile[$x][1]) ; Set the flag to indicate this $iStopped += 1 EndIf Next ; Save the CPU Sleep(1000) Until $iStopped = 3 M23
  9. #include <MsgBoxConstants.au3> $var1 = 250000 $var2 = $var1 / 2500 $var3 = 250 MsgBox( $MB_SYSTEMMODAL, "", "$var1: " + $var1 ) ;Shows 250000 MsgBox( $MB_SYSTEMMODAL, "", "$var2: " + $var2 ) ;Shows 100 MsgBox( $MB_SYSTEMMODAL, "", "$var3: " + $var3 ) ;Shows 250 MsgBox( $MB_SYSTEMMODAL, "", "$var3/$var2: " + $var2/$var2 ) ;Shows 1 Here is my code snippet that is acting up. For some reason the variables go in correctly, but they don't come out correctly. Basically my program gets a value from a website, then tries to divide it by another value it gets from that website, and then finally divide it by a number from a database. All of my test values come from the website and my database just fine, it's just this little part of the code. From some reason my code is showing my $var3/$var2 = 1 where it should give me 2.5. Can anyone explain to me why this is happening? It happens both in my actual code and in this little test snippet.
  10. Hello. I want to add playlist to my MP3 Player. To array i added 3 songs, i wanted to when first song finished, start 2nd song but it doesn't work. It's works only with _soundplay($aaa, 1) - with flag 1, i want do it with flag 0. How to do it? $file = FileReadToArray("file.txt") For $x = 0 To Ubound($file) -1 $test = _Soundplay($file[$x],0) Next
  11. GordonShumway, Try this Beta version and see if it meets your use case: ExtMsgBox_Test.au3 Negative values for timeouts are automatically set to 0 = no timeout Numeric countdown request in $vIcon, but no timeout = no icon and no error M23
  12. iamtheky, A very interesting point - and one I think is certainly worth a thread of its own in "Developer General Discussion". My personal view is that as AutoIt should make life easier for the less-experienced coder, we should have a fair amount of parameter error-checking to help them out as much as possible - as long as that does not impact too much on the UDF performance. Given the overall "speed" of AutoIt, I feel that an initial check for "sensible" parameter values is a sensible addition for UDF authors to make. In this particular case I was not expecting a negative value to be used for the timeout as it makes no sense whatsoever to do so - but a single If statement is not that onerous to add as a safety net. M23
  13. I have no idea if xcopy has any limitations. What I said was based purely on the trouble I would need to go to, to equal what TeraCopy does easily. It is probably a case of try-and-see to really appreciate the full benefit of TeraCopy. When I first started using it a few years ago, it blew me away, and is hands down one of the better programs to see light of day in the last decade, in the improvements it gives to users, especially over regular Windows copy and move. A short and nowhere near total list of benefits (available in free version). Pause & Resume. Skips problem files, but gives you a report that explains why and allows you to try again. CRC testing. Which also allows you to skip identical files and reporting which ones they were, etc. You can keep on adding files for the same destination, while the process is under way. You can start a job and then queue up others, if alternate destinations ... or run all simultaneously. Shutdown PC when finished. etc etc P.S. In short I see no need to re-invent the wheel, especially when that would take considerable effort and some likely obstacles to overcome.
  14. Faq 31 will give you most directions on how to deal with different gui and spying tools to help Iuiautomation works fast on most browsers ie,edge,opera,chrome,ff,safari and windows controls without any need to install drivers per browser which is required for webdriver solutions.
  15. will you test a version that has zero checks of the parameters -vs- this latest with it's one bajillionth safety net added? larger existential question being.....are there UDFs where the penalties in self-imposed checks are measurable and an unsafe version might have a reasonable use case with sanitized input?
  16. I was also unable to duplicate the behavior on Windows 7 or Windows 10. Scrolling up and down quickly and then changing to another window did not produce any discernible slowness.
  17. Referring to following coding, I try to understand some highlighted issues as shown below. Please see below image for error message Do you have any suggestions? Thanks, to everyone very much for any suggestions (^v^) =========================================================================================== #include <Array.au3> #include <IE.au3> Local $sHomePath = "https://world.taobao.com/" Local $oIE = _IECreate($sHomePath, 1) _IELoadWait($oIE) Sleep(3000) Local $oLinks = _IETagNameGetCollection($oIE, "a") For $oLink In $oLinks If $oLink.ClassName = "item-con" Then _IEAction($oLink, "Focus") Description : Causes the element to receive focus. I would like to know on what receiving focus do, does it trigger any Javascripts / AJAX on web page? $sStatusMsg = $oIE.StatusText I cannot find any reference for .StatusText, could you please describe more on what statusText do under AutoIT? ExitLoop EndIf Next $sHomeAddress = StringLeft($sStatusMsg, StringInStr($sStatusMsg, "?") -1) $sSiteParams = StringReplace($sStatusMsg, $sHomeAddress & "?", "") $aSiteParams = StringSplit($sSiteParams, "&") MsgBox(0, "", "Site Address: " & $sHomeAddress & @CRLF & "Site Params: " & $sSiteParams) _ArrayDisplay($aSiteParams)
  18. Thank you for your answer, I'll try that but the synthax with the & $dircp seems correct right?
  19. The bug appears to be in your code snippet. I seriously doubt that prior to 3.3.14.0 you would not have gotten the same error. Your Open method requests Async mode. If you change it to Synchronous mode, it works just fine. Global $oHttp = ObjCreate("WinHttp.WinHttpRequest.5.1") $oHttp.Open("GET", "https://www.google.com", False) $oHttp.Send() ConsoleWrite(BinaryToString($oHttp.ResponseBody, 4))
  20. AutoIT3 is installed under C:\Program Files (x86)\AutoIt3, and I have searched C:\ drive, IEbyXpath.au3 is not existed at all. My scripts are saved under D:\ drive I already updated with latest version, should IEbyXpath.au3 be included within its own library under C:\Program Files (x86)\AutoIt3 directory ? Do you have any suggestions on where to get this file? Thank you very much for any suggestions (^v^)
  21. Do you have the IEbyXpath.au3 in the same folder as your script?
  22. Didn't realise there were multiple urls try the following: #include <Array.au3> #include <IE.au3> Local $sHomePath = "https://world.taobao.com/" Local $oIE = _IECreate($sHomePath, 1) _IELoadWait($oIE) Sleep(3000) Local $oLinks = _IETagNameGetCollection($oIE, "a") For $oLink In $oLinks If $oLink.ClassName = "item-con" Then _IEAction($oLink, "Focus") $sStatusMsg = $oIE.StatusText ExitLoop EndIf Next $sHomeAddress = StringLeft($sStatusMsg, StringInStr($sStatusMsg, "?") -1) $sSiteParams = StringReplace($sStatusMsg, $sHomeAddress & "?", "") $aSiteParams = StringSplit($sSiteParams, "&") MsgBox(0, "", "Site Address: " & $sHomeAddress & @CRLF & "Site Params: " & $sSiteParams) _ArrayDisplay($aSiteParams)
  23. #include <IE.au3> $sData = ClipGet() $oIE=_IECreate("https://efps.gujarat.gov.in/webBillingApp2/BillDetails/eFPSBill", 1) _IELoadWait($oIE) $oObj = _IEGetObjByName($oIE,"userRationCard") _IEPropertySet($oObj,"innertext",$sData) $oObj = _IEGetObjById($oIE,"btnrationnext") _IEAction($oObj,"click") ;~ You can use _IELoadWait or Sleep to wait for the page to load _IELoadWait($oIE) Sleep(5000) ;"https://efps.gujarat.gov.in/webBillingApp2/BillDetails/ValidateRationCardDetails" -This is website for waiting full loaded. $oObj = _IEGetObjById($oIE,"btnmemberselect") _IEAction($oObj,"click") Exit
  24. How Can i use this ? My Full Code is : #include <IE.au3> $sData = ClipGet() $oIE=_IECreate("https://efps.gujarat.gov.in/webBillingApp2/BillDetails/eFPSBill", 1) $oObj = _IEGetObjByName($oIE,"userRationCard") _IEPropertySet($oObj,"innertext",$sData) $oObj = _IEGetObjById($oIE,"btnrationnext") _IEAction($oObj,"click") ;"https://efps.gujarat.gov.in/webBillingApp2/BillDetails/ValidateRationCardDetails" -This is website for waiting full loaded. $oObj = _IEGetObjById($oIE,"btnmemberselect") _IEAction($oObj,"click") Exit
  25. If its opening in the same page then you can still use the $oIE object so after _IEAction($oObj, "Click") just add another _IELoadWait or Add a Sleep(5000) function.
  1. Load more activity