All Activity

This stream auto-updates   

  1. Past hour
  2. it should not crash !!! But really, the same browser in android surely uses less memory, so, wassup with that !. I have 32 gb on this PC, but in a new, 8 gb pc or lappy, the swapping to disk, slows the fastest CPU. Still, I use chrome w/AdBlock. No anti-virus. If I had to use IE ( for an ActiveX in a business app. ), I'd need a good anti-virus, so also, for the integration w/gmail in the google world, chrome is the way ( for me ) For netflix and xfinity cable TV, I use Opera v49.0 . xfinity don't wanna run in chrome
  3. Today
  4. It's just stating it was a clean exit...exit code 0 is default. Add a consolewrite in your _terminate function, and another at the bottom of the script...with diff text, so you can see exactly where it's exiting.
  5. same thing made it to 139.5 and timed out, happened twice now, any ideas what error std out means?
  6. appreciate the response, i changed the the hotkey for exit, its just so strange. ill try that and let you know
  7. I have to imagine whatever else you are doing while this script is running is sending or warranting that the user press ESC or ctrl+break (since this script doesnt end, or do anything but make stuff available... and ran for the last 5 minutes I was watching football). >Exit code: 0 Time: 328.4 And tray icon artifacts are a windows problem, not an autoit problem. I'd guess you are magically refreshing that control with a mouseover.
  8. HotKeySet("{1}","_C1") HotKeySet("{4}","_C2") HotKeySet("{3}","_C3") HotKeySet("{2}","_C4") HotKeySet("{esc}", "_Terminate") Func _C1() MouseClick("right",885,186,1,1) Sleep(100) MouseClick("left",868,289,1,1) sleep(200) MouseClick("left",994,112,1,1) EndFunc Func _C2() MouseClick("left",1601,839,1,1) EndFunc Func _c3() MouseClick("left",1676,1048,1,1) ;Sleep(200) ;MouseClick("left",1586,903,1,1) sleep(200) EndFunc Func _c4() MouseClick("right",1598,833,1,1) Sleep(200) MouseClick("left",1608,933,1,1) sleep(200) EndFunc Func _Terminate() Exit EndFunc While 1 Sleep(1000) WEnd that is my code and its extremely simple, however it will shut itself down at time 117.4 and the rogue tray icon will be there until i move my cursor above it and then it disappears. this is in the bottom >"E:\AutoIt3\SciTE\..\AutoIt3.exe" "E:\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.au3" /run /prod /ErrorStdOut /in "C:\Users\Jeff\Desktop\Au3\project.au3" /UserParams +>21:10:18 Starting AutoIt3Wrapper v.17.224.935.0 SciTE v. Keyboard:00000409 OS:WIN_10/ CPU:X64 OS:X64 Environment(Language:0409) CodePage:0 +> SciTEDir => E:\AutoIt3\SciTE UserDir => C:\Users\Jeff\AppData\Local\AutoIt v3\SciTE\AutoIt3Wrapper SCITE_USERHOME => C:\Users\Jeff\AppData\Local\AutoIt v3\SciTE >Running AU3Check ( from:E:\AutoIt3 input:C:\Users\Jeff\Desktop\Au3\project.au3 +>21:10:18 AU3Check ended.rc:0 >Running:(\AutoIt3\autoit3.exe "C:\Users\Jeff\Desktop\Au3\project.au3" --> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop >Exit code: 0 Time: 117.4
  9. Correction: I've tried the simplespy script locally and it works fine, but I don't have easy access to the target app/controls I want to get at. I have to physically drive to another location and try it on-site, so I'm trying to do as much homework as I can to ensure the trips are worth it, if that makes sense.
  10. So, I've done a lot of reading. And I've started playing with the IUIAotmation scripts. I will try the `simplespy` script and see if I can target those controls using the UIAutomation integration. If there are any other tools that would be useful for introspecting windows apps / components, I'd love to hear about them -- most of the links posted in here are broken or dead, so it is a long haul to try to get updated information.
  11. Yesterday
  12. I was showing the error in the code. UTC vs. local time. Just use post #6 and forget the WMIC stuff. post #6 does not care about the time zone.
  13. Im trying to create a bot for a game and I wrote everything perfect. Now at the very end of the script, I wrote WEnd but underneath when I test compiled the script it says missing EndIF. Underneath is the end of the script. $pix = PixelSearch(1185,313,1327,340,0x98969A,5) if not (@error) then MouseClick("left", 1259,323,1,1) sleep(3000) MouseClick("left",1029,602,1,1) sleep(1000) MouseClick("left",1157,672,1,1) sleep(1000) EndIf MouseClick("left",1323,109,1,1) sleep(4000) WEnd
  14. let me clear this up. the msgbox is empty in the above example,does not return anything I'm clueless because when I use ping in place of net stop wuauserv It can read info from the stream.
  15. Perhaps try _Date_Time_GetTimeZoneInformation to find that out, see the help file.
  16. Can we get the above sample set for both IST and UTC time? so it detects the time zone and then get zone date?
  17. So, being in IST, that means that at midnight, _Date_Time_GetSystemTime will return 6:30pm, because you're 5.5 hours ahead of UTC time. You have to take that into account because _Date_Time_GetSystemTime works with UTC time and not local time.
  18. consolewrite all variables and nowcalc(), show results of this please such that we can all play along at home Func DaysSinceBoot() ; by argumentum ; Local $ret = _WinAPI_GetTickCount() consolewrite($ret & @CRLF) If @error Then Return SetError(1, 0, -1) Local $uptime = Int($ret / 1000) ; seconds since boot consolewrite($uptime & @CRLF) Local $bootDate = StringLeft(_DateAdd("s", $uptime, _NowCalc()), 10) ; boot date consolewrite(_NowCalc() & @CRLF) consolewrite($bootDate & @CRLF) Local $bootDays = _DateDiff("D", StringLeft(_NowCalc(), 10), $bootDate) ; days since midnight consolewrite($bootDays & @CRLF) Return SetError(0, $uptime, $bootDays) EndFunc ;==>DaysSinceBoot
  19. I ran into a problem as the title says. #include <AutoItConstants.au3> $Run = Run("cmd.exe" & " /c " & "net stop wuauserv",@SystemDir,@SW_HIDE,$STDOUT_CHILD) ProcessWaitClose($Run) $Output = StdoutRead($Run) MsgBox(0,'',$Output)
  20. What time zone are you in?
  21. Not using the code above. Once the loop starts you are not processing messages. Can you explain this further. Still unclear what you want to do. kylomas
  22. I did not tried your 2nd sample prior 12AM but only after 12AM and it is still doing the same.
  23. @argumentum, I tried with the 1st sample first and on my multiple machines. Prior 12AM the message was correct as usual. But After 12 AM, it still says, "System was booted up today." Attaching the 4 snapshots below This is correct... Msg 1.jpg = Prior 12AM (11/20/2017) Msg 2.jpg = Prior 12AM. This should have shown as: $TodayDate1 > 11/21/2017 (This is the issue) Msg 3.jpg = After 12AM (11/21/2017) Msg 4.jpg = This should have given "System was booted up yesterday."
  24. Hello, I'm trying to write a script to automate part of what appears to be a Winforms app. At least when I use AutoIT Info and drop the finder on it, it lists the Window's class as: The bizarre thing is some of the controls don't seem to be targetable. See the screen shot attached with what appears to show a WinForms GroupBox with the title "Command Window". Inside the group box it appears to have a Label, and TextBox, and a Button. Using the AutoIT Info Finder, I'm not able to individually address the inner components. I can only seem to target the GroupBox. Attached are the results of the Finder/Control window. Notice that it shows the control has class SWHGRP, in Advanced Mode: [CLASS:SWHGRP;INSTANCE:1]. My assumption here, though is that this is the GroupBox control. What I want to do is automate entering some text into the TextBox in there and then clicking the button. If this is just a standard Winforms app, it seems odd to me that these inner controls would not be targetable, but I'm pretty new to AutoIT (although certainly not new to software development). Using a standard mouse, I can certainly click in the TextBox, enter some text and click the button, so they are legit controls. Can someone help me understand why some controls like this appear to not be able to be targeted by the Finder? If I write my own script can I just enumerate all the children and see if I can find it that way? Is it worth trying to do this, or if the AutoIT Info Finder cannot address them, then that's likely definitive and I'm out of luck? Is it possible they may have some kind of 3rd party control embedded in there like a webview -- and this might be what is causing the issue?
  25. junkew, I think the problem here is that Invoke actually works. The Save button is clicked, the dialog box disappears, but the file is not be saved anyway.
  1. Load more activity