All Activity

This stream auto-updates   

  1. Past hour
  2. I expanded the example a bit to add Processor brand and to get the endianess right; apparently the bytes need reversed for autoit to display them properly.. I originally was passing arrays of bytes to the assembly code function to get Autoit to display the strings correctly. but I realized as I was looking through the returned values that the endian was reversed to what was shown on the Wiki page. Once I fixed that the strings were then reversed so I added a RevBinStr function to handle it In order to get the other values you'll need to pass your EAX value ($iLeaf) and check for set bits BitAND($aCPUID[?],1) or BitAND($aCPUID[?],2) .... BitAND($aCPUID[?],32)
  3. which function is use for wait webpage in IE? My code is like : #include <IE.au3> $sData = ClipGet() $oIE=_IECreate("https://abcd.com/efghi", 1) $oObj = _IEGetObjByName($oIE,"userno") _IEPropertySet($oObj,"innertext",$sData) $oObj = _IEGetObjById($oIE,"btnnext") _IEAction($oObj,"click") Then wait until "https://abcd.com/finish" is loaded then i want to use code like this : $oObj = _IEGetObjById($oIE,"btnselect") _IEAction($oObj,"click") Exit How can i do this ? please someone help
  4. Today
  5. qwert, That sounds like a definition of an Accelerator key - look at GUISetAccelerators in the Help file. M23
  6. PascalT, Welcome to the AutoIt forums. I have tried scrolling the GUI really quickly for a good time and I have no problems when I switch windows to any other one. Unless someone else can reproduce it, it looks like it might be a problem in your environment, sorry. M23 P.S. And a couple of points about your script: 1. It is much easier to declare those arrays in loops: #Region Array definition ; This array is normally filled with Software-Names thats why it is getting sorted later on Global $aSections[101] For $i = 1 To 100 $aSections[$i] = "Test" & $i Next Global $aAusnahmen[5] $aAusnahmen[0] = "Test20" $aAusnahmen[1] = "Test35" $aAusnahmen[2] = "Test54" $aAusnahmen[3] = "Test60" $aAusnahmen[4] = "Test70" Global $aZugewieseneSoftware[101] [2] For $i = 1 To 100 $aZugewieseneSoftware[$i] [0] = "Test" & $i $aZugewieseneSoftware[$i] [1] = Random(1, 1, 1) Next #EndRegion 2. And if you tell my UDF that you do not want a horizontal scrollbar, you do not get one: If $gHoehe >= 600 Then _GUiScrollBars_Generate($BWB_Softwareverwaltung, 0, $gHoehe) ;_GUiScrollBars_Generate($BWB_Softwareverwaltung, 870, $gHoehe) ;_GUIScrollBars_ShowScrollBar($BWB_Softwareverwaltung, $SB_HORZ, False) EndIf
  7. You need to go to the link @jdelaney posted above Copy the code from the first post into a new script and save it as IEbyXPath.au3 in the same location as your script. At the top of your script add: #include "IEbyXPath.au3" ...rest of your code goes here... The IEbyXPath includes the function BGe_IEGetDOMObjByXPathWithAttributes
  8. Change $oIE=_IECreate("https://acc.rollernet.us") To $oIE=_IECreate("https://acc.rollernet.us", 1)
  9. You can use something like: #include <Array.au3> #include <IE.au3> Local $sHomePath = "https://world.taobao.com/" Local $sMarketPath = "https://www.taobao.com/markets/tbhome/yhh-detail" Local $oIE = _IECreate($sHomePath, 1) _IELoadWait($oIE) Sleep(3000) Local $oLinks = _IELinkGetCollection($oIE) For $oLink In $oLinks If StringInStr($oLink.href, $sMarketPath) Then _IENavigate($oIE, $oLink.href) ExitLoop EndIf Next _IELoadWait($oIE) MsgBox(0,'', "Site address: " & $oIE.Document.Location.Origin & @CRLF & "Path name: " & $oIE.Document.Location.PathName) $aURL = StringSplit(StringReplace($oIE.Document.Location.Search, "?", ""), "&") _ArrayDisplay($aURL)
  10. x_bennY, That line tells AutoIt that the grouping of controls has ended. If you immediately begin another grouping using GUICtrlCreateGroup then it is not strictly necessary, but it does no harm - if you have no further groups then it is vital to include it. All clear? M23
  11. After DirCopy add a MsgBox with @error to determine the error. Also try to use pathname @ScriptDir & "\GuideOne" for your first parameter (assuming "GuideOne" is in the same folder as the script.
  12. Please see the attached image, an error is occurred on line 5312. Do you have any suggestions on what wrong it is? Thank you very much for any suggestions (^v^)
  13. Look at the _IEAction function in the help file, you can then click an item using the "click" action.
  14. Hi, I'd like to do simple copy of a directory reading an ini for the path. I'm pretty sure it's not a big deal but for a noob like me... Well I'm looking for a solution since 2 hours now #include <MsgBoxConstants.au3> $dircp = IniRead("path.ini", "Path", "path", " ERROR") MsgBox($MB_SYSTEMMODAL, "", "path is: : " & $dircp) DirCopy ("Guideone", $dircp) The value returned by iniread is correct, but the dircopy does nothing, Any idea?
  15. Autoit's wonderfull!!! if replace func name by short varian and can use Au3stripper /rm so i think it can do this!
  16. #include <IE.au3> $oIE=_IECreate("https://acc.rollernet.us") $oObj = _IEGetObjByName($oIE,"username") _IEPropertySet($oObj,"innertext","MyUserId") $oObj = _IEGetObjByName($oIE,"password") _IEPropertySet($oObj,"innertext","MyPassword") $oObj = _IEGetObjByName($oIE,"submit") _IEAction($oObj,"click") Exit i want to do the same but without open the "https://acc.rollernet.us" (the webpage is already opened and i want to fill the username and pass in the form direclty)
  17. I get an error when I run the execute file, please see attached image Do you have any suggestions on what wrong it is? Thank you very much for any suggestions (^v^) I get the same problem for following code as well $sXpath = "//li[@class='sbsb_c gsfs')]//span[@class='sbpqs_a']"
  18. How to to fill this forum when webpage already opened ?
  19. When I insert the direct link into following code, there is no session added into URL, please see attached image The session would only be created and add into the URL link after a clicking action on home page. Ref : https://world.taobao.com/ Do you have any suggestions on how to trigger a click to simulate an Ajax web session? Thank you very much for any suggestions (^v^) #include <Array.au3> #include <IE.au3> Local $oIE = _IECreate("https://detail.tmall.hk/hk/item.htm?id=562971448286", 1) _IELoadWait($oIE) MsgBox(0,'', "Site address: " & $oIE.Document.Location.Origin & @CRLF & "Path name: " & $oIE.Document.Location.PathName) $aURL = StringSplit(StringReplace($oIE.Document.Location.Search, "?", ""), "&") _ArrayDisplay($aURL)
  20. solved, #RequireAdmin
  21. Local $oHttp = ObjCreate("WinHttp.WinHttpRequest.5.1") $oHttp.Open('GET', 'http://www.163.com', True) $oHttp.Send() ConsoleWrite(BinaryToString($oHttp.ResponseBody(), 4)) after 3.3.14.0 version,the error is exist。bug?
  22. facepalm thanks
  23. i am using 56.0.2 (64 Bit) version of FF. And MozRepl installed and activated on startup, _ffclick working but _ffloadwait and fill forum not working.
  24. Why Koda creates thoses strings? should i keep it in my script? GUICtrlCreateGroup("", -99, -99, 1, 1)
  25. Sorry, all it does is mouseclick and I mentioned that.
  26. which version work with autoit ?
  27. @LNGS How about posting your code so we can see what you're attempting, rather than asking us to guess? My crystal ball is in the shop.
  1. Load more activity