Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. Today
  3. Thanks so much for your time....I think this is going to work. Now just need to deploy it!
  4. So that doesn't create the issue... but if you change example #2 to this it works the way I'm seeing it... Global $sRecipient = InputBox("OutlookEX UDF: _OL_DistListMemberAdd Example Script","Please enter name of recipient to be added to the distribution list") Global $oOL_Recipient = _OL_ItemRecipientCheck($oOutlook, $sRecipient, Default, Default, Default, Default, Default, Default, Default, Default, Default, Default, True)[1][2] ;<-- Get the recipient object (assumes it works) $oItem = _OL_DistListMemberAdd($oOutlook, $aOL_Item[1][0], Default, $oOL_Recipient) If @error <> 0 Then Exit MsgBox(16, "OutlookEX UDF: _OL_DistListMemberAdd Example Script", "Error adding member to distribution list in folder 'Outlook-UDF-Test\SourceFolder\Contacts'. @error = " & @error & ", @extended = " & @extended) ; Display item $oItem.Display MsgBox(64, "OutlookEX UDF: _OL_DistListMemberAdd Example Script", "Member successfully added to distribution list!") _OL_Close($oOutlook) It appears to have something to do with _OL_ItemRecipientCheck combined with _OL_DistListMemberAdd Edit: I forgot, yes, the Outlook version I have is 1.4.0.0... the modified date says July 24, 2019 however. I'll redownload it just to be sure. Edit 2: Yup, still modified in July. I have the latest version
  5. Thanks a lot! I already can generate the html files from a UDF. So I just need to play with the tool you suggested and create the CHM. Great 😃
  6. Your if @error then is wrongly placed. The consoleWrite statement before removed the @error value coming from _IEAttach. While you are at it, you should console the value of $hWnd...
  7. am a noob and i made a little program to send commands to a device via usb by sending arguments to a command line tool am having trouble in two things 1- first sending what i type into the input box and inserting in the command in place of the word HELLO between ' ' when clicking on send button. 2- second clearing the input and receiving the output as text also and displaying it in the input box when clicking on receive button. ;the UI Global $cmd = GUICtrlCreateGroup("command sender", 13, 407, 340, 80) Global $instcmdsnd = GUICtrlCreateButton("setup", 25, 422, 100, 25) GUICtrlSetFont(-1, 8.5, 400, 0, "Segoe UI", 5) GUICtrlSetOnEvent(-1, "setcmd") Global $sendcmd = GUICtrlCreateButton("send", 133, 422, 100, 25) GUICtrlSetFont(-1, 8.5, 400, 0, "Segoe UI", 5) GUICtrlSetOnEvent(-1, "gocmd") Global $getcmd = GUICtrlCreateButton("receive", 242, 422, 100, 25) GUICtrlSetFont(-1, 8.5, 400, 0, "Segoe UI", 5) GUICtrlSetOnEvent(-1, "getcmd") Global $cmdInput = GUICtrlCreateInput("", 25, 455, 318, 22) ;the function Func setcmd() Run(@ComSpec & " /c c:\mytool\bin\commandsender.exe start ", @ScriptDir, @SW_HIDE, $stderr_child + $stdout_child) EndFunc Func gocmd() Run(@ComSpec & " /c c:\mytool\bin\commandsender.exe send -t 'HELLO' ", @ScriptDir, @SW_HIDE, $stderr_child + $stdout_child) EndFunc Func getcmd() Local $get = RunWait("c:\mytool\bin\response.bat", @ScriptDir, @SW_HIDE) EndFunc thanks in advance
  8. I create CHM file's with Precision Helper. It's pretty easy to use but you need a decent HTML editor for the pages of your manual/help file. I use BlueGriffon. Let me hear if you need more info but it's quite easy to set up. For every UDF I created a HTLM file. Of course I could have create an automatic HTML file creator tool which scans the UDF's to create HTLM pages but I didn't bother. Most UDF's have additional info like an example which need to be written. To my opinion every library and program need a manual, a CHM file and/or website. Precision Helper can also created the pages for a help manual website. For the images in my programs and in a manual I use Inkscape and the Gimp.
  9. Hi My automation has suddenly started hanging. Is there anything wrong I'm doing? Here's the console output and it's literally been hanging for 30 minutes (and it hangs at this point each time) >"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "H:\Quality Assurance\AutoIT Scripts\EliteClientInceptionAutomation\Framework\TestEnv.au3" Loading URL --> IE.au3 T3.0-2 Warning from function _IEAttach, $_IESTATUS_NoMatch Here's the code ConsoleWrite(@CRLF & "Loading URL ") Local $oIE = _IECreate($URL, 1) WinWait($ApplicationWindow, 10) ConsoleWrite(@CRLF & "Waiting for window") ;attach ie window Sleep(10000) ConsoleWrite(@CRLF & "Getting handle") $hWnd = WinGetHandle($ApplicationWindow) Sleep(5000) ConsoleWrite(@CRLF & "Activating Window") WinActivate($ApplicationWindow) $oIE = _IEAttach($hWnd, "hwnd") ConsoleWrite(@CRLF & "Attaching IEATTach for window") if @error then ConsoleWrite("Unable to attach IE window") MsgBox($MB_SYSTEMMODAL, "Error handling ", "Can't attach IE Window ", 4) EndIf if WinSetState($ApplicationWindow, "", @SW_MAXIMIZE) Then Else Sleep(6000) WinSetState($ApplicationWindow, "", @SW_MAXIMIZE) EndIf
  10. Assume you have Windows 10 1909 ISO? If you have a Microsoft Volume License Agreement you can download it from the Volume Licensing Center or use this method: https://www.bleepingcomputer.com/news/microsoft/how-to-download-the-windows-10-1909-iso-from-microsoft/ Unpack the ISO to a network share Create a script as above example: \\server\share\Winv1909x64\setup.exe /auto upgrade /quiet Follow the link above to find switches you wish to use, for example in our environment we usually perform a compatibility scan first to check for any issues and then perform the upgrade if the compatibility scan comes back successful. For more info just search for "Windows 10 upgrade command line". https://joshheffner.com/automate-windows-10-in-place-upgrades-from-the-command-line/ If your systems are Windows 10 1903 then you might not have to perform a full upgrade, as 1909 features are installed in 1903 versions in a "dormant" state, see https://techcommunity.microsoft.com/t5/windows-it-pro-blog/windows-10-version-1909-delivery-options/ba-p/1002660
  11. That is probably much easier, but with my novice status I am not sure where to begin. We do have a WSUS server, but for whatever reason it doesn't push out to our stations.
  12. Ty yes I was playing around with this a bit last night and came to the conclusion that I was declaring it out of scope? Declaring the static variable inside of the main must make it invisible to the compiler. I'm assuming declaring it outside of the main makes the variable global. At least that's my take on it. Tutorials often don't make fine details like this explicitly clear, well at least the ones I'm watching anyways.
  13. Why don't you just run the upgrade from the network? Example: setup /auto upgrade /quiet /compat scanonly /compat ignorewarning https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-setup-command-line-options
  14. I have just run the _OL_DistListMemberAdd.au3 example script. No equal signs! Could you please run the example script yourself? You are sure to run the lastest version of the OutlookEX UDF?
  15. Trying to setup a script to install this new Windows 10 update one 1000+ computers. And I almost have it!! The last command will not work and I can't for the life of me figure out why. Here is the command, it is attached. It Runs the program, Clicks the "Run" button, Program launches and then it supposed to click the "UPDATE NOW"(Pic2 attached) button in the next window. Which of course doesnt get it's own controlID, instead it is the whole window. But I get the coordinates from the Window Info Tool, but nothing. Not sure what I am doing wrong, or if there is a better way to do it. I also noticed you can TAB 4 times and press ENTER, so I tried doing that with the Send command, but no luck. Any help is appreciated. THANKS
  16. I think the problem is that you have given the focus to "Enter initial" and never got fully back. Maybe because the password is not sent correctly, (btw you should have a sleep between mouseclick and send). Anyway it is hard to say without a runable script that replicates your issue. Nevertheless, I was able to try something with notepad. It is not exactly your situation, but it is close and I lost control of the GUI, so I solved my problem this way : Local $hGUI = GUICreate ("Test") Local $idButton = GUICtrlCreateButton ("OK", 20,50,100,25) GUISetState () Local $c, $aPos, $bAttempted = False While 1 If Not $bAttempted And WinExists("[CLASS:Notepad]") Then Local $c = WinActivate("[CLASS:Notepad]") WinWaitActive($c) Sleep(200) If $c = 0 Then Exit MsgBox(0, 0, "error") Local $aPos = WinGetPos($c) If @error Then Exit MsgBox(0, 0, 0) ConsoleWrite(@CRLF & $aPos[0] & " " & $aPos[1] & " " & $aPos[2] & " " & @CRLF) MouseClick("Primary", $aPos[0] + 125, $aPos[1] + 125, 1, 1) Sleep (800) Send("password") Send("{Enter}") Sleep (2000) If WinExists ($c) Then ConsoleWrite ("Wrong password" & @CRLF) $bAttempted = True EndIf Switch GUIGetMsg() Case $idButton Exit EndSwitch WEnd ps. this is the way to debug a program. Make a smaller replicate of the problem and then it is easier to find solution.
  17. No, there is no leading equals sign there, which was what seemed strange to me... the recipient is resolved and everything looks good, but when I add the recipient to the distribution list, they are shown with a leading equals sign
  18. Had to do things my own way. Uninstalled AutoIT, which did not resolve the problem, but was able to open task manager and stop the running script manually by ending task. Problem solved, and back to sanity. Thanks for the input, everybody.
  19. @markyrocks You're issue is so you must define them like: class Myclass { public: static std::string str; }; std::string Myclass::str="Hello World"; int main() { std::cout << Myclass::str << "\n"; Myclass::str="Hola Mundo"; Myclass obj; std::cout << obj.str << "\n"; return 0; } Saludos
  20. Don't have 8 box, but I suppose your code must have a glitch. Do you enclose the code within double-quotes ? Make sure Num Lock is on. If that doesn't work, post a runable snippet of your code that replicates the problem...
  21. Guessing that the objects in $oButtons go out of scope once the button is clicked, which is easily solved by adding an ExitLoop after the click.
  22. My curiosity would push me to understand why this button is giving trouble. I would first set a counter to know which button is badly reacting. Understanding the DOM of this object would allow to skip it in some way. If you don't have that curiosity, just add a COM error handler.
  23. Yes. The wiki already shows how to utilize a custom profile. You can specify the Firefox binary in moz:firefoxOptions Not something that I've tested, but I imagine it should be possible. Give it a shot and let us know how it goes.
  24. Would be a good feature to use the icon declared as #AutoIt3Wrapper_Icon=. If you use a3x instead of an compiled autoit script you have some advantages: 1. false positive virus detection would be not exist expect from the autoit.exe interpreter file 2. if you have more than one autoit scripts on this pc (which has no autoit installed), you only have one autoit.exe. This is the logic behind the question I guess. And I just want to try out this method. Edit: A third launcher application (like c++) would execute the autoit3.exe with parameter (a3x file name).
  1. Load more activity
×
×
  • Create New...