Jump to content

Recommended Posts


My tool worked well yesterday, but it says "Variable must be of type "Object"" when I run it today, I didn't update it from yesterday to today.

error is:

_XMLDomWrapper.au3 (451) : ==> Variable must be of type "Object".:

$objNodeList = $objDoc.documentElement.selectNodes ($strXPath)

$objNodeList = $objDoc.documentElement^ ERROR


Link to post
Share on other sites

There are some undocumented functions in the UDF. Add _SetDebug(True) just before you open the file and run it from SciTE (writes to the console).

The error you got is from _XMLGetValue(). Opening the document creates $objDoc, and must have worked, or you wouldn't have gotten that far (it's checked before line 451). You'll have to see what happened to your XPath.


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...