Jump to content

Control Viewer - AutoIt Window Info Tool


Recommended Posts

Okay I downloaded this tool because autoit info and spy++ isnt working and control viewer worked perfectly on every program EXCEPT the one I intended to use it on. I am intrigued. Is it because there is some protection on that software that prevents control viewer and info/spy++ from getting information on the controls?

Link to post
Share on other sites
  • Replies 179
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

LAST VERSION - 1.1 18-May-12 Control Viewer (CV) is a replacement of AutoIt Window Info with a number of advantages. I tried to stick to the interface of the last, so you almost do not have to be ret

There you go  

I used @boomingranny's code and corrected/added handy stuff, like:   1) The file-version would not show compiled scripts   2) Added the command line to the listview   3) Added exit to tray on us

Posted Images

The most likely reason is that the program is implemented with modern control components which are not identifiable by these tools. Have you tried the "Simple Spy Tool" in the UI Automation framework or Inspect.exe from Windows SDK.

Link to post
Share on other sites
7 hours ago, LarsJ said:

The most likely reason is that the program is implemented with modern control components which are not identifiable by these tools. Have you tried the "Simple Spy Tool" in the UI Automation framework or Inspect.exe from Windows SDK.

Hi I just spent some time playing around with my company's computer and i believe the reason is because that said program is not on my desktop, rather its a program on the server side that allows me to use it through this thing call citrix connector, something like a cloud thing. Can i confirm that if the said program is launch to your desktop through a cloud connection Spy ++ , autoit info and control viewer would not be able to spot the controls? 

Link to post
Share on other sites

It cannot be excluded that this is the reason for the problems in your program. But in general you cannot make such a simple conclusion.

Without information about the program it's difficult to come up with anything other than general considerations.

Edited by LarsJ
Link to post
Share on other sites
  • 1 month later...
  • 4 weeks later...
  • 2 months later...
  • 3 months later...
  • 2 weeks later...
  • 4 weeks later...
  • 2 months later...
  • 1 month later...

Hi Yashied, or if anyone here can give me some pointers?

I've downloaded the Zip from Github, compiled built and trying to run but keep receiving the error:

CV.au3" (73) : ==> Can not redeclare a constant.:
Global Const $STM_SETIMAGE = 0x0172
Global Const ^ ERROR

Does anyone know how I can resolve this error?

 

Link to post
Share on other sites
1 hour ago, R3D4 said:

Hi Yashied, or if anyone here can give me some pointers?

I've downloaded the Zip from Github, compiled built and trying to run but keep receiving the error:

CV.au3" (73) : ==> Can not redeclare a constant.:
Global Const $STM_SETIMAGE = 0x0172
Global Const ^ ERROR

Does anyone know how I can resolve this error?

 

Just comment that line out by using the ";" char.

 

Edited by UEZ

Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Link to post
Share on other sites
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...