Jump to content
Sign in to follow this  
jaberwacky

SciTE Customization GUI -- [03/04/2017]

Recommended Posts

I believe there's something missing from this post. :oops:


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Doesn't work with a non-installed (portable) version of SciTe because it's reading from the registry instead of looking for the environment variable SCITE_Home first. I'll have to try it on my home computer to see how it works, I have it installed there, but can't test on my company computer because AutoIt isn't installed on it, using it from a thumb drive.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

I am fine with people creating more extensive SciTEConfig setups, but just as a pre-warning: I have been making quite some changes to SciTEConfig to avoid the need of updating au3.properties and all changes will now be saved into SciTEUSer.properties (where it belongs).

This all will ensure that whenever you upgrade the SciTE4AutoIt3 package, the updates made will stay and you don't require Admin level anymore to make the changes, except for the File Open setting change in the registry.

By the way: It is looking nice.

Jos :oops:

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I have been making quite some changes to SciTEConfig to avoid the need of updating au3.properties and all changes will now be saved into SciTEUSer.properties.

By the way: It is looking nice.

One step ahead of you.

Thanks!

@BrewmanNH, I'll see what I can do to address those issues.

Share this post


Link to post
Share on other sites

Awesome! only one problem :S

When I ran the compiled binary under SciTE4AutoIt3 (v2.28) and changed the tidy parameters default to white spaces instead of tab delimiters under SciTE , leaving all the defaults your script had and not touching anything else, I pressed update and got this.

Posted Image

Is this expected behavior?


Edit: Oh, never mind, I see what's going on now, I hadn't noticed its defaults are set to disable all the 3rd party tools, you just have to check them and click update, my bad! Edited by THAT1ANONYMOUSEDUDE

Share this post


Link to post
Share on other sites

I don't understand. If it's a bug I want to work on it for sure. It shouldn't disable any tools by default.

Doesn't seem like it, I had just assumed the tool would detect active tool entries and set them to checked under the tools tab, and when I updated the config, I wasn't expecting it to disable all the tools, but as I noticed, it doesn't seem to detect a users current tool configuration and you have to set it manually when first run as it seems. After first run It does detect what tools a user has after it sets them itself, I guess it has something to do with "SciteTools.ini", which came with the download which has all the tools disabled by default.

Works great btw.

Share this post


Link to post
Share on other sites

Ok, problem detected!

when I updated the configuration for what tools will appear in the "Tools" menu area, I disabled "Make UDF header", when I re-enable the tool selection, I get an error in the scite console.

C:Program FilesAutoIt3SciTELuaTools.lua:73: Tool "AutoItTools.InsertUDFHeader" not found.
>Lua: error occurred while processing command

Share this post


Link to post
Share on other sites

yep yep, even reinstalled scite a few times to see if it would do it again, and it did, I couldn't figure out what was happening though :/

Edit: Forgot to mention I'm using windows 7 x86 if it's of any relevance.

Edited by THAT1ANONYMOUSEDUDE

Share this post


Link to post
Share on other sites

It seems to work flawlessly on my system now, I see that you even have it detect what tools are active now as well? I'd say this is a very suitable contender for the current scite config tool distributed with the autoit installation, I wouldn't mind seeing this as a tool option under tools.

Feature Request: add an option to replace the current scite config tool, this thing is too robust in features not to consider doing so, wouldn't you say?

Sadly, I believe it hasn't gotten the attention it deserves, I would say jos should consider replacing the current scite config with this, I mean why not? It has everything it scite config has and more.

I'd also like to mention that you should consider making the gui resizable and wider instead of taller, it's not fitting into the screen on my laptop, which I use a lot and I can only see a portion of the contents in the gui unless I attach it to a monitor.

Share this post


Link to post
Share on other sites

It seems to work flawlessly on my system now, I see that you even have it detect what tools are active now as well? I'd say this is a very suitable contender for the current scite config tool distributed with the autoit installation, I wouldn't mind seeing this as a tool option under tools.

Feature Request: add an option to replace the current scite config tool, this thing is too robust in features not to consider doing so, wouldn't you say?

Sadly, I believe it hasn't gotten the attention it deserves, I would say jos should consider replacing the current scite config with this, I mean why not? It has everything it scite config has and more.

I'd also like to mention that you should consider making the gui resizable and wider instead of taller, it's not fitting into the screen on my laptop, which I use a lot and I can only see a portion of the contents in the gui unless I attach it to a monitor.

Thanks for the positive words!

I haven't done anything with the Tools stuff. Nice to know I don't have to now. LOL!

I wouldn't want to have to officially maintain this monster. Have you seen the source?

It used to be resizeable, so I guess I'll go back to that. It's should just be a matter of uncommenting a few lines.

Share this post


Link to post
Share on other sites

Thanks for the positive words!

I haven't done anything with the Tools stuff. Nice to know I don't have to now. LOL!

I wouldn't want to have to officially maintain this monster. Have you seen the source?

It used to be resizeable, so I guess I'll go back to that. It's should just be a matter of uncommenting a few lines.

Hmm, interesting...

I remember the last time I tried it, any modifications to the tools options would render the "Make UDF header" option inoperable, but it's not doing it anymore..

I've re-installed different versions of autoit since that time, so who knows what might be at play there.. And yeah, I saw the source, turned 360 degrees and walked away, I hate the objects syntax, it's confusing as hell!

Share this post


Link to post
Share on other sites

Played real quick, seem to have found some problems.

1) First two tabs, changing options does not enable the Update button.

2) First two tabs, reload does not refresh / reset the options.

3) Theme tab, not recognizing the current font.

Edit2:

#3 seems to be that you're not picking up both the base font and monospace font, and which is actually active.

It would also be nice to import user themes from the standard location, <scitedir>SciteConfig.

I'm running Win7 x64, SciTE v3.0.4.

Edit:

You should also check for user defined Tools in the user properties file (that's where I keep mine).

Edited by wraithdu

Share this post


Link to post
Share on other sites

1) First two tabs, changing options does not enable the Update button.

2) First two tabs, reload does not refresh / reset the options.

3) Theme tab, not recognizing the current font.

Edit2:

#3 seems to be that you're not picking up both the base font and monospace font, and which is actually active.

It would also be nice to import user themes from the standard location, <scitedir>SciteConfig.

Edit:

You should also check for user defined Tools in the user properties file (that's where I keep mine).

I think I have everything so far except for importing user themes from standard location. Please run again to see if that corrects the issues so far. Thank you.

Share this post


Link to post
Share on other sites

I'm getting a lot of errors when using this on Windows 7 x64.

=============================================

! AutoItCOM Test: We intercepted a COM error!

windescription: Member not found.

(-1) :

=============================================

This happens when starting and when trying to update the properties file.

BTW, using this on a portable version of SciTE/AutoIt.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Beege
      If you have every taken the time to set up a nice dark theme for your scite editor, you probably noticed shortly after a small yet really annoying flaw. For what ever reason, scite is not set up to let you change the caret fore color and caret line color per language. This really sucks if say you want to edit a properties file or any of the many other languages that Scite currently is setup to support. Pretty much all the other languages are set as light theme so unless you change the theme for those file types, you end up with something like below where the line color and caret are still using the dark theme colors. Line 3 in the pic:
       

       
      To get around this I came up with the following that seems to work pretty well.  
       
      Add the following properties to SciteUser.properties file (Options -> Open User Options File). Update colors to your own needs. You can addionally add any other propertys that dont have a lexer language option in the same fashion.
      # The default values (light themes) will be used for any lexer other than au3 caret.default.fore=#000000 caret.default.line.back=#FFFED8 selection.default.fore=#006000 selection.default.back=#F0A0A8 caret.au3.fore=#FFFFFF caret.au3.line.back=#111111 selection.au3.fore=#C2FFAE selection.au3.back=#f9f9f9  
      Add the following function to PersonalTools.Lua file. As jos pointed out, the OnStartup covers the filetab switches as well as the startup so only need the one function:
      function PersonalTools:OnStartup() -- the "and" + "or" keywords are ternary operators here local sLex = self:IsLexer(SCLEX_AU3) and 'au3' or 'default' props['caret.line.back'] = props['caret.' .. sLex .. '.line.back'] props['caret.fore'] = props['caret.' .. sLex .. '.fore'] props['selection.fore'] = props['selection.' .. sLex .. '.fore'] props['selection.back'] = props['selection.' .. sLex .. '.back'] end
      Last restart SciTE and that should be it. Let me know if you have any issues. Thanks
       
    • By AZJIO
      Place the Notepad ++ in the AutoIt3 folder
      Just replace the files in your Notepad++. The path must be "AutoIt3Notepad++"

      NotepadPlus.7z (v6.5.3 Ru, 4.9 Mb)



      shortcuts.xml, Contains commands:
      F5 - Start File (Alt + F5 - Setting)
      F6 - Start Script (ConsoleWrite) (Ctrl + F6 - Setting)
      Alt + F - Jump to function as a SciTE 
      Alt+X - AutoIt3Wrapper (Ctrl + F6 - ConsoleWrite)
      Alt + Z - Tidy.exe %1 /refc /reel /bdir=C:AutoIt3BackUp
      Alt+i - Au3Info.exe
      Alt + R - ToolsRegExpRegExp.exe
      Alt + F1 (F2, F3) - HELP_AutoIt3.au3
      Alt+F6 - Converter AU3 to BBcode
      Alt + F8 - list_var_funk.au3
      Alt + Shift + A - txt2au3
      Alt + G - JumpRegCMD
      Alt+Shift+D - Remove spaces
      Alt + K - Strip Comments
      Alt + L - Debugger
      Alt + F - JumpFunc
      Alt + N - CreateNewFile
      Alt + O - OpenToExplorer
      Alt + F7 - Renaming variables
      Ctrl + F7 - Include_Helper
      Ctrl + F9 - panel_function
      Ctrl + F12 - JumpToString
      Ctrl + 1 (2 ,3 ,4 ,5) - Set the color of the selected
      Ctrl + Shift + 1 (2 ,3 ,4 ,5) - Remove the color of the selected
      Ctrl + Shift + 0 - Remove the color of all selected


      langs.xml
      Added registered functions, operators and keywords

      themes
      AutoIt_Def.xml
      AutoIt+Zenburn.xml

      autoit.xml, batch.xml (for example enter "ms" and press "Enter")

      XBrackets.dll - sets closing brackets (disabled by default)
      NppExec.dll - Ctrl + F6 - for ConsoleWrite
      FunctionList.dll - List of functions
      NppSnippets.dll
      ScrollPastEOFUni.dll
       
       
      >JumpToString (Notepad++)
      >Include_Helper
      >Renaming variables
      >Debugger
×
×
  • Create New...