Jump to content

Problem mounting with daemon tools for an emulator with AdvanceLauncher

Recommended Posts

I am trying to mount a .cue file image in XBMC via Advance Launcher. I was using virtual clone drive and it worked pretty well. The downside of virtual clone drive is that it cannot mount .cue image files. I have now switched to daemon tools. I've tried the Lite and Pro Advanced versions but it dosent mount any image file.

With a batch file it works. Here is the batch file :

"C:\Program Files (x86)\DAEMON Tools Lite\DTLite.exe" -mount scsi, 0,%1

Here is my script with autoIt.

If $CmdLine[0] == 1 Then

RunWait ( '"C:\Program Files (x86)\DAEMON Tools Lite\DTLite.exe" -mount scsi, 0,"' & $CmdLine[1] & '"')
RunWait('"C:\Users\Il be back\Desktop\Windows 7 XBMC Project\Emulators\Sega\Saturn\EmuCR_SSF_012_beta_R3\SSF_012_beta_R3   (E)\SSF.exe"')


While 1


Func Terminate()
    ProcessClose ( "SSF.exe" )
RunWait( '"C:\Program Files (x86)\DAEMON Tools Lite\DTLite.exe" -unmount scsi, 0' )
Run ("XBMC.exe")
   WinSetState("[CLASS:XBMC]", "", @SW_Maximize)
    Exit 0



Link to post
Share on other sites

Hi Divad, I had the same problem as you a while ago. I came up with the answer.

Actually wow, hahaha I just realized I had the same problem with the same program. For the sega saturn emulator SSF as well.

Check out my thread:

What is the full command that you are sending to Runwait?

I'm making a frontend for the sega saturn emulator. It's really a big coincidence that I read your post haha. My front end is by means of a GUI for Windows. Are you using XBMC as your GUI?

Link to post
Share on other sites

Just to be double sure, I tried out your program and switch the paths with mine:

RunWait ( '"I:stuff I put onDAEMON Tools ProDTAgent.exe" -mount scsi, 0,"I:stuff I put onGamesConsole GamesSega Saturn RomsDragon ForceDRAGON_FORCE.CUE"')
RunWait('"I:stuff I put onGamesConsole GamesSega Saturn EmulatorSSF_012_beta_R3SSF.exe"')

and it works fine. I think the program is in your $CmdLine[1] variable.

Link to post
Share on other sites

I've solved my problem!!

When I was using Clone Virtual Drive I was opening the .iso of the game. Now with Daemon Tools I was able to open the game with the .cue file format.

80% of my roms had errors in the .cue file. That is why when i tried my script it didin't mount the rom.

Yup I'm using XBMC as the GUI with AdvanceLauncher for all my games.

Thx for helping me!!!

Link to post
Share on other sites

There is also an error in Advance-Launcher or XBMC.

If the laucher's (begining) name is the same as the program and is in the same directorie, it will open the program and not the launcher.

Here is an exemple:

My autoIt script is named like this. SSF (E)-Launcher.exe (C:EmulatorsSega Saturn)

The program is named like this. SSF.exe (C:EmulatorsSega Saturn)

With this configuration even though the launcher is redirected to SSF (E)-Launcher.exe it will open SSF.exe instead!

Solutions : - Name your launcher differently (Ex: Launcher-SSF.exe)

- Put the launcher in a different directory (Ex: Put SSF (E)-Launcher.exe to "C:Emulators" instead of "C:EmulatorsSega Saturn")

Will try to see if it's a bug from XBMC or Advanced Launcher


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...