Jump to content

"Run" to launch java app seems to be architecture dependant (32/64 bit)

Recommended Posts

Hello - I've got a situation for which I'd like to get some insight from those more knowledgeable than I:

  • I have an Autoit application that I deploy as an executable. 
  • I can be deployed (I hope) to any level of Windows (2K - 8) both 32 and 64 bit. 
  • I has a sub-component that is a java app (BaseX XML database). 
  • I develop on a Win 7 Pro 64bit machine.

Just recently (last 4 months), I had not touched it since its last version and I started coding/testing again for another release.  It no longer worked!  I'd not changed the code but both the compiled and non-compiled versions now failed on my development machine.  Banged my head for quite a while to figure out what the deal was! :mad2:

I finally narrowed it all down to:

This command:

Local $pid = run(@ComSpec & " /c " & "java -cp BaseX.jar org.basex.BaseXServer","C:\Users\David\DOCUME~1\OPENSO~3\TESTIN~1\OPENSO~1\BaseX",@SW_HIDE,$STDERR_MERGED) ;starts the basex server to facilitate queries

worked when I commented out:


when it was NOT commented out (I had it uncommented to create 32bit executables for multi-architecture deployment) I received this message from the run command:


'java' is not recognized as an internal or external command, operable program or batch file.

I've uninstalled ALL of java and then just reinstalled the most recent version to see what that would do - same behavior.  I'm guessing that perhaps java, in more recent versions, has changed the way it is deployed for distinguishing between 32 and 64 bit machines.

So it would appear that my tactic to develop and deploy as a single 32-bit application that would cover all 32 and 64 bit machines will no longer work.  Is my only choice to create/use an installer that installs EITHER the 32 bit or 64 bit executable? Or is there some way to change my Run command such that it finds "java" no matter how it is intalled on my machine?


Link to comment
Share on other sites

Ok - edit of the situation. 

I found that I wasn't at the latest AutoIt version.  I then updated to and then it didn't work at all! :

I had updated to make the simplesort work in x64 but it broke my call to java.  So I went and looked into the help file about x64 issues and found this piece of code:

DllCall("kernel32.dll", "int", "Wow64DisableWow64FsRedirection", "int", 1)

So I added it to my script.  Now the java call works AND the simplesort works.  Next step will be the compile and testing under 32 bit systems.

So, we're good for now - more testing to do!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...