Jump to content
MarkRobbins

IE embedded border-radius not complying

Recommended Posts

I have IE 10 installed, so I assume the embedded is using the same.

If I make a test html doc that has a DIV with inline style of "border-radius:8px 8px 8px 8px;" this radius works if I browse the file with normal IE 10 --- but if I am embedding IE in a form and using _IEPropertySet($oIE, 'innerhtml', $html) with the exact same html that is in the file, the border-radius does not work.

#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#include <IE.au3>

_IEErrorHandlerRegister()
Local $oIE = _IECreateEmbedded()

Global $thisfile="C:\batch\borg\TestCreeper.au3"
Global $logg="C:\$data\logs\TestCreeper-log.txt";
Global $timestamp=@YEAR&"."&@MON&"."&@MDAY&"."&@HOUR&"."&@MIN&"."&@SEC&"."&@MSEC


Global $f_w=800
Global $f_h=400

Global $hgui=GUICreate("Embedded Web control Test", $f_w, $f_h, _
        (@DesktopWidth - $f_w) / 2, (@DesktopHeight - $f_h) / 2, _
        $WS_POPUP)
GUICtrlCreateObj($oIE, -2, -2, $f_w+30, $f_h+8)

GUISetState() ;Show GUI

_IENavigate($oIE, "about:blank")
Global $st='body {  background-color:black;margin: 0; padding: 0; } '

Global $tx='Mary had a little lamb, little lamb, little lamb, little lamb, whose fleece was white as snow'


;THIS DOESNT WORK, SPECIFYING EACH INDIVIDUALLY
Global $br=BorderRadiusTxt(8)
;MsgBox(0,$thisfile,$br)

;NONE OF THE FOLLOWING WORK
$br='border-radius:8px;'
$br='-ms-border-radius:8px;'
$br='-webkit-border-radius:8px;'
$br='-moz-border-radius:8px;'

$br='border-radius:8px 8px 8px 8px;'
$br='-ms-border-radius:8px 8px 8px 8px;'
$br='-webkit-border-radius:8px 8px 8px 8px;'
$br='-moz-border-radius:8px 8px 8px 8px;'

;WORKS IN IE, BUT NOT IN EMBEDDED     <<<<<=== HERE
$br='border-radius:8px 8px 8px 8px;'

Global $t='';
$t&='<div style="position:absolute;'&$br&'border:1px solid green;background-color:black;padding:12px;color:#ccc;font-family:Tahoma;height:10px;top:10px;left:10px;">'

$t&=$tx
$t&='</div>'

Global $body_tags='border="0" marginheight="0" topmargin="0" vspace="0" marginwidth="0" leftmargin="0" hspace="0" '

Global $html='<HTML><HEAD><STYLE type="text/css">'&$st&'</STYLE></HEAD><BODY '&$body_tags&'>'&$t&'</BODY></HTML>'
;MsgBox(0,$thisfile,$html)
;ClipPut($html)

Global $r=_IEPropertySet($oIE,'innerhtml',$html)

; Waiting for user to close the window
While 1
    Local $msg = GUIGetMsg()
    Select
        Case $msg = $GUI_EVENT_CLOSE
            ExitLoop
    EndSelect
WEnd

GUIDelete()









Func BorderRadiusTxt($i)
  Return 'border-top-left-radius:'&$i&'px;' & _
  'border-top-right-radius:'&$i&'px;' & _
  'border-bottom-left-radius:'&$i&'px;' & _
  'border-bottom-right-radius:'&$i&'px'
EndFunc

;;;;;;functions
Func ts()
  Return @YEAR&"."&@MON&"."&@MDAY&"."&@HOUR&"."&@MIN&"."&@SEC&"."&@MSEC
EndFunc
Func logline($line)
  Local $fh1=FileOpen($logg,1);
  If $fh1<>-1 Then
    FileWriteLine($fh1,$line)
    FileClose($fh1)
  EndIf
EndFunc

Share this post


Link to post
Share on other sites

I have IE 10 installed, so I assume the embedded is using the same.

If I make a test html doc that has a DIV with inline style of "border-radius:8px 8px 8px 8px;" this radius works if I browse the file with normal IE 10 --- but if I am embedding IE in a form and using _IEPropertySet($oIE, 'innerhtml', $html) with the exact same html that is in the file, the border-radius does not work.

#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#include <IE.au3>

_IEErrorHandlerRegister()
Local $oIE = _IECreateEmbedded()

Global $thisfile="C:\batch\borg\TestCreeper.au3"
Global $logg="C:\$data\logs\TestCreeper-log.txt";
Global $timestamp=@YEAR&"."&@MON&"."&@MDAY&"."&@HOUR&"."&@MIN&"."&@SEC&"."&@MSEC


Global $f_w=800
Global $f_h=400

Global $hgui=GUICreate("Embedded Web control Test", $f_w, $f_h, _
        (@DesktopWidth - $f_w) / 2, (@DesktopHeight - $f_h) / 2, _
        $WS_POPUP)
GUICtrlCreateObj($oIE, -2, -2, $f_w+30, $f_h+8)

GUISetState() ;Show GUI

_IENavigate($oIE, "about:blank")
Global $st='body {  background-color:black;margin: 0; padding: 0; } '

Global $tx='Mary had a little lamb, little lamb, little lamb, little lamb, whose fleece was white as snow'


;THIS DOESNT WORK, SPECIFYING EACH INDIVIDUALLY
Global $br=BorderRadiusTxt(8)
;MsgBox(0,$thisfile,$br)

;NONE OF THE FOLLOWING WORK
$br='border-radius:8px;'
$br='-ms-border-radius:8px;'
$br='-webkit-border-radius:8px;'
$br='-moz-border-radius:8px;'

$br='border-radius:8px 8px 8px 8px;'
$br='-ms-border-radius:8px 8px 8px 8px;'
$br='-webkit-border-radius:8px 8px 8px 8px;'
$br='-moz-border-radius:8px 8px 8px 8px;'

;WORKS IN IE, BUT NOT IN EMBEDDED     <<<<<=== HERE
$br='border-radius:8px 8px 8px 8px;'

Global $t='';
$t&='<div style="position:absolute;'&$br&'border:1px solid green;background-color:black;padding:12px;color:#ccc;font-family:Tahoma;height:10px;top:10px;left:10px;">'

$t&=$tx
$t&='</div>'

Global $body_tags='border="0" marginheight="0" topmargin="0" vspace="0" marginwidth="0" leftmargin="0" hspace="0" '

Global $html='<HTML><HEAD><STYLE type="text/css">'&$st&'</STYLE></HEAD><BODY '&$body_tags&'>'&$t&'</BODY></HTML>'
;MsgBox(0,$thisfile,$html)
;ClipPut($html)

Global $r=_IEPropertySet($oIE,'innerhtml',$html)

; Waiting for user to close the window
While 1
    Local $msg = GUIGetMsg()
    Select
        Case $msg = $GUI_EVENT_CLOSE
            ExitLoop
    EndSelect
WEnd

GUIDelete()









Func BorderRadiusTxt($i)
  Return 'border-top-left-radius:'&$i&'px;' & _
  'border-top-right-radius:'&$i&'px;' & _
  'border-bottom-left-radius:'&$i&'px;' & _
  'border-bottom-right-radius:'&$i&'px'
EndFunc

;;;;;;functions
Func ts()
  Return @YEAR&"."&@MON&"."&@MDAY&"."&@HOUR&"."&@MIN&"."&@SEC&"."&@MSEC
EndFunc
Func logline($line)
  Local $fh1=FileOpen($logg,1);
  If $fh1<>-1 Then
    FileWriteLine($fh1,$line)
    FileClose($fh1)
  EndIf
EndFunc

Did u solve the problem? I'm facing the same issue...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By TXTechie
      Hello Everyone,
      I'm looking for a way to use an already open Internet Explorer (IE) window (if one is up and running) and then navigate to a new URL in a new IE tab.
      I thought that _IECreate would easily meet my needs. However, when I use the following script:
      #include <IE.au3> Local $oIE = _IECreate("https://" & $Server & ":8444/", 1, 1, 0, 1) ...with one or more open IE windows, it still opens yet a new IE window.
      Are there any other ideas for how to reliably use an already open IE windows and then how to open a new tab in IE to navigate to a new URL?
      Regards,
      TX Techie
    • By WoodGrain
      Hi All,
      I've tried to create a script to browse to a web page in IE, but it only works for some sites, I've tried to simplify the script as much as possible, hoping you can point me in the right direction - thanks.
      This one going to Google does work:
      #include <IE.au3> $oIE = _IECreate("https://www.google.com.au/", 0, 1, 1) _IELoadWait($oIE) _IEQuit($oIE) But this one going to OneDrive opens the IE page, but fails immediately returning the errors, and the IE window is not closed:
      --> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_ClientDisconnected (-2147023174, Browser has been deleted prior to operation.)
      --> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_InvalidObjectType ()
      --> IE.au3 T3.0-2 Error from function _IEQuit, $_IESTATUS_InvalidObjectType
      #include <IE.au3> $oIE = _IECreate("https://abccorp-my.sharepoint.com/", 0, 1, 1) _IELoadWait($oIE) _IEQuit($oIE) Even if I put a sleep timer in for 10 seconds after the _IECreate it still doesn't work
      Thanks all!
    • By Dent
      https://rmplusportal.rightmove.co.uk/
      On that page is a login form requiring username, password and then the clicking of the button (or pressing enter but I'm not a fan of using Send)
      Here's the section of code from the page that specifically deals with the form...
      <form> <div class="error-message-login" data-test="error-message"></div> <label> <span>User email</span> <div class="ui input"> <input id="email" type="text" placeholder="Your email"> </div> </label> <label> <span>Password</span> <div class="ui input"> <input id="password" type="password" placeholder="Password"> </div> </label> <button class="ui primary button" role="button" data-test="login">Login</button> <p> <a class="forgot-your-password" href="https://www.rightmove.co.uk/forgottenPasswordForm.html">Forgot your password?</a> </p> </form> Specifically the <button class...></button> is causing me problems as I can't find a way to click it. The 'User email' and 'Password' objects have an 'id' so I can reference these in the AutoIT code and interact with them and the button also previously had the id of 'login' but I guess in a change to this page that was altered.
      Oddly, if I get the code to show the instance of IE that is created and manually click Login or press Enter the page gives me an error saying 'Please enter your email address' even though it is there. I have to manually go into each field and make a change i.e. adding a character to the end of each field then deleting it before it will let me in by either clicking Login or pressing enter. So maybe there's so code elsewhere on the page that knows the fields haven't been physically typed in?
      Any help on this would be much appreciated.
    • By JackER4565
      Hi, first of all thanks to all the guys who always help people in the forums, I wouldn't be able to do anything if wasn't for your help, even if I don't ask it myself.
       
      I've created this code to get some info on a monitoring network on my work. It relays on _IETableGetCollection and _IETableWriteToArray.
      It works well, but take around 3:25 minutes to get the info from 28 pages (some of them are large and take longer to load, but most of them are small and fast).
      My question is if you see a way to get the program to go faster...
       
      I've tried to make it easy for you to understand and edited somethings with sensitive info.
      (Some of the pages doesn't have the black divider with MIRA in the end, so I need to search if it is there or not.)
       
      #include <IE.au3> #include <array.au3> Local $oIE = _IECreate("about:blank", 0, 0) Local $paginas[28] = [89, 90, 91, 92, 93, 96, 105, 113, 119, 125, 126, 129, 131, 133, 135, 137, 139, 140, 141, 144, 145, 146, 148, 149, 150, 151, 158, 159] Local $Datos_array[0][2] Local $oTable Local $tabla Local $aux_x = 1 Local $ar = 1 Local $Numtables_datos = 0 MsgBox(0, "asd", "asd") For $pag = 0 To UBound($paginas) - 1 Step 1 _IENavigate($oIE, "<WEBSITE URL>" & $paginas[$pag]) ; <<< the pages to load are always the same except for the last digits. _ArrayAdd($Datos_array, $paginas[$pag] & "|" & "Entrante", 0, "|") ; <<<<<<<<<<<<<<<< adds the page number toarray [0, 0] ;############################################ START counts amount of tables with traffic $oTable = _IETableGetCollection($oIE) Local $iNumTables = @extended For $i = 3 To $iNumTables - 2 Step 1 $oTable = _IETableGetCollection($oIE, $i) $nomb_tabla2 = _IETableWriteToArray($oTable) ; <<<<<<<< TABLE TO ARRAY. $string2 = StringStripWS($nomb_tabla2[1][0], 8) If $string2 <> "MIRA" Then $Numtables_datos = $Numtables_datos + 1 Next $tabla_End = $iNumTables - $Numtables_datos ;############################################ FIN $tabla_Start = 4 $tabla_trafico = 2 For $for = 1 To $Numtables_datos Step 1 $oTable = _IETableGetCollection($oIE, $tabla_Start - 1) ; <<<<<<<<<<< NAME OF THE TABLE; row2 = mira $nomb_tabla = _IETableWriteToArray($oTable) ; <<<<<<<< TABLE TO ARRAY ;########################################### ADDS the traffic number into the row $string = StringStripWS($nomb_tabla[1][0], 8) If $string == "MIRA" Then ;si o si pasa por aca 1 vez _ArrayAdd($Datos_array, $nomb_tabla[0][0]) $nomb_aux = $nomb_tabla[0][0] $aux_x = 1 $tabla_trafico = $tabla_trafico + 2 Else ;esto deberia ser por row _ArrayAdd($Datos_array, $nomb_aux & " " & $aux_x) $aux_x = $aux_x + 1 $tabla_trafico = $tabla_trafico + 1 EndIf $oTable = _IETableGetCollection($oIE, $tabla_trafico) Local $aTableData = _IETableWriteToArray($oTable) $bps = _ArrayToString($aTableData, "|", 0, 0, @CRLF, 0, 0) $bps = StringRight($bps, 5) $bps = StringLeft($bps, 4) $trafico_actual = _ArrayToString($aTableData, "|", 0, 0, @CRLF, 2, 2) If $bps == "Gbps" Then $trafico_actual = $trafico_actual * 1000 If $bps == "Kbps" Then $trafico_actual = $trafico_actual / 1000 $Datos_array[$ar][1] = $trafico_actual $ar = $ar + 1 If $string == "MIRA" Then $tabla_Start = $tabla_Start + 2 Else $tabla_Start = $tabla_Start + 1 EndIf Next $ar = $ar + 1 ;~ ############# CAÍDA ############ ;~ If $actual_entrante = 0 Then ;~ $xxx = 0 ;~ Do ;~ MsgBox(0, "Tráfico Caído", $paginas[$i], 5) ;~ $xxx = $xxx + 1 ;~ Until $xxx = 10 ;~ EndIf ;~ ############# CAÍDA ############. Local $Numtables_datos = 0 Next _ArrayDisplay($Datos_array, "Array display") _IEQuit($oIE) Thanks!! 


      monitoria.html
    • By Dent
      Here is the URL to get to the page with the code as shown in the screenshot https://www.rightmove.co.uk/house-prices/detail.html?country=england&locationIdentifier=POSTCODE^1603593&searchLocation=SW1V+1AA&year=1&referrer=listChangeCriteria
      But how do I select the highlighted text, the address?
      I've tried variations of the below code but to no avail so far
      Local $oClassReturn = $oIE.document.getElementsByClassName("soldList") If Not IsObj($oClassReturn) Then Exit ConsoleWrite("Error in $oClassReturn" & @CRLF) Local $oTagReturn = $oClassReturn.Item(0).getElementsByTagName("div") If Not IsObj($oTagReturn) Then Exit ConsoleWrite("Error in $oTagReturn" & @CRLF) MsgBox(0, "TEST", $oTagReturn.Item(0))  

×
×
  • Create New...