Jump to content
Jos

20-9-2015: New SciTE4AutoIt3 available with the updated SciTE v3.6.0 release.

Recommended Posts

20-9-2015: Uploaded a new SciTE4AutoIt3.exe.

Merged the SciTE 3.6.0 source into our version and several fixes.
We now also have set the default encoding to UTF8 W/O Bom when no other File encoding is specified or special ASCII characters are detected in the source. 

 

Enjoy,
Jos

Addition/Changes/Fixes in the current installer:

20-9-2015
*** Merged the SciTE v 3.6.0 by Neil Hodgson with our own version of SciTE. (Jos)
    - More fixes to outputpane lexing to ensure FuncTrace generated lines work again.
    - Added tf8.auto.check=4 default to SciTEGlobal. properties to check files when opened for their encoding or else use utf8 w/o BOM ad default.
*** Updated AutoIt3Wrapper v15.920.938.0 (Jos)
    - 15.729.1555.1: Fixed /Watcher and /Jump2FirstError mechanism to kill the script when Ctrl+Break or via the Menu the script should be terminated.
    - 15.729.1555.2: Added Win10 to the Manifest and made that the default similar to what aut2exe does.
    - 15.729.1555.3: 15.729.1555.4 "Version Diff Source" now properly handling UTF encoded files.
    - 15.729.1555.4: Internal mods.
    - 15.729.1555.5: Added /RunAfter to copy to Programdir and Versioning without compiling.
    - 15.729.1555.6: Changes to the tempfiles generated to allow for concurrent sessions of Autot3Wrapper.
    - 15.729.1555.7: cleanup some tempfile remaining behind.
    - 15.729.1555.8: Fixed consolewrite in debug mode.
    - 15.729.1555.9: killed extra autoit3 pid when restarting the script.
    - 15.729.1555.10: Removed Compiled support statements.
    - 15.729.1555.11: Added a console message when Script requires Admin and SciTE is running on normal level that no console output will be displayed.
*** Updated Au3Stripper v15.920.938.0 (Jos)
    - 15.729.1555.2: Fixed issue for Include files with BOM encoding not recognizing #Include-once on the first line.
    - 15.729.1555.3: Fixed hardcrash in case de au3stripper didn't exist and /debug was specified.
    - 15.729.1555.4: Minor internal changes.
*** Updated SciTEConfig v15.920.938.0 (Jos)
    - added scheme OLD_LCD.SciTEConfig  (mLipok)
*** Updated Au3Stripper v15.729.1555.0 (Jos)
    - 15.729.1555.1: Fixed hardcrash in case an Include is used with BOM and #include-once on the first line.
*** Updated Tidy v15.920.938.0 (Jos)
    - 15.729.1555.1: Fixed hardcrash adding Gobal Const to the variable tables.

==> ScitillaHistory page containing all SciTE-Scintilla updates.
==> Visit the SciTE4AutoIt3 Download page for the latest versions
==> Check the newly formatted the online documentation for an overview of all extra's you get with this installer.

Edited by Jos

Share this post


Link to post
Share on other sites

maybe it related to : Fixed issue for Include files with BOM encoding not recognizing #Include-once on the first line.

if you have 3 scripts : main.au3; UDF_n1.au3 and UDF_n2.au3 encoded as UTF8 with BOM :

;# main.au3 ===================

#include "UDF_n1.au3"
#include "UDF_n2.au3"

script body

Exit
;==============================
;# UDF_n1.au3 =================
#include-once
#include "UDF_n2.au3"

script body
;==============================
;# UDF_n2.au3 =================
#include-once
#include "UDF_n1.au3"

script body
;==============================

now, if you run Syntax Check against main.au3 everything is ok

But : if you run Syntax Check against UDF_n1.au3 you get:

warning: $sSomeVariable_from_UDF_n1 already declared/assigned
error: $iSomeConst_from_UDF_n1 previously declared as a 'Const'.
error: SubFunction_from_UDF_n1() already defined.

same with UDF_n2.au3

warning: $sSomeVariable_from_UDF_n2 already declared/assigned
error: $iSomeConst_from_UDF_n2 previously declared as a 'Const'.
error: SubFunction_from_UDF_n2() already defined.

it seems Syntax Check not consider #include-once in head script

Edited by Iczer

Share this post


Link to post
Share on other sites

Maybe you have real errors in your script as the #included filenames are not the same!

In the Main.au3 they do not contain an underscores where as in the UDF_nx.au3 they do?

Jos

Edited by Jos

Share this post


Link to post
Share on other sites

no, i mistyped in previous post (corrected now)

if that was reason - i would also get errors after Syntax Check against main.au3 (not found/declared/defined. errors), but everything is ok

 

Share this post


Link to post
Share on other sites

Then you need to provide the script files so I can test it.

Jos

Edited by Jos

Share this post


Link to post
Share on other sites

save as UTF8 with BOM and make Syntax Check against each :

;# main.au3 ===================

#include "UDF_n1.au3"
#include "UDF_n2.au3"

SubFunction_UDF_n1_1()
SubFunction_UDF_n1_2()
SubFunction_UDF_n1_3()
SubFunction_UDF_n2_1()
SubFunction_UDF_n2_2()
SubFunction_UDF_n2_3()

Exit
;==============================
;# UDF_n1.au3 =================
#include-once
#include "UDF_n2.au3"
;
Global Const $UDF_n1_const_1 = 1
Global Const $UDF_n1_const_2 = 2
;------------------------------
Func SubFunction_UDF_n1_1()

EndFunc
;------------------------------
Func SubFunction_UDF_n1_2()

EndFunc
;------------------------------
Func SubFunction_UDF_n1_3()

EndFunc
;==============================
;# UDF_n2.au3 =================
#include-once
#include "UDF_n1.au3"
Global Const $UDF_n2_const_1 = 1
Global Const $UDF_n2_const_2 = 2
;------------------------------
Func SubFunction_UDF_n2_1()

EndFunc
;------------------------------
Func SubFunction_UDF_n2_2()

EndFunc
;------------------------------
Func SubFunction_UDF_n2_3()

EndFunc
;==============================

 

Share this post


Link to post
Share on other sites

Understand the issue now. I had made a "workaround" for UTF8/16 encoded main scripts quite some time ago, to copy the main script into a temp file before running au3check as at that time au3chech only supported Ascii.

UTF8 is now supported in au3check so I have removed the check for that in AutoIt3Wrapper and simply process the original file now with the current Beat version of AutoIt3Wrapper.

Jos 

Share this post


Link to post
Share on other sites

I have a problem with the beta, I can't access the Beta help file... I tried both F1 & Help Menu :(


My contributions to the AutoIt Community - ##AutoIt at freenode, real-time chat

3fHNZJ.gif

Spoiler

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) intend to do that to anybody.

Share this post


Link to post
Share on other sites

I Just open SciTe4AutoIt (lates version)

And for me all works correctly.
The same for you:

  1. F1 should open your instaled AutoIt release version
  2. ALT+F1 should open your instaled AutoIt beta version
  3. MENU: "Help/ Help F1" should open your AutoIt release version

which one do not work for you ?


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API Forum Rules *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST APIErrorLog.au3 UDF - A logging Library *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF * Dual Monitor resolution detection * * 2GUI on Dual Monitor System * _SciLexer.au3 UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * IE in TaskScheduler

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

11

Signature last update: 2018-10-31

Share this post


Link to post
Share on other sites

What does Help/About SciTE tell you?
Have you installed the Prod and Beta version of AutoIt3 in the normal way and also installed the latest version of SciTE4AutoIt3 separate installer? 

Jos

Share this post


Link to post
Share on other sites

What does Help/About SciTE tell you?

SciTE
Version 3.5.4
    May 17 2015 16:32:11
by Neil Hodgson.
 Updated by Jos
Check the SciTE4AutoIt3 Homepage for Updates
December 1998-March 2015.
http://www.scintilla.org
Lua scripting language by TeCGraf, PUC-Rio
    http://www.lua.org
Contributors:
<snip>

 

Have you installed the Prod and Beta version of AutoIt3 in the normal way and also installed the latest version of SciTE4AutoIt3 separate installer? 

Yes! First I installed AutoIt 3.3.4.1 Then SciTE4AutoIt3 Then again AutoIt 3.3.15.0


My contributions to the AutoIt Community - ##AutoIt at freenode, real-time chat

3fHNZJ.gif

Spoiler

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) intend to do that to anybody.

Share this post


Link to post
Share on other sites
SciTE
Version 3.6.0 
    Aug  4 2015 17:34:27
by Neil Hodgson.
 Updated by Jos

https://www.autoitscript.com/cgi-bin/getfile.pl?../autoit3/scite/download/SciTE4AutoIt3.exe

 


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API Forum Rules *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST APIErrorLog.au3 UDF - A logging Library *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF * Dual Monitor resolution detection * * 2GUI on Dual Monitor System * _SciLexer.au3 UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * IE in TaskScheduler

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

11

Signature last update: 2018-10-31

Share this post


Link to post
Share on other sites

Is the Beta Help shown under tools under Beta Compile? (Ensure you have a file open with an au3 extension.)

Jos

 

Share this post


Link to post
Share on other sites

@Jos Yeah! I just tried Alt + F1 and it worked! Thanks! :D

 

P.S Why is Beta Help in Tools instead of Help? :huh:


My contributions to the AutoIt Community - ##AutoIt at freenode, real-time chat

3fHNZJ.gif

Spoiler

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) intend to do that to anybody.

Share this post


Link to post
Share on other sites

So, which other app could be "eating" the ALt+F1 keys combo or did you change it?

Jos

Share this post


Link to post
Share on other sites

@Jos I have no Idea, I updated my SciTE4AutoIt3 installation, maybe It refreshed something :unsure:


My contributions to the AutoIt Community - ##AutoIt at freenode, real-time chat

3fHNZJ.gif

Spoiler

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) intend to do that to anybody.

Share this post


Link to post
Share on other sites

So Alt+F1 is working now?    

Duh ... you said that already. :)

Edited by Jos

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By ozymandius257
      Is there a way to remove the numbers from the tabs in Scite?
      When you have multiple autoit programs open, the tabs are numbered, so you'll get something like 1 ProgramA.au3    2 Program2.au3   3 Program3.au3
      I am working on programs with numbers as the first character, so I get  1 3-DoThis.au3     2 4-DoAnother.au3   3 5-DoTheRest.au3  (not the real program names, obviously :))
      It would be nice if I could get rid of the tab number, and just have the program name on each tab.
       
       
    • By SgtHugoStiglitz
      HI people,
                        I got a questions, I maintain code in autoIT and every time I compile a new version or modification, Scite generate 2 folders. One folder is finish by released and the other is tentative. I try to make some google search, but never find answer would satisfied myself. The dev who was maintain it before were using AutoIt3Wrapper_GUI, and I don't know if it's related. I look both folder, but they seem pretty identical, but I would like to know what it's the difference between those to folder. Anyone have a clue?
    • By user4157124
      ConsoleWrite('>Message here.' & @CRLF) outputs colored text (per + > - ! characters).
      ConsoleWrite('warning' & @TAB & '38' & @TAB & 'more text ...' & @CRLF) enables jump to line 38 on doubleclick.

      Using "jump to line" format, only red and pink text coloring seems possible (simply prefixing color directives to output-text disables jump to line functionality). Is it possible to combine the two (define custom color while keeping "jump to line" functionality)?
    • By mannworks00
      After testing various schemes (themes) in the settings for the newest SciTE editor (v. 4.1.2), I discovered that I wasn't able to fully reset it back to its original colors (See snapshot). Specifically, after applying the "__SciTE4AutoIt3_Dark ==> Dark SciTE4AutoIt3 Color scheme."
      The problem: The Line number column and the Output console do not reset back to their original colors.
      The Solution: Delete or edit the user config file. You can safely delete the config file because it will completely regenerate on SciTE restart- with it's factory (out of the box) color scheme.
      I also wrote a small script that will do it programatically: How to reset SciTE scheme in version 4.1.2.
       
       

    • By kellariluukku
      Hello.
      I'm using SciTE v3.3.14.5 I think, and I find this very annoying (GIF):
      https://i.gyazo.com/e60b5d94b8c16d217be4010e208d7042.mp4
       
      I've searched around but found nothing that helped including this:
      https://www.autoitscript.com/forum/topic/100517-stop-scite-removing-tab-indentations/
       
      So the problem obviously is that when I go to a new line after "EndIf", it removes the tab which I don't want to happen.
      Is there any fix?
       
      I've tried to change some configs such as 
          Line 183: # Indentation     Line 185: indent.size=0     Line 187: #indent.auto=0     Line 188: indent.automatic=0     Line 189: indent.opening=0     Line 190: indent.closing=0     Line 191: #tab.indents=0     Line 192: #backspace.unindents=0 strip.trailing.spaces=0 But nothing seems to get rid of this.
       
      Thanks
×
×
  • Create New...