Jump to content

SciTE & Au3Stripper (Solved)

Recommended Posts


Using SciTE Version 3.5.4 

I have Hebrew text in the working script, when I chose to compile with Au3Stripper, after the compile SciTE changed all the text on the working script that was in Hebrew to another format which was unreadable 
opening the working script in notepad ++,  the text was again readable so I pasted it back to SciTE and saved it.

Prior to that I had tried using Au3Stripper manually, compiling from SciTE, the result when running the compiled script was unreadable text in the GUI, showing question marks for text
So there is something new in this SciTE Version  that is causing this since This wasn't an issue with the previous version of Scite that I was using 
is there some setting that can be changed to avoid this ?


Edited by Deye

Share this post

Link to post
Share on other sites

 2 scenarios:
1. when I chose to compile from the GUI menu and check in to use Au3Stripper
After the compile ends, The text changes on the working sheet. the program runs as expected except for Hebrew text inside included UDFs

2. When I use "#AutoIt3Wrapper_Run_Au3Stripper=y" and F7 to compile
the text does not change on the working sheet but when I run the compiled program I get question marks for text

Edited by Deye

Share this post

Link to post
Share on other sites

First try to update SciTE4AutoIt


as you are using old SciTE4AutoIt (latest is 3.6.0)


After install if this still will occur, try also BETA:



Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API Forum Rules *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST APIErrorLog.au3 UDF - A logging Library *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF * Dual Monitor resolution detection * * 2GUI on Dual Monitor System * _SciLexer.au3 UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * IE in TaskScheduler

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."


Signature last update: 2018-10-31

Share this post

Link to post
Share on other sites

Thanks for the response and the links

I must have got the older version by mistake

Tried 3.6.0 now:
That partly helped
Opening the stripped file in SciTE I noticed the text gets encoded, opening with other viewer the text is no more readable

I would over look what's been encoded but here in some parts of the include UDF that contains Hebrew text The problem persists in the compiled outcome 

so this is what I found with latest version of autoit program pack installer v3.3.14.2
As I mentioned didn't notice this problem before.

Share this post

Link to post
Share on other sites

Send me a test version (small) of your script and details of the issues you see and I will have a check whether I can replicate what you see.


Share this post

Link to post
Share on other sites

Thanks for the file. The issue lies in the limitations au3stripper currently has when the files have incompatible encoding.

The Func _CFF_Choose() has 2 lines which require ANSII encoding and your main script is UTF8.
These are the lines causing the ANSII standard: (1st & 3rd)

$cRet_Button = GUICtrlCreateButton("âáä", $iW -($iButton_Width + 10), $iH - 40, $iButton_Width, 30)
$cCan_Button = GUICtrlCreateButton("áéèåì", $iW -($iButton_Width + 10) * 2, $iH - 40, $iButton_Width, 30)


Share this post

Link to post
Share on other sites

actually they should look like this :

$cRet_Button = GUICtrlCreateButton("גבה", $iW - ($iButton_Width + 10), $iH - 40, $iButton_Width, 30)
$cCan_Button = GUICtrlCreateButton("ביטול", $iW - ($iButton_Width + 10) * 2, $iH - 40, $iButton_Width, 30)

what looks to me  now as encoded in the stripped version is not the same language from the original 

changed the include file to UTF8 

problem solved 


Edited by Deye

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...