Jump to content
Sign in to follow this  
AJB

"Error: Variable must be of type object" on new machine

Recommended Posts

Hello,

I've been using autoit for about a year now and overall it's been great despite my limited understanding of all of its features. I have several scripts that run on virtual machines that have been running smoothly for several months without any issues. Recently, I had to create new virtual machines and migrate my scripts over and now I am getting errors that I can't seem to repeat, but seem to happen at least once a day with all of my executables that were flawless before.

The error that I keep getting is:

Autoit Error

Line [this number varies per script] (File "[path to my executable]"); Error: variable must be of type object.

I  never received this error before until I moved everything to the new VMs, and when I rerun my scripts after clearing the error everything seems to work and run fine until hours later or sometimes the next day. I am assuming that that the root cause may be in some kind of settings on the VM itself since it is happening nearly across the board, but I have no idea where to even look. These are running on Windows 7, which is what they were running on before I had any errors.

The only consistent include used in these scripts is  IE.au3

Has anyone run into a similar problem or can maybe point me in the right direction. I am at the point of pulling hair out trying to resolve this. I have even rewritten and re-compiled the scripts to see if somehow the executables got corrupted, but that didn't help.

Thank you.

Share this post


Link to post
Share on other sites

@AJB the error is telling you exactly what is wrong - you're calling a variable that is not an object. Unfortunately, more than that is impossible if you do not post your script.


"Profanity is the last vestige of the feeble mind. For the man who cannot express himself forcibly through intellect must do so through shock and awe" - Spencer W. Kimball

How to get your question answered on this forum!

Share this post


Link to post
Share on other sites

Hello,

 I have a similar problem but I received this error when moved from Windows 7 / IE7 / 32bit to Windows 7 / IE11 / 64 bit machine.

The script selects one of  4 dropdown options in the loop and randomly the third or fourth gets this error when in FireBug you can see all of them and if

_IEFormElementOptionSelect() is not called, Console write will print all of them

Here is the code:

$oForm = _IEFormGetObjByName($oIE, "myform")
$tp = _IEFormElementGetObjByName($oForm, "target")
If @error = "0" Then
    $cc = 0
    _IEAction($tp, "focus")
    For $t In $tp
        $cc = $cc + 1
        ConsoleWrite("count: " & $cc & @CRLF)


        If $cc = 1 Then
            ConsoleWrite(_IEPropertyGet($t, "outerhtml") & @CRLF)
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            ;If ($t.innerText) <> "" Then
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            _IEFormElementOptionSelect($tp, "Coldstore", 1, "byText")
            ;EndIf
            Sleep(1000)
        ElseIf $cc = 2 Then
            ConsoleWrite(_IEPropertyGet($t, "outerhtml") & @CRLF)
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            ;If ($t.innerText) <> "" Then
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            _IEFormElementOptionSelect($tp, "Windows File Share/SMB", 1, "byText")
            ;EndIf
            Sleep(1000)
        ElseIf $cc = 3 Then
            ConsoleWrite(_IEPropertyGet($t, "outerhtml") & @CRLF)
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            ;If ($t.innerText) <> "" Then
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            _IEFormElementOptionSelect($tp, "Internal SD card", 1, "byText")
            ;EndIf
            Sleep(1000)
        ElseIf $cc = 4 Then
            ConsoleWrite(_IEPropertyGet($t, "outerhtml") & @CRLF)
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            ;If $t.innerText <> "" Then
            ConsoleWrite("innerText: " & $t.innerText & @CRLF)
            _IEFormElementOptionSelect($tp, "none", 1, "byText")
            ;EndIf

        EndIf
    Next
EndIf

Output:

count: 1
<option value="coldstore">Coldstore
innerText: Coldstore
innerText: Coldstore
count: 2
--> IE.au3 T3.0-1 Error from function _IEPropertyGet, $_IESTATUS_InvalidObjectType
0
innerText:
innerText:
"C:\Program Files (x86)\AutoIt3\Include\IE.au3" (1115) : ==> Variable must be of type "Object".:
For $oItem In $oItems
For $oItem In $oItems^ ERROR

You can see that I commented check for an empty string.

If I uncomment it, I won't receive the error "Variable must be of type "Object".:" but I won't be able to select all options in loop in the dropdown.

The output will be with the 2 options available and 2 empty strings:

count: 1
<option value="coldstore" selected="">Coldstore
innerText: Coldstore
innerText: Coldstore
count: 2
<option value="wfs">Windows File Share/SMB
innerText: Windows File Share/SMB
innerText: Windows File Share/SMB
count: 3
--> IE.au3 T3.0-1 Error from function _IEPropertyGet, $_IESTATUS_InvalidObjectType
0
innerText:
count: 4
--> IE.au3 T3.0-1 Error from function _IEPropertyGet, $_IESTATUS_InvalidObjectType
0
innerText:

Any help will be appreciated!!!!!!

Edited by Melba23
Added code tags

Share this post


Link to post
Share on other sites

seeker0718,

Welcome to the AutoIt forums.

When you post code please use Code tags - see here how to do it.  Then you get a scrolling box and syntax colouring as you can see above now I have added the tags.

M23

 


Public_Domain.png.2d871819fcb9957cf44f4514551a2935.png Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind

Open spoiler to see my UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Deshanur
      Am trying to automate injecting credential on the login form for all kind of Web application for IE. I know how to identify the form name by viewing the source code and using the method - _IEFormGetObjByName($ie, $form_Name).
      I would like to know how to identify or get the form object for the web app where there is no form name tag for example below, for the is I have used - _IEFormGetCollection($ie, 0) to get the form object.
      My Question is does it work for all kind of application "_IEFormGetCollection($ie, 0)" how to identify Index value? is it always 0? is there any better solution?
      The final solution am looking for is find out form object, get the username, password field and inject credential and submit the form.
      How to find out index value? for the forms which does not have form name field.
      $login_form = _IEFormGetCollection($ie, 0) $email_field = _IEFormElementGetObjByName($login_form, $form_UserName) $pass_field = _IEFormElementGetObjByName($login_form, $form_password) $login_button = _IEFormElementGetObjByName($login_form, $form_submitbutton) _IEFormElementSetValue($email_field, $CmdLine[2]) _IEFormElementSetValue($pass_field, $CmdLine[3]) ControlSend($hwnd, "", "[CLASS:Internet Explorer_Server; INSTANCE:1]","{Enter}") OR This works fine if the form has form name. $login_form = _IEFormGetObjByName($ie, $form_Name) $email_field = _IEFormElementGetObjByName($login_form, $form_UserName) $pass_field = _IEFormElementGetObjByName($login_form, $form_password) $login_button = _IEFormElementGetObjByName($login_form, $form_submitbutton) _IEFormElementSetValue($email_field, $CmdLine[2]) _IEFormElementSetValue($pass_field, $CmdLine[3]) ControlSend($hwnd, "", "[CLASS:Internet Explorer_Server; INSTANCE:1]","{Enter}")
    • By devilspride
      The following code creates a IE blank window
      Local $oIE = _IECreate()  
      But when i use Navigate to the URL, it open the URL in Microsoft Edge instead if IE.
      _IENavigate($oIE,$url)  
      What should i do to navigate in IE.
      Complete code :
      #include <MsgBoxConstants.au3> #include <WinAPIFiles.au3> #include <IE.au3> #Region TESTING Local $url = 'https://www.youtube.com' Local $oIE = _IECreate() _IENavigate($oIE,$url) #EndRegion Console Output
      IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_ClientDisconnected (-2147023174, Browser has been deleted prior to operation.)  
      I have searched the forums but did not find such kind of post.
      Other posts were describing How to use Edge using Web driver selenium.
       
      Edit: I am working in Windows10. Recently many changes have been done by Microsoft to IE and Microsoft Edge. (2020)
      Earlier in 2019 this was working fine.
    • By Zaoka
      I'm trying to create script that would login on my SAP WEBI "web page" and replace some uploaded excel files. But i'm having problem on even the log in.
      These are user fill elements with Firefox Inspector
      <input type="text" id="_id0:logon:CMS" name="_id0:logon:CMS"> <input type="text" id="_id0:logon:USERNAME" name="_id0:logon:USERNAME"> <input type="password" id="_id0:logon:PASSWORD" name="_id0:logon:PASSWORD"> LogOnButton
      <input type="submit" id="_id0:logon:logonButton" value="Log On" class="logonButtonNoHover logon_button_no_hover" onmouseover="this.className = 'logonButtonHover logon_button_hover';" onmouseout="this.className = 'logonButtonNoHover logon_button_no_hover';">  
       
      My example, I tried _IEGetObjByName and _IEGetObjById but the script only open page but will not even fill out the form
        #include <IE.au3> Call("signIn") Func signIn() Global $oIE = _IECreate("http://192.xxx.xxx.xx:xxx/BOE/BI") Sleep (5000) Local $server = _IEGetObjByName($oIE, "_id0:logon:CMS") Local $username = _IEGetObjByName($oIE, "_id0:logon:USERNAME") Local $password = _IEGetObjByName($oIE, "_id0:logon:PASSWORD") Local $button = _IEGetObjById($oIE, "_id0:logon:logonButton") _IEFormElementSetValue($server, "TestServer:1000") _IEFormElementSetValue($username, "MyUserName") _IEFormElementSetValue($password, "MyPass") ; THIS PART ABOUT BUTTON CLICK I DONT UNDERSTAND AT ALL $sSelector = "body > div:nth-of-type(2) > div > div:nth-of-type(3) > div > table > tbody > tr > td > table > tbody > tr > td > table > tbody > tr:nth-of-type(1) > td > div > div:nth-of-type(1) > form > div:nth-of-type(5) > button" $signInUC = $oIE.document.QuerySelector($sSelector) _IEAction($signInUC, "click") EndFunc ;==>signIn  
      I would be very grateful for any help
    • By adityaparakh
      Hello ,

      A website I am trying to login with my credentials.
      And retrieve the cookie into a text file.
      Unable to do so.
      Is it that certain,  Httponly , type - are not allowed to be fetched.

      Then further ,
      I will be checking every 5 minutes if my session is active , else re-login and re-fetch the cookie.
      For the second part , I will probably fetch some table and see if not in appropriate format do Part 1 : Fetch Cookie - again.
      Any better way , tips would be appreciated.
       
      Thanks
       
    • By Jamestay97
      Hello! Thanks you for looking at my post
      **No source code I'm sorry work related can't copy information**
      I've been using autoit for about 1 year. 
      I'm having trouble automating a click on an internet explorer web page and I've tried a lot of examples from help pages and forums already. The object I'm trying to click on isnt always in the same spot so I can't use mouse click or control click, I have tried to use the different get collection options and clickbyname, or index or get object. I'm just struggling. 
      Description of object I'm trying to click -- 
      HTML Code looks like <a ng-click.. "Click Here" it appears it's just a click able object named "click here" that opens a hidden window by running a script inside the web page. I'm not able to grab the information from the window unless it's open so I have to automate this click somehow. 
       
      I understand it's difficult to assist without having something to look at, I apologize for that sincerely and appreciate and assistance and suggestions. 
×
×
  • Create New...