Jump to content

Recommended Posts

Does anyone here have experience using AutoIt on virtual Windows machines like in VirtualBox or Cloudify? I'm trying to write some AutoIt scripts but even the basic WinZip tutorial .au3 does not work on either a Windows 10 VM in VirtualBox (running over MacOS X) or on a Windows Server 2012 VM running on Cloudify/OpenStack. The Run("winzip90.exe") command works and launches the installer, but nothing I've tried to click the "Setup" button does anything. I've tried using "Send()" as documented in the tutorial, "ControlClick()", and even "MouseClick()" with coordinates but none of them seem to be clicking the button and making the install proceed.

I've found some posts here that refer to using AutoIt on AWS and VMware, so I suspect there might just be something I'd need to configure somewhere, though I can't figure out what it would be.

Link to post
Share on other sites
  • Moderators

I've run plenty of scripts on VirtualBox and VMware, though never on Cloudify. You are talking about running the script inside the VM, not from the host trying to control the VM, right?

"Profanity is the last vestige of the feeble mind. For the man who cannot express himself forcibly through intellect must do so through shock and awe" - Spencer W. Kimball

How to get your question answered on this forum!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RestrictedUser
      Hello AutoIt programmers🙃
      I don't know how can i aware of my Server IP Address changes
      I want to make program and start it in to check every 1 minute my Server and if IP Address changed then Send POST Action to this URL:
    • By Spartan117
      Hi everyone,
      I wonder if there is a cloud service that can offer a physical server so that AutoIT can turn as it is in a physical machine.
      Thank you
    • By cu0x
      I´m trying to get the Keyboard language and get als return "0" wenn I do it under Windows Server 2012, I executed also in Windows 7 x64 and works fine :S
      Any suggestion? Appreciate it!
      Here my code:
      #include <WinAPISys.au3> Run("cmd.exe", "", @SW_HIDE) Local $hWnd = WinWait("[CLASS:ConsoleWindowClass]") Local $bNewKey = "0" & StringRight(_WinAPI_GetKeyboardLayout($hWnd), 3) MsgBox(0,"Keyboard Language", $bNewKey) 
    • By adrigalilea
      Hi, im able to send or click on a vmware virtual machine, example:
      WinActivate("[TITLE:M1 - VMware Workstation]", "") MouseClick("Right",233, 979) Sleep(100) Send("x") But when it comes to controlclick, or controlsend nothing happens:
      Autoit window info: >>>> Window <<<< Title: M1 - VMware Workstation Class: VMUIFrame Position: -8, -8 Size: 1936, 1056 Style: 0x17CF0000 ExStyle: 0x00000100 Handle: 0x00000000000306D0 >>>> Control <<<< Class: MKSEmbedded Instance: 4 ClassnameNN: MKSEmbedded3 Name: Advanced (Class): [CLASS:MKSEmbedded; INSTANCE:4] ID: Text: MKSWindow#0 Position: 202, 94 Size: 1699, 884 ControlClick Coords: 456, 374 Style: 0x50000000 ExStyle: 0x00000000 Handle: 0x00000000000E0AC0 Tested controlclick and controlsend code:
        WinActivate("[TITLE:M1 - VMware Workstation]", "") $tempo = ControlSend("M1 - VMware Workstation", "","","ic") $tempo = ControlClick("M1 - VMware Workstation", "","","left",1,456, 374) $tempo = ControlSend("[CLASS:MKSEmbedded; INSTANCE:4]", "MKSWindow#0","","x") $tempo = ControlSend("[CLASS:VMUIFrame]", "","","x") Thank you.
      EDIT: Tested sending something to VMWare and it worked, but when it comes to the actual virtual machine it keeps doing nothing.
      Tested code to send alt+h to vmware, not working when i try it with the virtual machine.
      $tempo = ControlSend("M1 - VMware Workstation", "","","!H") Ok, all control send are giving me a 0 as output wich means "Returns 0 if window/control is not found.", except the one thats being sent to VMWare software, wich gives me a 1, anyone able to help? :S
  • Create New...