Jump to content
Sign in to follow this  
RichardL

MouseMove didn't Move

Recommended Posts

RichardL

A few days ago I'd written an AutoIt program that drove a Target program to open/modify/save pictures.  (Don't want name it, looks like a normal windows application, has a ribbon the little shortcuts appear when you press alt.) Everything working well on  a VM (WServer 2012 I think.)  Then I moved it to a real computer, Lenovo Think Center Windows 8.1, and the MouseMove stopped working.  The MouseMove worked as normal if anything else had the focus (Explorer, Paint, TaskMgr).  If Target had the focus the mouse did not move.  I tried all 3 values for MouseCoordMode.  Tried 32 bit and 64 bit compile.

There's a topic somewhere about the mouse not moving, but MouseGetPos says it's moved.   I tried that and it showed the mouse had not moved.

For a few moments I thought of alternately activating another window to move the mouse, then activate Target, but that was too horrible.

We went around the problem by moving to a different computer, Windows Server 2012 again, and everything was fine. 'Target' is the same version in all cases.  I've worked with it a few times before, never had any problems.

I don't need this solved but I'd be interested to know why.

Share this post


Link to post
Share on other sites
DarkDragon

RichardL can you please post the script. Have you checked that the screens have the same resolution?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • Lecdev
      By Lecdev
      Can anyone tell me the default parameter to input into, GUISetOnEvent($GUI_EVENT_MOUSEMOVE, "")  to disable a previously set user defined function?
      help file example says empty string ("") which works for other events but doesnt seem to on mouse move.
      Ive attached some of my test code to select icon by clicking and click on screen where needed to create an icon the same or cancel by right clicking and then escape the window with the keyboard escape key. best solution i have come up with after a few hours of trying different things is to create a DoNothing() function
       
      any help would be appreciated.
      dummy2.au3
    • LegitStack
      By LegitStack
      So I'm trying to make a script that will move my mouse when I scroll. I know that's weird, but I have my reasons. What I have so far can detect when I'm moving my mouse, but then when I tell the script to make my mouse move whenever it detects scroll activity it freezes. probably because of some feedback loop.
      Anyway, If anyone on here wants to help, I'm at a loss of how to solve this problem. Like maybe when it is about to take the action of moving the mouse it could stop detection for a bit, idk. but I don't know how to do that.
       
       
      #include <GUIConstantsEx.au3> #include <StaticConstants.au3> #include <WindowsConstants.au3> #include <WinAPI.au3> #include <MsgBoxConstants.au3> #include <Misc.au3> #include <GUIConstants.au3> Global Const $MSLLHOOKSTRUCT = $tagPOINT & ";dword mouseData;dword flags;dword time;ulong_ptr dwExtraInfo" Global $currentEvent Global $hDLL = DllOpen("user32.dll") #Region ### START Koda GUI section ### Form= ;Register callback $hKey_Proc = DllCallbackRegister("_Mouse_Proc", "int", "int;ptr;ptr") $hM_Module = DllCall("kernel32.dll", "hwnd", "GetModuleHandle", "ptr", 0) $hM_Hook = DllCall("user32.dll", "hwnd", "SetWindowsHookEx", "int", $WH_MOUSE_LL, "ptr", DllCallbackGetPtr($hKey_Proc), "hwnd", $hM_Module[0], "dword", 0) #EndRegion ### END Koda GUI section ### While 1 WEnd Func _Mouse_Proc($nCode, $wParam, $lParam) Local $info, $mouseData If $nCode < 0 Then $ret = DllCall("user32.dll", "long", "CallNextHookEx", "hwnd", $hM_Hook[0], _ "int", $nCode, "ptr", $wParam, "ptr", $lParam) Return $ret[0] EndIf $info = DllStructCreate($MSLLHOOKSTRUCT, $lParam) $mouseData = DllStructGetData($info, 3) Select Case $wParam = $WM_MOUSEWHEEL If _WinAPI_HiWord($mouseData) > 0 Then ;Wheel Up $currentEvent = "WheelUp" Else ;Wheel Down $currentEvent = "WheelDown" If _IsPressed("02", $hDLL) Then MsgBox(0,"test","test") EndIf EndIf EndSelect ;;;;;;Mouse Movement CAUSES FREEZING, MAKES ME RESTART COMPUTER: if $currentEvent == "WheelUp" then $pos = MouseGetPos() MouseMove($pos[0]+100,$pos[1]+100,0) EndIf $ret = DllCall("user32.dll", "long", "CallNextHookEx", "hwnd", $hM_Hook[0], _ "int", $nCode, "ptr", $wParam, "ptr", $lParam) Return $ret[0] EndFunc ;==>_Mouse_Proc Func OnAutoItExit() DllCall("user32.dll", "int", "UnhookWindowsHookEx", "hwnd", $hM_Hook[0]) $hM_Hook[0] = 0 DllCallbackFree($hKey_Proc) $hKey_Proc = 0 EndFunc ;==>OnAutoItExit  
    • Miliardsto
      By Miliardsto
      Hello I got this script works below and I want to do not move cursor on screen when action is performed.
      Opt("MouseCoordMode", 1) ; cause it gets whole screen coords Local $x, $y Local $search = _ImageSearch('item.bmp', 0, $x, $y, 0) If $search = 1 Then MouseMove($x, $y,0) MouseClick("right", $x, $y)) MouseMove($xMiddle, $yMiddle,0) MouseClick("left", $xMiddle, $yMiddle) EndIf I changed this above to this below and what happen is. It clicks right button and then left button but not move mouse to $x $y and then to $xMiddle $yMiddle.
      Opt("MouseCoordMode", 1) ; cause it gets whole screen coords Local $x, $y Local $search = _ImageSearch('item.bmp', 0, $x, $y, 0) If $search = 1 Then ControlClick("","",0,"secondary",1,$x,$y) ControlClick("","",0,"primary",1,$xMiddle,$yMiddle) EndIf If needed I got handle in var $hwnd
      Please tell me how parameters in ControlClick would like be
    • Fuzy
      By Fuzy
      #include<img/img.au3>
      #include <AutoItConstants.au3>
      Func Skype()
      $coords = imageSearch(0,0,-1,-1,"Skype.PNG")
      MouseMove($coords[0],$coords[1])
      [when it find the skype icon i want it to move from these coordinates, but of insted of moving to an expecific coordinate i want it to move down from these coordinates, (there is multiple images so i cant move to an specific image)] -- Kinda having trouble telling what i want cuz english isnt my first language, sorry about that. ;X
      MouseClick($MOUSE_CLICK_LEFT)
    • jannikrendl
      By jannikrendl
      Hey,
      so I was trying to create a script which clicks an option of a dropdown menu but can't find a solution to move the mouse from the current position 50 units down...
      If someone knows how to do this pls help me
      [EDIT: MBY the solution is to just use MouseGetPos and then use MouseMove(MouseGetPos[0],MouseGetPos[1]+50)? but idk... mby there is a better solution...
      Global $aPos = MouseGetPos Sleep(10000) MouseMove($aPos[0],$aPos[1]+50,10) ] Edit 2: NOPE Isn't working...
      Thanks in advance
      Jannik
×