Jump to content
Sign in to follow this  
sui

Help image search

Recommended Posts

Run the script through the Tidy program.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

RTFC i did 

i tryed 1 space 2 space and 0 space none of them worked same error

Edited by sui

Share this post


Link to post
Share on other sites

 

4 hours ago, BrewManNH said:

Run the script through the Tidy program.

tidy programm what is that and for what is it if i can ask 

Share this post


Link to post
Share on other sites
1 minute ago, Earthshine said:

 So, it’s not compiling built-in auto ID code?

sorry sir i am a newbie to this programm i am learning and i dont know what you mean by that sorry :(

Share this post


Link to post
Share on other sites
5 minutes ago, sui said:

5ac2bbb1de913_HELP2.png.d03727f0328997ac0162e20316327218.png

this is the code i write 

is it wrong ?

this is the script that is not working 

Share this post


Link to post
Share on other sites
1 minute ago, Earthshine said:

 Yeah I think you need to pass something by reference. Check the arguments you’re passing to that function

sorry didnt understand well what do i need to pass

Share this post


Link to post
Share on other sites
1 minute ago, Earthshine said:

 It takes five arguments and you’re passing sex with an extra zero at the end and the other zero is the faulted you don’t even need it 

ohh i am sorry i just wanted to be respectful

madame ?

 

the 0 at MSGBox ? i dont need that one?

Share this post


Link to post
Share on other sites

#include "ImageSearch.au3"

$x1=0
$y1=0

$picture = "C:\Users\SUI\Desktop\image blue\draft.png"
Do
    $result = _ImageSearch($picture,1,$x1,$y1,0,0)
    ;_ImageSearch($findImage, $resultPostion, ByRef $x, ByRef $y, $transparency = 0)

    ConsoleWrite($result)
Until $result = 1;
If $result=1 Then

    MouseMove($x1,$y1,50)
Else
    MsgBox(0,"MSG","End")
    EndIf

 

like this ?

i only know how to copy past the script 

Share this post


Link to post
Share on other sites
1 minute ago, Earthshine said:

_ImageSearch($picture,1,$x1,$y1)

help123.thumb.png.9c27cbfeb875468d399f969103c162ed.png

this is the new error 

i deleted the 2- 0 on the end 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...