Jump to content

Recommended Posts

Something simple enough, and I am sure it's an oversight, but I have not been able to track this down. The entire script is attached, but here is the point of failure.

Note: I am getting the "Error: subscript used on non-accessible variable" but I thought the initial line of:

AutoItSetOption('MouseCoordMode', 0)

Should address that issue? 

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

; Install updates (minimized and updating for many minutes)
; Updates Not Installed Screen
   ; Wait for updates to complete
WinWait("ProSeries Update")

   ; Wait just over 9 minutes to ensure popup is ready (test alternative to WinWait)
Sleep(550000)

   ; Set focus on Product Licenses window
WinActivate("ProSeries Update")

   ; Send Mouse Click to Install Now button

MouseClick ( "left" [, 581, 362 [, clicks = 1 [, speed = 10]]] )

; end Installing Updates screen

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

 

Thanks for any insights!

c1one

ProSeries2017_No_Customer_Info.au3

Share this post


Link to post
Share on other sites

Udpate, tried with simpler:

 

MouseClick("left", 580, 360, 50)

 

Now, not getting an error, but the installer is not advancing.

Notes: 

1. Verified the Window Information tool was set to "Window" and verified coordinates few times as I moved the window around the screen.

2. Verified I am looking at the mouse tab as well as the position information there.

Share this post


Link to post
Share on other sites

Why 50 clicks?


Spoiler

Renamer - Rename files and folders, remove portions of text from the filename etc.

GPO Tool - Export/Import Group policy settings.

MirrorDir - Synchronize/Backup/Mirror Folders

BeatsPlayer - Music player.

Params Tool - Right click an exe to see it's parameters or execute them.

String Trigger - Triggers pasting text or applications or internet links on specific strings.

Inconspicuous - Hide files in plain sight, not fully encrypted.

Regedit Control - Registry browsing history, quickly jump into any saved key.

Time4Shutdown - Write the time for shutdown in minutes.

Power Profiles Tool - Set a profile as active, delete, duplicate, export and import.

Finished Task Shutdown - Shuts down pc when specified window/Wndl/process closes.

NetworkSpeedShutdown - Shuts down pc if download speed goes under "X" Kb/s.

IUIAutomation - Topic with framework and examples

Au3Record.exe

Share this post


Link to post
Share on other sites
3 hours ago, Earthshine said:

use silent install of installer instead of automation of installer

I wish, we typically do that, we have around 500 applications packaged for SCCM, but this is pretty much the only one that has to be done manually, partially because of the updater. 

Share this post


Link to post
Share on other sites

you could use the Information Tool to capture the buttons and controls you want to control, and then talk direct to them maybe?


My resources are limited. You must ask the right questions

 

Share this post


Link to post
Share on other sites
1 hour ago, Earthshine said:

you could use the Information Tool to capture the buttons and controls you want to control, and then talk direct to them maybe?

Typically I use:

Send("!N")

or a tab space or tab enter:

Send("{TAB}")
Send("{SPACE}")

But, this installer is a real nightmare. There is no "button" just a giant panel when attempting to get button info with the tool.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By lunarlattice
      Hi All,
      I am trying to login into our application using AutoIT. When I launch the application a splash screen appears and the login screen goes behind it. At this point the script pauses and I loose control of everything. I have literally tried everything for the past two days but nothing has worked yet. Any suggestions would be appreciated.
      RunWait("\\mchsv411.siplaceworld.net\splmshare\int00\conf\start_apps\windows\start_nx110.bat en portal_client int00 tc112", "", @SW_MAXIMIZE)
      AutoItSetOption("SendKeyDelay", 200)
      Local $hWnd = WinWaitActive("Teamcenter Login")
      MouseClick("left", @DesktopWidth / 2, @DesktopHeight / 2)
      The splash screen has title "Teamcenter" and is static.
      I tried to click on the center to get control of login window.
      I have tried WinActivate, WinSetState, ControlCommand and a lot of other things.
    • By lonardd
      Hi,
      I have a very strange problem concerning MouseClick function.
      I need to start Control Panel, navigate it on the Display Section (Adjust screen resolution link), click on it, and from the next Dialog choose Intel Graphic tool tab and navigate into it when it opens. 
      I wasn't using MouseClick() at first when I tried to use Control IDs, but I was fed up with the Autoit Window Info poor and inaccurate info (It flickers and the moment I click on the control the control ID and class disappear) so I ended up choosing the easiest way.
      The code I'm posting worked OK until two weeks ago, the mouse clicks were accurately performed and the Script reached the end with no errors...and I was happy.
      All of a sudden, between one try and the other, I noticed the cursor not flying exactly where it was supposed to, namely to the Control Panel ->Display->Adjust screen resolution link   but it clicked some 30 pixels below and some 30 pixels to the left, choosing obviously and undesired function and from that point it screwed the whole thing up. And from that moment onward, it seems I can no longer regain the mouse to click on that sequence.
      Could it be because my Control Panel ->Display form moved slightly from one test to another and therefore I got that small offside?
      If you believe this is the reason, I should then re position the Control Panel ->Display window to 0,0 and recalculate all the clicks. 
      do you have a suggestion?
       
      Thanks a lot
      Dave
       
       
       
      RotateDisplays.au3
    • By dadalt
      Hi!
      I have a button where I need to close it!
      I was doing through  clicking same position in screen but there are some id's that have different sizes.
      What are the possible ways to click this closable button?
      Is there a way to close it through id? Is there a way to get it's position through it's ID?  
      Thanks in advance!


    • By Miliardsto
      Hello I got this script works below and I want to do not move cursor on screen when action is performed.
      Opt("MouseCoordMode", 1) ; cause it gets whole screen coords Local $x, $y Local $search = _ImageSearch('item.bmp', 0, $x, $y, 0) If $search = 1 Then MouseMove($x, $y,0) MouseClick("right", $x, $y)) MouseMove($xMiddle, $yMiddle,0) MouseClick("left", $xMiddle, $yMiddle) EndIf I changed this above to this below and what happen is. It clicks right button and then left button but not move mouse to $x $y and then to $xMiddle $yMiddle.
      Opt("MouseCoordMode", 1) ; cause it gets whole screen coords Local $x, $y Local $search = _ImageSearch('item.bmp', 0, $x, $y, 0) If $search = 1 Then ControlClick("","",0,"secondary",1,$x,$y) ControlClick("","",0,"primary",1,$xMiddle,$yMiddle) EndIf If needed I got handle in var $hwnd
      Please tell me how parameters in ControlClick would like be
    • By fchelp
      Hi,
      I'm trying to get the value of
      WinTitleMatchMode so i checked the help file, and it says  "If the param is not provided, then the function just returns the value already assigned to the option."
      So i'm running this line in SciTE
      AutoItSetOption( "WinTitleMatchMode" ) And am checking the output, but the only output i'm getting is 
      What am i doing wrong?
      I'm trying to set it that it should do exact match on titles, but i want to see first what is the current setting.
      Thanks in advance!
×
×
  • Create New...