Jump to content
JackER4565

Getting info from a website with arrays and table read (Optimize my code)

Recommended Posts

Hi, first of all thanks to all the guys who always help people in the forums, I wouldn't be able to do anything if wasn't for your help, even if I don't ask it myself.

 

I've created this code to get some info on a monitoring network on my work. It relays on _IETableGetCollection and _IETableWriteToArray.

It works well, but take around 3:25 minutes to get the info from 28 pages (some of them are large and take longer to load, but most of them are small and fast).

My question is if you see a way to get the program to go faster...

 

I've tried to make it easy for you to understand and edited somethings with sensitive info.

(Some of the pages doesn't have the black divider with MIRA in the end, so I need to search if it is there or not.)

 

#include <IE.au3>
#include <array.au3>

Local $oIE = _IECreate("about:blank", 0, 0)
Local $paginas[28] = [89, 90, 91, 92, 93, 96, 105, 113, 119, 125, 126, 129, 131, 133, 135, 137, 139, 140, 141, 144, 145, 146, 148, 149, 150, 151, 158, 159]
Local $Datos_array[0][2]
Local $oTable
Local $tabla
Local $aux_x = 1
Local $ar = 1
Local $Numtables_datos = 0
MsgBox(0, "asd", "asd")
For $pag = 0 To UBound($paginas) - 1 Step 1
    _IENavigate($oIE, "<WEBSITE URL>" & $paginas[$pag]) ; <<< the pages to load are always the same except for the last digits.


    _ArrayAdd($Datos_array, $paginas[$pag] & "|" & "Entrante", 0, "|") ; <<<<<<<<<<<<<<<< adds the page number toarray  [0, 0] 

    ;############################################ START counts amount of tables with traffic
    $oTable = _IETableGetCollection($oIE)
    Local $iNumTables = @extended
    For $i = 3 To $iNumTables - 2 Step 1
        $oTable = _IETableGetCollection($oIE, $i)
        $nomb_tabla2 = _IETableWriteToArray($oTable) ; <<<<<<<< TABLE TO ARRAY.
        $string2 = StringStripWS($nomb_tabla2[1][0], 8)
        If $string2 <> "MIRA" Then $Numtables_datos = $Numtables_datos + 1
    Next
    $tabla_End = $iNumTables - $Numtables_datos
    ;############################################ FIN

    $tabla_Start = 4
    $tabla_trafico = 2
    For $for = 1 To $Numtables_datos Step 1

        $oTable = _IETableGetCollection($oIE, $tabla_Start - 1) ; <<<<<<<<<<< NAME OF THE TABLE; row2 = mira

        $nomb_tabla = _IETableWriteToArray($oTable) ; <<<<<<<< TABLE TO ARRAY

        ;########################################### ADDS the traffic number into the row
        $string = StringStripWS($nomb_tabla[1][0], 8)
        If $string == "MIRA" Then
            ;si o si pasa por aca 1 vez
            _ArrayAdd($Datos_array, $nomb_tabla[0][0])
            $nomb_aux = $nomb_tabla[0][0]
            $aux_x = 1
            $tabla_trafico = $tabla_trafico + 2
        Else
            ;esto deberia ser por row
            _ArrayAdd($Datos_array, $nomb_aux & " " & $aux_x)
            $aux_x = $aux_x + 1
            $tabla_trafico = $tabla_trafico + 1
        EndIf

        $oTable = _IETableGetCollection($oIE, $tabla_trafico)
        Local $aTableData = _IETableWriteToArray($oTable)

        $bps = _ArrayToString($aTableData, "|", 0, 0, @CRLF, 0, 0)
        $bps = StringRight($bps, 5)
        $bps = StringLeft($bps, 4)
        $trafico_actual = _ArrayToString($aTableData, "|", 0, 0, @CRLF, 2, 2)
        If $bps == "Gbps" Then $trafico_actual = $trafico_actual * 1000
        If $bps == "Kbps" Then $trafico_actual = $trafico_actual / 1000
        $Datos_array[$ar][1] = $trafico_actual
        $ar = $ar + 1

        If $string == "MIRA" Then

            $tabla_Start = $tabla_Start + 2
        Else
            $tabla_Start = $tabla_Start + 1
        EndIf
    Next
    $ar = $ar + 1




;~ ############# CAÍDA ############
;~          If $actual_entrante = 0 Then
;~              $xxx = 0
;~              Do

;~              MsgBox(0, "Tráfico Caído", $paginas[$i], 5)
;~                  $xxx = $xxx + 1
;~              Until $xxx = 10
;~          EndIf
;~ ############# CAÍDA ############.
    Local $Numtables_datos = 0
Next
_ArrayDisplay($Datos_array, "Array display")
_IEQuit($oIE)

Thanks!! 

array output.png

WEB SCREENSHOT2.png

monitoria.html

Edited by JackER4565

Share this post


Link to post
Share on other sites
16 hours ago, Danp2 said:

You could likely shave off some time by loading some of the slower pages in a background tab and then using _IEAttach to select them as needed.

good idea, will try it and share the results!

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ahha
      Okay I know this will be one of those - how stupid can I be when I see the answer but I'm baffled at the current time.
      #include <Debug.au3> Local $aArray[11][2] = [ [10,10],[1,5],[2,0],[3,0],[4,"M"],[5,0],[6,0],[7,0],[8,"M"],[9,0],[10,2] ] _DebugArrayDisplay($aArray, "$aArray") Local $iCount = 0 ;init Local $i For $i = 1 to $aArray[0][0] If $aArray[$i][1] = "M" Then $iCount = $iCount + 1 ;debug ;MsgBox($MB_OK + $MB_TOPMOST, "Debug", "$aArray[$i][0] = " & $aArray[$i][0] & @CRLF & "$aArray[$i][1] = " & $aArray[$i][1]) EndIf Next MsgBox($MB_OK + $MB_TOPMOST, "Info", "M's found = " & $iCount) When I run this it states there are 8 M's in the array.
    • By D2thunder
      Hi all, I wasnt active in this Forum forum for Years. 😅
      Since I need something with Json in AutoIt i write a little UDF to save a variable to file to read it with another language - and back. After a while until my other script grows i thought - lets integrate all variables wich is possible, because i want have arrays to.
      This is my first public UDF in Autoit - normaly my AutoIt scripts are quick an dirty.... - like the examples for this udf. - someone want to write nice examples?
      I tried to write this UDF properly, cared for processing speed, low mem consumption as possible, a short code, and a high usability without beeing very familiar with arrays.
      What is it for? - convert nearly all types of variables to a json string for saving it in a file or to an ini. Read it back in to a same formated variable and preserv variable types. All array types are supported with nested arrays, the only restriction is ram and array/stringsize - and time if the array is very big. You can use Filters for variable types and some other options.
      If anyone found a bug or any suggestions, please post it.
       
      get Json.au3 from here Json.au3
       
       
      JsonVar 2019.01.25.1.zip
    • By Ho3ein
      Hi, i have a source code of "Danny35d" and i have 2 main question that are:
       How to extract this function's results (Datas are as Array) to combo-box without set number of datas?  When i type 1, 2 in _SystemUsers($AccountType = 0) to get only Local or Domain users, it just give me both of them, it's old problem of this function, please share us debugged code :)❤ #include <Array.au3> $Users = _ArrayToString(_SystemUsers(), "|", 1) ConsoleWrite($Users & @CRLF) #cs =============================================================================== Function: _SystemUsers($AccountType = 0) Description: Return an array with the local or domain username Parameter(s): $AccountType: Local, domain or both username 0 = Local and Domain usernames 1 = Local usernames only 2 = Domain usernames only Returns: An array with the list of usernames - Succeeded @error 1 - Didn't query any username @error 2 - Failed to create Win32_SystemUsers object @error 3 - Invalid $AccountType Author(s): Danny35d #ce =============================================================================== Func _SystemUsers($AccountType = 0) Local $aSystemUsers Local $wbemFlagReturnImmediately = 0x10, $wbemFlagForwardOnly = 0x20 Local $colItems = "", $strComputer = "localhost" If Not StringRegExp($AccountType, '[012]') Then Return SetError(3, 3, '') $objWMIService = ObjGet("winmgmts:\\" & $strComputer & "\root\CIMV2") $colItems = $objWMIService.ExecQuery("SELECT * FROM Win32_SystemUsers", "WQL", _ $wbemFlagReturnImmediately + $wbemFlagForwardOnly) If IsObj($colItems) Then For $objItem In $colItems $Output = StringSplit($objItem.PartComponent, ',') If IsArray($Output) Then $Temp = StringReplace(StringTrimLeft($Output[2], StringInStr($Output[2], '=', 0, -1)), '"', '') If $AccountType = 0 Or ($AccountType = 1 And @ComputerName = $Temp) Then $aSystemUsers &= StringReplace(StringTrimLeft($Output[1], StringInStr($Output[1], '=', 0, -1)), '"', '') & '|' ElseIf $AccountType = 2 And @ComputerName <> $Temp Then $aSystemUsers &= StringReplace(StringTrimLeft($Output[1], StringInStr($Output[1], '=', 0, -1)), '"', '') & '|' EndIf EndIf Next $aSystemUsers = StringTrimRight($aSystemUsers, 1) If $aSystemUsers = '' Then Return(SetError(1, 1, $aSystemUsers)) Return(SetError(0, 0, StringSplit($aSystemUsers, '|'))) Else $aSystemUsers = '' Return(SetError(2, 2, $aSystemUsers)) EndIf EndFunc ;==>_SystemUsers Thanks to your best Team.
    • By moimon
      Hi all. 
      Sorry if my words are confusing because I am not good at English.
      I am writing code to embed website with Recaptcha in GUI. And then, the code will automatically press the "I'm not a robot" button. The problem here is:
         - The code still works fine when entering iFrame to interact with Recaptcha with the URL is "https://www.google.com/recaptcha/api2/demo"
      <snip>
       
         - But for other URLs (such as "https://recaptcha-demo.appspot.com/recaptcha-v2-checkbox.php"), the code cannot be entered into the iframe.
       
      Code:
      <snip>  
      I did a lot of research but didn't know why.
       I sincerely thanks for the help. 
    • By SkysLastChance
      I am pretty sure the site that I am using was updated and now I am not seeing the same tags/elements that I used to. I tried using a UIAspy to see if I could grab them that way with no luck. 
      What do I need to do to be able to automate this again. Are the elements hidden somewhere?
      Instead of highlighting established account is highlights all of the web page almost. How can I get to the detail again? 
      I used to grab establish account by the name. Now I have nothing to even try to grab. 
      There are not elements in the event viewer either. 
       


       
      This is what happens when I try to inspect the element and click established account. 
      I get the same type of results in chrome
×
×
  • Create New...