Jump to content

Runtime issue with Robot Framework 4


Recommended Posts

Hello,

I have an execution problem with Robot Framework 4.


I work in the environment below:
- 64-bit Python
- windows 10
- Robot Framework 4

I created a script with Robot Framework 4 and created a shell to run the script and got the error message below.

Script

*** Settings ***
Library           AutoItLibrary

*** Variables ***
${app}            C:/Program Files/Notepad++/notepad++.exe

*** Test Cases ***
TC1 - Enter text
    Run    ${app}
    Send    This is just a test.

 

Batsh

Write-Host "Congratulations! Your first script executed successfully"
python "C:\\Python37\\Lib\\site-packages\\win32com\\client\\makepy.py" "C:\\Python37\\Lib\\site-packages\\AutoItLibrary\\lib\\AutoItX3.dll"
robot "c:\WK\Test_Automation\Runs\Regression\Test.robot"

 

Error Message

[ ERROR ] Error in file 'c:\WK\Test_Automation\Modules\Script.robot' on line 10: Initializing library 'AutoItLibrary' with no arguments failed: com_error: (-2147221005, 'Invalid class string', None, None)
Traceback (most recent call last):
  File "c:\python37\lib\site-packages\AutoItLibrary\__init__.py", line 84, in __init__
    self._AutoIt = win32com.client.Dispatch("AutoItX3.Control")
  File "c:\python37\lib\site-packages\win32com\client\__init__.py", line 95, in Dispatch
    dispatch, userName = dynamic._GetGoodDispatchAndUserName(dispatch,userName,clsctx)
  File "c:\python37\lib\site-packages\win32com\client\dynamic.py", line 98, in _GetGoodDispatchAndUserName
    return (_GetGoodDispatch(IDispatch, clsctx), userName)
  File "c:\python37\lib\site-packages\win32com\client\dynamic.py", line 83, in _GetGoodDispatch
    IDispatch = pythoncom.CoCreateInstance(IDispatch, None, clsctx, pythoncom.IID_IDispatch)
==============================================================================
Test Blocnote :: Here is the test suite documentation to be completed           
==============================================================================
COMPUTERNAME=********
TC1 - Enter Text-
| FAIL |
No keyword with name 'Send' found. Did you mean:
    FakerLibrary.Seed

Thank you in advance for solving my problem

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...