Sign in to follow this  
Followers 0
jpm

Autoit-gui 101.18 Available

105 posts in this topic




#22 ·  Posted

@jpm: where?  :D there's still the 'old' version...

Sorry,

I did something wrong now you get a .zip with the .exe and the .bin :huh2:

Share this post


Link to post
Share on other sites

#23 ·  Posted

The main reason I care about the combo box is because your change-log says it is "fixed."  Remove the change-log entry and I'll be happy :D

I posted screen shots here.  Tested with AutoGUI 102.18A on Windows XP Pro sp1 (but using windows 2000 theme)

Do I understand, you get the same size when maximizing.

When I click the maximize button I get a full screen image with the XP theme not a small one as yours.

I put 2 .png files in the AutoIt-gui download area showing what I get :huh2:

Share this post


Link to post
Share on other sites

#25 ·  Posted

Thank you jpm, now it works as expected! I'll continue testing.

BTW confirm bug with combo on same system (WinXP Pro with "classic" theme). More clear, bug appear when you maximize window and then restore this (with buttons or by double-clicking title).

What is the bug?

I test I cannot have the image as shown by CyberSlug.

You can see that my maximize is much bigger than the one of CyberSlug

can you email me your before after image

Thanks :D

Share this post


Link to post
Share on other sites

#26 ·  Posted

Sorry if the image was misleading.

The problem is not the window size; the problem is the combo control not re-painting properly.

In fact, gui 102.18A seems to more problems with repaint than 102.17

I'll post some low-res screenshots showing AutoPad problems:

look at bugInfo.html


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

#27 ·  Posted

@jpm: Thxs for the update! AutoIT3-GUI grows!! :):D

Only that, I discover two mistakes (please, try the code):

- The last item dissapears if I don't add another "tabitem"

- The background not refresh correctly. In this case, I found a way to refresh, displaying a fast SplashText over the Form, but the simple way to refresh would be with the "BLUE" option. :huh2:

See the code (modified from the TAB example):

AutoItSetOption("TrayIconDebug", 1)
; --------------------------------------------------------------
Opt("GuiNotifyMode",1)
GUICreate("My GUI TAB", 220, 160)
GuiCreateEx("",0x00E0FFFF)
GUIDefaultFont(9, 300)

$button1=GUISetControl("tab", "tab", 10,10, 200,100)

; TAB 0
$tab0=GUISetControl("tabitem", "tab#0",0,0)
; TAB 1
$tab1=GUISetControl("tabitem", "tab#1",0,0)
GuiSetControlEx($tab1, 16)
$lab1= GuiSetControl("Label"," Set me a color ", 92, 51, 90, 20)
$combo=GUISetControl("combo","", 20, 50, 70, 80)
GuiSetControlData(-1,"Red|*Blue|Green")
$input1=GUISetControl("input","default", 20, 120,70,20)

;; In this case, I need only 2 tabs, but I have to put another TABITEM for show my last item ($input1 in this case).
$tab2= GUISetControl("tabitem", "", 0, 0)

While GuiMsg()
   If GUIRead($combo) then
      $col= GUIRead($combo)
      $_posw = WinGetPos("My GUI TAB")
      Select
         case $col= "Red"
            GUISetControlEX($lab1, -1, 0, "",0x00, 0xff)
            GUICreateEx(-1, 0xff)
           ; I use a Splash function for refresh the window.
            splashtexton(0, "", 220, 160, $_posw[0], $_posw[1])
            splashoff()
         case $col= "Blue"
            GUISetControlEX($lab1, -1, 0, "",0x00, 0xff0000)
            GUICreateEx(-1, 0xff0000)
         case $col= "Green"
            GUISetControlEX($lab1, -1, 0, "",0x00,0xff00)
            GUICreateEx(-1, 0xff00)
            splashtexton(0, "", 220, 160, $_posw[0], $_posw[1])
            splashoff()
         EndSelect
   EndIf
Wend

Share this post


Link to post
Share on other sites

#28 ·  Posted

not updated in v102.18? :D

(the background color in the checkboxes/labels when exists a TAB control)

taked and modified from a example:

AutoItSetOption("TrayIconDebug", 1)
FileChangeDir(@Scriptdir)
#include "Gui_include.au3"

; ----------------------------------------------------------------------------
; Script Start
; ----------------------------------------------------------------------------
;Test script to try and get a list box information updated
;by clicking on a button
Opt("GuiNotifyMode",1)
GUICreate("My GUI TAB"); will create a dialog box that when displayed is centered
GuiCreateEx("",0x00E0FFFF)

$button1=GUISetControl("tab", "tab", 10,10, 200,100)
;GUISetControlEx(-1,-1,0,"",-1,0xff)

$tab0=GUISetControl("tabitem", "tab0",0,0)

GuiSetControl("checkbox","checkbox", 20,150,90,20)
GuiSetControl("label","label", 20,130,90,20)

While GuiMsg()
 msgbox(0,"Click #",GuiRead(),2)
Wend

Share this post


Link to post
Share on other sites

#29 ·  Posted

not updated in v102.18?  :huh2:

(the background color in the checkboxes/labels when exists a TAB control)

taked and modified from a example:

AutoItSetOption("TrayIconDebug", 1)
FileChangeDir(@Scriptdir)
#include "Gui_include.au3"

; ----------------------------------------------------------------------------
; Script Start
; ----------------------------------------------------------------------------
;Test script to try and get a list box information updated
;by clicking on a button
Opt("GuiNotifyMode",1)
GUICreate("My GUI TAB"); will create a dialog box that when displayed is centered
GuiCreateEx("",0x00E0FFFF)

$button1=GUISetControl("tab", "tab", 10,10, 200,100)
;GUISetControlEx(-1,-1,0,"",-1,0xff)

$tab0=GUISetControl("tabitem", "tab0",0,0)

GuiSetControl("checkbox","checkbox", 20,150,90,20)
GuiSetControl("label","label", 20,130,90,20)

While GuiMsg()
 msgbox(0,"Click #",GuiRead(),2)
Wend
Easy one,

The label and checkbox are part of the tabitem definition so they get by default the tab bakground color.

In fact the positioning is not relative to the tab control. It is the user reponsability to put it on the control tab :D

Share this post


Link to post
Share on other sites

#30 ·  Posted

@jpm: Thxs for the update!  AutoIT3-GUI grows!! :lol:  :huh2:

Only that, I discover two mistakes (please, try the code):

- The last item dissapears if I don't add another "tabitem"

- The background not refresh correctly. In this case, I found a way to refresh, displaying a fast SplashText over the Form, but  the simple way to refresh would be with the "BLUE" option. :)

See the code (modified from the TAB example):

AutoItSetOption("TrayIconDebug", 1)
; --------------------------------------------------------------
Opt("GuiNotifyMode",1)
GUICreate("My GUI TAB", 220, 160)
GuiCreateEx("",0x00E0FFFF)
GUIDefaultFont(9, 300)

$button1=GUISetControl("tab", "tab", 10,10, 200,100)

; TAB 0
$tab0=GUISetControl("tabitem", "tab#0",0,0)
; TAB 1
$tab1=GUISetControl("tabitem", "tab#1",0,0)
GuiSetControlEx($tab1, 16)
$lab1= GuiSetControl("Label"," Set me a color ", 92, 51, 90, 20)
$combo=GUISetControl("combo","", 20, 50, 70, 80)
GuiSetControlData(-1,"Red|*Blue|Green")
$input1=GUISetControl("input","default", 20, 120,70,20)

;; In this case, I need only 2 tabs, but I have to put another TABITEM for show my last item ($input1 in this case).
$tab2= GUISetControl("tabitem", "", 0, 0)

While GuiMsg()
   If GUIRead($combo) then
      $col= GUIRead($combo)
      $_posw = WinGetPos("My GUI TAB")
      Select
         case $col= "Red"
            GUISetControlEX($lab1, -1, 0, "",0x00, 0xff)
            GUICreateEx(-1, 0xff)
          ; I use a Splash function for refresh the window.
            splashtexton(0, "", 220, 160, $_posw[0], $_posw[1])
            splashoff()
         case $col= "Blue"
            GUISetControlEX($lab1, -1, 0, "",0x00, 0xff0000)
            GUICreateEx(-1, 0xff0000)
         case $col= "Green"
            GUISetControlEX($lab1, -1, 0, "",0x00,0xff00)
            GUICreateEx(-1, 0xff00)
            splashtexton(0, "", 220, 160, $_posw[0], $_posw[1])
            splashoff()
         EndSelect
   EndIf
Wend
You kill me :)

I never thought that GuiCreateEx can be use dynamically. In fact it seems the last one. THe defaultfont will not update previous created control but that will work for new ones.

The doc never describe such think but why not.

Stay tune :D

Share this post


Link to post
Share on other sites

#31 ·  Posted

@josbe

you will get an almost perfect work with 102.18B and your updated script.

The extra tabitem was a bug.

I need somebody help me to find a simple way of painting the upper right corner not as the tab background but as the window background.

The standard way of window to redraw the whole part of the tab is too much code.

autoItSetOption("TrayIconDebug", 1)
; --------------------------------------------------------------
Opt("GuiNotifyMode",1)
GUICreate("My GUI TAB", 220, 160)
GuiCreateEx("",0x00E0FFFF)
GUIDefaultFont(9, 300)

$button1=GUISetControl("tab", "tab", 10,10, 200,100)

; TAB 0
$tab0=GUISetControl("tabitem", "tab#0",0,0)
; TAB 1
$tab1=GUISetControl("tabitem", "tab#1",0,0)
GuiSetControlEx($tab1, 16)
$lab1= GuiSetControl("Label"," Set me a color ", 92, 51, 90, 20)
$combo=GUISetControl("combo","", 20, 50, 70, 80)
GuiSetControlData(-1,"Red|Blue|Green")
$input1=GUISetControl("input","default", 20, 80,70,20)

While GuiMsg()
  If GUIRead($combo) then
     $col= GUIRead($combo)
     $_posw = WinGetPos("My GUI TAB")
     Select
        case $col= "Red"
           GUISetControlEX($lab1, -1, 0, "",0x00, 0xff)
           GUICreateEx(-1, 0xff)
        case $col= "Blue"
           GUISetControlEX($lab1, -1, 0, "",0x00, 0xff0000)
           GUICreateEx(-1, 0xff0000)
        case $col= "Green"
           GUISetControlEX($lab1, -1, 0, "",0x00,0xff00)
           GUICreateEx(-1, 0xff00)
        EndSelect
  EndIf
Wend

Share this post


Link to post
Share on other sites

#32 ·  Posted

Sorry if the image was misleading.

The problem is not the window size; the problem is the combo control not re-painting properly.

In fact, gui 102.18A seems to more problems with repaint than 102.17

I'll post some low-res screenshots showing AutoPad problems:

look at bugInfo.html

Have a look at 102.18B I think I solve all issues !!! :D

Share this post


Link to post
Share on other sites

#33 ·  Posted

I upload 102.18C fixing all known problems.

At least the one I know. :huh2:

Last one was the one of Condoman on GuiRead() after GuiWaitClose()

Good testing :D

Share this post


Link to post
Share on other sites

#34 ·  Posted (edited)

I hate to say it, but my combo-box in AutoPad still highlights when I resize the AutoPad window.... Maybe my AutoPad code is bad?

Otherwise, 102.18C is very good!!!

P.S. I tried 102.18B and all other versions. I have not changed AutoPad yet...

Edited by CyberSlug

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

#35 ·  Posted

I hate to say it, but my combo-box in AutoPad still highlights when I resize the AutoPad window.... Maybe my AutoPad code is bad?

Otherwise, 102.18C is very good!!!

P.S.  I tried 102.18B and all other versions.  I have not changed AutoPad yet...

I know but it looks like a MS something.

The focus stay on the control it is supposed to be but the combo hightlight.

Is it acceptable to stay in the current state? :D

Share this post


Link to post
Share on other sites

#36 ·  Posted

This maybe a dumb question, but how do you compile it to make an exe?

Share this post


Link to post
Share on other sites

#37 ·  Posted

...

The focus stay on the control it is supposed to be but the combo hightlight.

Is it acceptable to stay in the current state? :huh2:

That's fine--I can accept the behavior :D You have spent enough time on this!

And I think I can script a workaround...


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

#39 ·  Posted

That's fine--I can accept the behavior :huh2:  You have spent enough time on this!

And I think I can script a workaround...

Thanks for the quietus.

I notice that if you don't use the GuiNotifyMode=1 and set the notification on the specific control it could be better.

:D

Share this post


Link to post
Share on other sites

#40 ·  Posted

@jpm: Thxs for the replies.  :)

(Sorry for the constant questions.)

It's the way to improve...  :):lol:

:D You have not to fill sorry. Your are doing your betatester/improver job

I like your work and the way you make AutoIt-GUI improving :huh2:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0