Sign in to follow this  
Followers 0
LxP

Find Classes by Text (v1.2)

24 posts in this topic

Thanks that update works fine :).

Share this post


Link to post
Share on other sites



Hello,

I got the error when actived the windows to be captured. Please help me.

Thank you.

>"C:\Program Files\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "D:\Softwares\_AutoIt2_Scripts\FindClassesByText_new1.au3"

D:\Softwares\_AutoIt2_Scripts\FindClassesByText_new1.au3 (329) : ==> Subscript used with non-Array variable.:

If StringInStr($a_Item[0], "'") <> 0 Then

If StringInStr($a_Item^ ERROR

>Exit code: 1 Time: 12.049

Share this post


Link to post
Share on other sites

running the script seems to spit back info into the gui when focusing on normal windows (that also return data in the window info tool) however comes up with nothing on the windows that don't give anything in the win info tool either >.<

specificly - trying to get control id info for a World of warcraft window - by fluke or miracle i can controlsend keystrokes to it but controlclick won't work with the same logic - i assume because there are no controlclick cords in the win info tool :D

 

This script (like AutoIt Window Info) will only be useful for windows containing standard Windows controls.  Games tend to manage their own controls in a custom way.

Does this script still work? I tried it and I get an error about $GUI_SS_DEFAULT_GUI not being declared.

 

This problem was caused by AutoIt v3.2.12.0 making backwards-incompatible changes to some library files.  ptrex helpfully provided a fix I've now added this fix to the script available from the original post.

I intend to merge big_daddy's and MHz's copy-to-clipboard functionality into that script soon as well.

Share this post


Link to post
Share on other sites

#24 ·  Posted (edited)

Hi,

many thanks for the script, clicking "Copy to clipboard" returns

C:\Program Files\AutoIt3\Include\FindClassesByText.au3 (327) : ==> Subscript used with non-Array variable.:

If StringInStr($a_Item[0], "'") <> 0 Then

If StringInStr($a_Item^ ERROR

Is this still supported? Would be useful to have.

 

Hello,

I got the error when actived the windows to be captured. Please help me.

Thank you.

 

These problems have now been addressed with the release of v1.2, available from the first post in this thread.

v1.2 (29/May/2013):
  • Add "Copy Item" and "Copy All" buttons to copy information from the TreeView item to the clipboard (thanks to big_daddy for the idea)
  • Show control text as an AutoIt string definition (with macros as appropriate) instead of just naively wrapping it in single quotes
Edited by LxP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0