Jump to content
Sign in to follow this  
PaulIA

Auto3Lib

Recommended Posts

@Zedna: My bad, i ran it using "Beta Run" from SciTE. I was able to run it using the official release (3.2.6.0) but I got a lot of errors prior to running..

...

I am using Windows XP with SP2, with .NET 2.0, Autoit 3.2.6.0 / 3.2.7.3.

Did you delete the old version of Auto3Lib before installing the new one? Is the one in the \include\ folder the only version you have?

Share this post


Link to post
Share on other sites

Hi!

Me too: I desinstall AutoIt ; then I install 3.2.6.0 ; then I run Auto3lib, and I get the error (see gif attachment)

Thanks for the next...

You didn't follow the instructions - look at Post #822 and others after it.

Share this post


Link to post
Share on other sites

Hi PaulIA

When, I tried to install Auto3Lib on my pc, I get the error message saying that your version of AutoIt is older, so I downloaded the latest AutoIt version and installed it. However, I am still getting the error "Auto3Lib requires at least version 3.2.4.9 of AutoIt. Your version of AutoIt is v3.2.6.0"

Please help me.

Share this post


Link to post
Share on other sites

There is a hot-fix.au3

$sRegKey = "HKEY_LOCAL_MACHINE\SOFTWARE\AutoIt v3\AutoIt"
$sRegValue = "Version"
$sRegType = "REG_SZ"

$sCurrent = RegRead($sRegKey, $sRegValue)
RegWrite($sRegKey, $sRegValue, $sRegType, "v3.2.4.9")
MsgBox(0, "", "You are ready to install Auto3Lib." & @CRLF & @CRLF & _
        'Click "OK" when the installation is complete.')
RegWrite($sRegKey, $sRegValue, $sRegType, $sCurrent)

The point of world view

Share this post


Link to post
Share on other sites

hello,

I try to run a process in a new desktop into a SwitchDesktop but there's a problem (i think) with startupinfo :

#include <A3LWinAPI.au3>

$OriginalThread = DLLCall("kernel32.dll","int","GetCurrentThreadId")
$OriginalInput = DllCall('user32.dll', 'hwnd', 'OpenInputDesktop', 'int', 0, 'int', 0, 'int', 0x100)
$NouveauBureau = DLLCall("user32.dll","int","CreateDesktop","str","NouveauBureau", "str","","ptr",0,"int",0,"int",0x10000000,"ptr",0)
$Startup = DllStructCreate($tagSTARTUPINFO)
$Process = DllStructCreate($tagPROCESS_INFORMATION)
DllCall('user32.dll', 'int', 'SetThreadDesktop', 'hwnd', $NouveauBureau[0])
DLLCall("user32.dll","int","SwitchDesktop","int",$NouveauBureau[0])
DllStructSetData($Startup, "Size", DllStructGetSize($Startup))
DllStructSetData($Startup, "Desktop", DllStructGetData($Startup, "NouveauBureau"))
_API_CreateProcess("", "C:\Windows\Notepad.exe", 0, 0, False, 0, 0, "", DllStructGetPtr($Startup), DllStructGetPtr($Process))
Sleep(2000)
_API_CloseHandle(DllStructGetData($Process, "hProcess"))
_API_CloseHandle(DllStructGetData($Process, "hThread" ))
DLLCall("user32.dll","int","SwitchDesktop","int",$OriginalInput[0])
DllCall('user32.dll', 'int', 'SetThreadDesktop', 'hwnd', $OriginalThread[0])
DLLCall("user32.dll","int","CloseDesktop","int",$NouveauBureau[0])

Is there something wrong in my code or is it the startupinfo which block ?

Thanks :)

Share this post


Link to post
Share on other sites

Hum, another thing about the installer. I don't know if it has be said already, but I didn't try the 'temporary bug fix' at page 55. When it said that I have an old version I clicked cancel and then 'Exit setup' and it started installing :) Now it's installed...

Anyone esle noticed this?

Share this post


Link to post
Share on other sites

I just updated AU3 to 3.2.8.1 and now I can't Install A3Lib

Hi,

see post 822 of this thread.

So long,

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

A simple solution I found is without changing registry values.

I just discovered the installer bug that enable users to install it without having AutoIt v3.2.4.9.

Step:

1.)

The installer complaint about while you're trying to install:

[AutoIt Update Required

Auto3Lib requires at least version 3.2.4.9 of AuotIt.

...]

Just click on [Cancel] button.

2.)

The Auto3Lib Installer will say:

Setup is not complete...etc.

Click on the [Exit Setup] button.

3.)

Auto3Lib Setup Wizard come out, just click [Next >] to continue installation.

4.)

Repeat step 1 and step 2 if it is complaint AutoIt version again.

5.)

Continue setup until successful, then you're done.


[u]My Projects[/u]:General:WinShell (Version 1.6)YouTube Video Downloader Core (Version 2.0)Periodic Table Of Chemical Elements (Version 1.0)Web-Based:Directory Listing Script Written In AutoIt3 (Version 1.9 RC1)UDFs:UnicodeURL UDFHTML Entity UDF[u]My Website:[/u]http://dhilip89.hopto.org/[u]Closed Sources:[/u]YouTube Video Downloader (Version 1.3)[quote]If 1 + 1 = 10, then 1 + 1 ≠ 2[/quote]

Share this post


Link to post
Share on other sites

^Yeah, that's what I said a few posts above.

#402072

Opps....I don't see that. :)


[u]My Projects[/u]:General:WinShell (Version 1.6)YouTube Video Downloader Core (Version 2.0)Periodic Table Of Chemical Elements (Version 1.0)Web-Based:Directory Listing Script Written In AutoIt3 (Version 1.9 RC1)UDFs:UnicodeURL UDFHTML Entity UDF[u]My Website:[/u]http://dhilip89.hopto.org/[u]Closed Sources:[/u]YouTube Video Downloader (Version 1.3)[quote]If 1 + 1 = 10, then 1 + 1 ≠ 2[/quote]

Share this post


Link to post
Share on other sites

What can be said? The library is simply awsome! T-H-A-N-K-S !!!!!

Just a question: since I am running AutoIt as a regularly installed application and in the meantime as a portable app on my usb key drive, I would like to know whether I can simply install it twice: the first on the hard disk and the second onto the usb drive.

I would not like to mess up the configuration but taking away the library as well.

If it is not possible, might a zipped version be available?

Thanks in advance!

Share this post


Link to post
Share on other sites

Sorry that Elvis has left the building - Paul Campbell (PaulIA) did do a series of very nice functions that I find usefull alot..

The install bug could do that newbees newer get to know of these nice libraries and functions so I did a new installer that provide install / uninstaller script included - there has been no modifications at all...

Download or install new Autoit3Lib installer from site:

http://www.fritidshjemmet.com/Temp/Autoit3Lib.exe

Note: The install do only install includes into the public model like the original script

kjactive :)

Edited by kjactive

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...