Jump to content
Sign in to follow this  

Run parameters dont work from script

Recommended Posts

I seem to be having a problem running a program with command line parameters from my script. It works fine if I run from a cmd console, but when I run the following code from the script, the exe i'm trying to call says it cannot find the file specified.

Any ideas?

$GlovePieScriptFile = "Mario_swf"

RunWait('GlovePIE029\GlovePie.exe -' & $GlovePieScriptFile)

edit: fixed by adding GlovePIE029\ in front of $GlovePieScriptFile

Edited by Justin

Share this post

Link to post
Share on other sites


When I first used parameters I had the same problem... the correct way is to insert a space before the parameter and above all to formally put

it between quotes. The variable $GlovePieScriptFile = "kdmkfd" is in the command line interpreted without the quotes. That's why you have to add it again....

Try this :

RunWait('GlovePIE029\GlovePie.exe -' & " " & '"' & $GlovePieScriptFile & '"')

Rem : The double quote is enclosed in single quotes, that permits to make it visible



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...