Jump to content
Sign in to follow this  

Part of script only works on my own comp

Recommended Posts


Somehow the script works on the second xp based computer. I don't

know why, I needed to run the Ie in visible mode the first time, then

it worked. Anyhow, still problems with vista.

This part of my script does only work on my computer,

the one I'm scripting on. Tried vista ultimate and another

windows xp computer. On the second Xp comp the error msg show

"No '.torrent' links found". It dosnt open internet explorer, even if I

use $oIE = _IECreate($url, 0).

On the other hand, the vista comp executes internet explorer

and then does nothing.

Func RSS()
$Readrss = _guictrllistgettext($listbox2,0)
$url = "http://www.swedvdr.org/browse.php"
$oIE = _IECreate($url, 0,0)
$oForm = _IEFormGetCollection($oIE, 0)
$oSearchInput = _IEGetObjByName($oIE, 'Search')
_IEFormElementSetValue($oSearchInput , $Readrss)
$colLinks = _IELinkGetCollection($oIE)
_GUICtrlListAddItem($List1,"Laddar ner:" & $Readrss & ".torrent")

$sURL = ""
For $oLink In $colLinks
    $sURL = $oLink.href
    If StringInStr($sURL, "download.php?") Then ExitLoop

If $sURL <> "" Then
DirCreate(@HomeDrive & "\Temp\Torrent\")
$Torrentsave = (@HomeDrive & "\Temp\Torrent\download.torrent")
INetGet($sURL, $Torrentsave)
_GUICtrlListAddItem($List1,"Executar Utorrent")
    MsgBox(16, "Error", "No '.torrent' links found.")
_GUICtrlListAddItem($List1,"Error, Ingen .torrent funnen")
Edited by walle

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...