Jump to content
Sign in to follow this  
Jos

New Scite4AutoIt3 installer

Recommended Posts

BTW: I see AU3Check is 1.24, was Tylo too quick for ya by putting out 1.25?

<{POST_SNAPBACK}>

Yes, there is no way i can keep up with Tylo's versions of au3check at this moment. :lmao:

Everytime i release Scite4Autoit3.exe or Scite4AU3Upd.exe, it will contain the last one available at that time......


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

If you all want i could change Tidy to ignore lines starting with ;~ totally which would solve you issues ... right ???

<{POST_SNAPBACK}>

Thanks, I certainly would appreciate it.

Phillip

Share this post


Link to post
Share on other sites

Thanks, I certainly would appreciate it.

<{POST_SNAPBACK}>

ok ... here's the deal...

Just made a test version available which i only did some basic testing on..

Have a go with it and test it to see if it solves the issue and didn't break anything:

http://www.autoitscript.com/fileman/users/jdeb/test/tidy.exe

If its confirmed that it works, i will add this to the next version of the installer and put the default back to:

comment.block.at.line.start.au3=1


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

ok ... here's the deal... 

Just made a test version available which i only did some basic testing on..

Have a go with it and test it to see if it solves the issue and didn't break anything:

http://www.autoitscript.com/fileman/users/jdeb/test/tidy.exe

If its confirmed that it works, i will add this to the next version of the installer and put the default back to:

comment.block.at.line.start.au3=1

<{POST_SNAPBACK}>

Basic tests on my end also confirm no problems, I currently don't have the time to do a rigorous test of this yet. I'll make it sweat in the gym tomorrow. :lmao:

Lofting the cyberwinds on teknoleather wings, I am...The Blue Drache

Share this post


Link to post
Share on other sites

ok ... here's the deal... 

Just made a test version available which i only did some basic testing on..

Have a go with it and test it to see if it solves the issue and didn't break anything:

http://www.autoitscript.com/fileman/users/jdeb/test/tidy.exe

If its confirmed that it works, i will add this to the next version of the installer and put the default back to:

comment.block.at.line.start.au3=1

<{POST_SNAPBACK}>

Many thanks! My tests are all positive (with comment.block.at.line.start.au3 set to 1).

Phillip

Share this post


Link to post
Share on other sites

Am I the only one who has had my .au3 file associations changed so that the default action is Run the script... despite selected Edit the script when given the option in the SciTe installer? It seems to have happened with this newest release.

Share this post


Link to post
Share on other sites

Am I the only one who has had my .au3 file associations changed so that the default action is Run the script... despite selected Edit the script when given the option in the SciTe installer? It seems to have happened with this newest release.

<{POST_SNAPBACK}>

If you reinstalled Autoit after installing Scite, then it will change the setting to run. Here is a gui for changing it back to open.
#include <GUIConstants.au3>

#Region - GUI Create

GUICreate('Run or Open', 185, 100)
GUICtrlCreateLabel('Choose Default action for Au3 files', 10, 10)
$Checkbox_Open = GUICtrlCreateCheckbox('Open', 20, 35, -1, 15 )
$Checkbox_Run = GUICtrlCreateCheckbox('Run', 20, 60)
$Button_Go = GUICtrlCreateButton('Change', 130, 70)
#EndRegion

#Region - Check Registry

$read = RegRead('HKEY_CLASSES_ROOT\AutoIt3Script\Shell', '')
If  $read = 'Open' Then
    GUICtrlSetState($Checkbox_Open, $GUI_CHECKED)
Else
    GUICtrlSetState($Checkbox_Run, $GUI_CHECKED)
EndIf
#EndRegion

GUISetState(@SW_SHOW)

#Region - GUI SelectLoop

While 1
    $msg = GUIGetMsg()
    
    Select
        
        Case $msg = -3;$GUI_EVENT_CLOSE
            Exit
            
        Case $msg = $Button_Go
            If GUICtrlRead($Checkbox_Open) = $GUI_CHECKED Then
                RegWrite('HKEY_CLASSES_ROOT\AutoIt3Script\Shell', '', 'reg_sz','Open')
                $read = RegRead('HKEY_CLASSES_ROOT\AutoIt3Script\Shell', '')
                If  $read = 'Open' Then
                    MsgBox(262144, 'RegRead', $read & ' is default for opening Au3 filetypes')
                EndIf
            ElseIf GUICtrlRead($Checkbox_Run) = $GUI_CHECKED Then
                RegWrite('HKEY_CLASSES_ROOT\AutoIt3Script\Shell', '', 'reg_sz', 'Run')
                $read = RegRead('HKEY_CLASSES_ROOT\AutoIt3Script\Shell', '')
                If $read = 'Run' Then
                    MsgBox(262144, 'RegRead', $read & ' is default for opening Au3 filetypes')
                EndIf
            Else
                MsgBox(262144, '', 'No choice selected')
            EndIf
            
            Case $msg = $Checkbox_Open
                GUICtrlSetState($Checkbox_Run, $GUI_UNCHECKED)
                
            Case $msg = $Checkbox_Run
                GUICtrlSetState($Checkbox_Open, $GUI_UNCHECKED)
                
    EndSelect
    
WEnd
#EndRegion

Edit: For MikeOsdx

For multiple instances of Scite, add to your Options->User Options File

check.if.already.open=0
Normal setting is 1. Edited by MHz

Share this post


Link to post
Share on other sites

This thread is getting pretty long but I have a question about SCITE.

I have multiple monitors setup on my computer and would like to have one script open on one monitor and another script on the other but Scite will not allow multiple instances of itself. is there any way to allow multiple instances?

Thanks,

Mike

Share this post


Link to post
Share on other sites

This thread is getting pretty long but I have a question about SCITE.

I have multiple monitors setup on my computer and would like to have one script open on one monitor and another script on the other but Scite will not allow multiple instances of itself.  is there any way to allow multiple instances?

Thanks,

Mike

<{POST_SNAPBACK}>

SciTE has a help-file, I suggest you make use of it. The answer is there.

Share this post


Link to post
Share on other sites

Another comment on the new abbreviations feature. I see if you use the 'selectloop' abbreviation one of the lines it inserts is;

Case $msg = -3;$GUI_EVENT_CLOSE

would it not be better to use

Case $msg = $GUI_EVENT_CLOSE

?

Share this post


Link to post
Share on other sites

If you reinstalled Autoit after installing Scite, then it will change the setting to run. Here is a gui for changing it back to open...

<{POST_SNAPBACK}>

That worked for me thanks, but I'm sure that wasn't what happened - something went screwy. Could I suggest something like this be added with SciTe somewhere (maybe tools menu, but that's getting kinda long), to make it easy for people to reset if they install AutoIt and forget...

I was gonna suggest SciTe automatically doing this, but I guess some people want to Run Script when they double click rather than Edit...

Share this post


Link to post
Share on other sites

That worked for me thanks, but I'm sure that wasn't what happened - something went screwy. Could I suggest something like this be added with SciTe somewhere (maybe tools menu, but that's getting kinda long), to make it easy for people to reset if they install AutoIt and forget...

I was gonna suggest SciTe automatically doing this, but I guess some people want to Run Script when they double click rather than Edit...

<{POST_SNAPBACK}>

Why not just rerun the SciTE installer to fix this ?

It should prompt you for it everytime with as default you last setting... :lmao:


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Well, cos that I means I have to keep it around or re-download it everytime. Something, well, literally tiny, built into SciTe would be nice.

Share this post


Link to post
Share on other sites

Well, cos that I means I have to keep it around or re-download it everytime. Something, well, literally tiny, built into SciTe would be nice.

<{POST_SNAPBACK}>

Will see if it can be added to the SciTEConfig.au3 script.... :lmao:

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Uploaded a new version of SciTe4AutoIt3.exe which contains the definitions for v3.1.0.9 released Jan 30, 2005 and also contains below updates.

==> Visit the SciTe4AutoIt3 Download page for the latest versions

==> Check the online documentation for an overview of all extra's you get with the SciTE4AutoIt3 installer.

Enjoy,

02/01/2005
*** Updated installer to skip Updatedefs.exe when using Silent (/s) switch.
*** Updated Tidy to skip BlockComment lines (:~) and changed :
    comment.block.at.line.start.au3=1 (Back to what it was before)
*** Updated CompileAU3 docs and directives.au3 to incorporate:
    #Compiler_OutFile=           ;Target exe filename. 
*** Updated SciTEConfig, added option to update the default action for AU3 to either Run or Edit.
*** Updated FuncPopUp, Fixed the new registry location and Helpfile not found error for new release.

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

02/01/2005

*** Updated installer to skip Updatedefs.exe when using Silent (/s) switch.

[post="57986"]<{POST_SNAPBACK}>[/post]

Great, I used the 'Unst' switch for Updatedefs.exe but still got a prompt at the end. I am hoping a switch will be added to make Updatedefs.exe totally silent.

Any chance of adding this switch JdeB ?

Share this post


Link to post
Share on other sites

Great, I used the 'Unst' switch for Updatedefs.exe but still got a prompt at the end. I am hoping a switch will be added to make Updatedefs.exe totally silent.

Any chance of adding this switch JdeB ?

<{POST_SNAPBACK}>

here's a test version of http://www.autoitscript.com/fileman/users/jdeb/test/updatedefs.exe which has a /s switch added to make it totally silent.

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

here's a test version of http://www.autoitscript.com/fileman/users/jdeb/test/updatedefs.exe which has a /s switch added to make it totally silent.

<{POST_SNAPBACK}>

Tested, worked great, thanks :lmao:

Will this be include in your next release ?

Share this post


Link to post
Share on other sites

*** Updated SciTEConfig, added option to update the default action for AU3 to either Run or Edit.

<{POST_SNAPBACK}>

Cheers for accomodating my laziness :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...