Sign in to follow this  
Followers 0

Official Z33to Update

65 posts in this topic

Posted (edited)

Becuase a pay version will be developed I am going to remove this source code. If you have posted the source, please remove it and PM me. I will put you in the beta.

A Free Version will always be available!

Maybe I should give a bit more info. The script will be a compiled script but the Frontend GUI that gives you control over the script will be mine. The script I am working on will have many more features than have been made anywhere and will support mana resoltions. A Trail Version will be released that has the script with msot features enabled. The ones missing msot notably being the Security features. So if you dont want to get banned then you can purchase it for a small small price otherwise you'll jsut have to deal with the lack of security features.

Here is the 1024x768 Version.

Make sure your overlay graphics are 1024x768 and you have turned hardware mouse on.

New Features since last release

-1024x768 Compatibly

-Autologout when your inventory is full

-Quicker failsafe to prevent text from getting away too often.

Future Features

-Rusty Item Dropper

-/tell autoresponder

-/tell autlogout

-Other security features and more efficient code.

Please add to the script as you want like the bait commands. This script

is setup for a lure like the sabiki rig.

Put Send("/equip ammo ""Insect Ball""{ENTER}");

under autosort() near the top.

Edited by z33to

Share this post


Link to post
Share on other sites



Posted

Sometimes pixelgetcolor sees a txt from the system and thinks its caught something. i dunno if that is fixable though. by system message i mean when ppl are fighting around you.

Share this post


Link to post
Share on other sites

Posted

Its working, but I had a question. It seems like everytime I have something on the hook, it does not hit "enter" till about 8 seconds, is this the way it was designed? Also, should all chat filters be on? off? thanks:)

Share this post


Link to post
Share on other sites

Posted

quick question: how do you make sure hardware mouse is on? Thanks!

Share this post


Link to post
Share on other sites

Posted

Hey Z33to thanks for the newer update for lower res. Do you plan on doing an update for resolution inbetween? I use 1280x1024 if you can do that one =) any plans?

Share this post


Link to post
Share on other sites

Posted

I just tried using this version, and I had a couple of problems.

The autosort feature was not working. It would get as far as choosing "yes" to make the autosort happen but the mouse cursor never found its way there. The mouse cursor would always move to the middle topish part of screen. soooo close =/ What could this be from?

The macro restarted to early. I am assuming this script is made for someone that is rank2 or above in fishing? just to explain if that is unclear.... A fisherman that is in the 0-9 skill range (rank 1) and has not completed the first test has a 14 second recycle time. This means once I reel in my rod I must wait 14 seconds to cast it back out. A rank 2 fisherman has a recycle time of 13 seconds. For every rank you go up the recycle time goes down by one second. Is this whats happened z33to?

Well plase help to answer those 2 questions. -thanks

Share this post


Link to post
Share on other sites

Posted

The mouse problem u state is probably becuase you arnt running 1024x768. DOuble check that. As for timing try fooling around with some of the Sleep to see if you can get it to work

on the line that says

Until $biteyes = 1

there is a:

Sleep(12000);

adjust that, try adding a few seconds (12000 = 12 seconds)

or subtracting.

Share this post


Link to post
Share on other sites

Posted (edited)

Since I don't know exactly what exactly the getpixelcolor is looking for, I can't really make my own script for 800x600. Still I wonder if I can convert all the numbers.

For instance,

1024 / 1.28 = 800

768 / 1.28 = 600

so If I have something at,

735 / 1.28 = 574

100 / 1.28 = 78

At a res of 800x600 the new point will be at 574x78.

Would this work?

Edited by ravenfyre

Share this post


Link to post
Share on other sites

Posted (edited)

Its working, but I had a question.  It seems like everytime I have something on the hook, it does not hit "enter" till about 8 seconds, is this the way it was designed?  Also,  should all chat filters be on? off?  thanks:)

Yes where is it in the script that you will be able to change it so that it presses enter right when it says "you have something on the line." It seems this way you would catch alot more fish. This new script is a great idea but the fact that it doesnt press enter when you get a catch is a big prolem. Hope this can be fixed thanks alot z33to!! I think there might be a problem in your pixel color as your older version If PixelGetColor(229,740) = 16777215 it hit enter perfectly. Edited by ffxionline

Share this post


Link to post
Share on other sites

Posted

Anyone know how to turn mouse hardware on???

Share this post


Link to post
Share on other sites

Posted

go into ffxi config and its in there somwhere.

Share this post


Link to post
Share on other sites

Posted

I checked in all the config pages in game and didn't see anything about mouse or cursor hardware /on. ?

Share this post


Link to post
Share on other sites

Posted

its in the ffxi config that came with the game under misc.

Share this post


Link to post
Share on other sites

Posted

I am running 1024x768. I made sure and retried, but nothing changed.

Does the background resolution matter? My only options for that is 256x256, 512x512, or 1024x1024. I have tried using both 512x512 and 1024x1024 without the problem fixing itself.

This might be the problem, but I'm not sure. I have 2 computers sharing the same keyboard and mouse through a KVM switch. Has anyone had any experience using AutoIt like I am? Everything works fine, besides the mousemovement. On Jades script I would have issues only at the autosort part also. Everything else works fine.

I was thinking I might need to slow down how fast the mouse moves across the screen. How can I change that?

-thanks for helping =)

Share this post


Link to post
Share on other sites

Posted (edited)

ohh SethDrone to get to FFXI config where you can change that option go

start==>programs==>Playonline==>FFXI==>FFXI config==>misc==>Enable hardware mouse cursor

Edited by Dhaer

Share this post


Link to post
Share on other sites

Posted

Thanks a bunch daer!

Share this post


Link to post
Share on other sites

Posted

whole script runs flawlessly now thanks zeeto!

Share this post


Link to post
Share on other sites

Posted

The script does work with hardware mouse on and the auto function sort does work. What I have noticed though even if you put in the command to equip bait after or before the auto sort after you catch a fish or lose a catch it does not go to the auto sort or reequip bait. Also the biggest problem is that it does not press enter after their is something on the line it just waits and waits and waits and never does it.

Share this post


Link to post
Share on other sites

Posted

Keep up the good work guys :whistle: .. I having a problem though..

I only caught like 3 stacks of moat carps after using 10 stacks of insect paste over 8 hours..

Fishing skill is at 13 and i have full fishing gear.. >_> the catch rate is pretty slow .. that's what i am talking about.. 3 sets of paste for 1 stack of moat carp is ok for me

Share this post


Link to post
Share on other sites

Posted

What setting should we have for minimum chat line?

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.