Jump to content

AMT - Auto-Movie-Thumbnailer [Updated 2022-Nov-26]


KaFu
 Share

Recommended Posts

Thanks for reporting, that is a unique ID I set to the default AuoIt window with AutoItWinSetTitle(), the text is the hwnd of the main GUI.

But I don't know why it shows up at all, it does not for me and it shouldn't 🙄.

Maybe you could provide a screenshot, an erroneous file to test and a copy of the "extended" log display via PM?

Best Regards

 

P.S.: AMT not being able to perform screenshots most likely means that your movie files are corrupt. Please also try the "MPlayer functionality test" at the bottom right of the "Layout" tab.

Edited by KaFu
Link to comment
Share on other sites

On 11/17/2022 at 8:15 PM, KaFu said:

P.S.: AMT not being able to perform screenshots most likely means that your movie files are corrupt. Please also try the "MPlayer functionality test" at the bottom right of the "Layout" tab.

The movie played fine in MPlayer.

Running the movie, here's the log:

14:46:23-185| FLUSH - SUCCESS|LX=Temp files deleted - Size = 0
14:46:22-716| FINISHED Processing Cycle in 14 seconds - 2022-11-22, 14:46:22 - Files: 1 / 1 (0 left) - Result: 0 / 0 / 1 / 0
14:46:22-710| #1-Result = FAILURE, output file was not created|LX="D:\Temp\Test\sparks (352 x 240).avi.jpg"
14:46:22-710| ERROR - Thumbnail Creation Error #3b
14:46:22-661| 1: SCREENSHOT - START|LX=screenshot|pause|
14:46:22-660| LX=MPLAYER-STDOUT = ANS_TIME_POSITION=2.7|ANS_PERCENT_POSITION=26|
14:46:22-631| 1: SEEK = 2.5|LX=seek 2.5 1|get_time_pos|get_percent_pos|
14:46:22-628| MPLAYER restarted 4/3
14:46:22-628| 1: MPLAYER - "Starting playback"
14:46:22-628| LX=MPLAYER-STDOUT = <vo_directx><ERROR>Your card doesn't support overlay|Opening video filter: [screenshot]|==========================================================================|Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family|libavcodec version 59.25.101 (internal)|[mpeg4 @ 00007ff75f9bf700]Requested frame threading with a custom get_buffer2() implementation which is not marked as thread safe. This is not supported anymore, make your callback thread-safe.|Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)|==========================================================================|ID_VIDEO_CODEC=ffodivx|ID_FILENAME=D:\Temp\Test\sparks (352 x 240).avi|ID_DEMUXER=avi|ID_VIDEO_FORMAT=DX50|ID_VIDEO_BITRATE=896928|ID_VIDEO_WIDTH=352|ID_VIDEO_HEIGHT=240|ID_VIDEO_FPS=29.967|ID_VIDEO_ASPECT=0.0000|ID_START_TIME=0.00|ID_LENGTH=10.44|ID_SEEKABLE=1|ID_CHAPTERS=0|Audio: no sound|Starting playback...|Could not find matching colorspace - retrying with -vf scale...|Opening video filter: [scale]|[swscaler @ 00007ff75fb27e40]bicubic scaler, from yuv420p to bgra using MMXEXT|VO: [directx] 160x109 => 160x109 BGRA [zoom]|[VD_FFMPEG] DRI failure.|
14:46:22-517| LX=MPLAYER-STDOUT = MPlayer sherpya-r38363+g4fbf3c828b-10-win32 (C) 2000-2022 MPlayer Team|Setting process priority: abovenormal||C:\Windows\fonts\verdana.ttf doesn't look like a bitmap font description, ignoring.|Cannot load bitmap font 'C:\Windows\fonts\verdana.ttf'.||Playing D:\Temp\Test\sparks (352 x 240).avi.|libavformat version 59.20.101 (internal)|AVI file format detected.|ID_VIDEO_ID=0|[aviheader] Video stream found, -vid 0|ID_AUDIO_ID=1|[aviheader] Audio stream found, -aid 1|VIDEO: [DX50] 352x240 24bpp 29.967 fps 896.9 kbps (109.5 kbyte/s)|
14:46:22-472| 1: MPLAYER - START = 4; Seek adjustment = 1|LX="C:\Program Files\AMT\AMT_Binaries\MPlayer-r38363_x64\AMT-MPlayer.exe" -vo directx -slave -identify -vf screenshot -msglevel all=5 -zoom -x 160 -y 109 -nokeepaspect -wid 526760 -nokeepaspect -monitorpixelaspect 1 -priority abovenormal -progbar-align 95 -nofs -nodr -double -noslices -font "C:\Windows\fonts\verdana.ttf" -subfont-autoscale 3 -subfont-osd-scale 4 -subfont-outline 1 -subfont-blur 1 -noautosub -colorkey 0 -input nodefault-bindings -noconsolecontrols -nofontconfig -nomouseinput -nosound -ao null -af volume=-200:0 -osdlevel 3 -lavdopts threads=12 "D:\Temp\Test\sparks (352 x 240).avi"
14:46:22-453| 1: FLUSH|LX=SUCCESS, current screenshot temp files successfully deleted
14:46:16-403| 1: SCREENSHOT - START|LX=screenshot|pause|
14:46:16-402| LX=MPLAYER-STDOUT = ANS_TIME_POSITION=0.3|ANS_PERCENT_POSITION=2|
14:46:16-373| 1: SEEK = -0.5|LX=seek -0.5 1|get_time_pos|get_percent_pos|
14:46:16-370| MPLAYER restarted 3/3
14:46:16-370| 1: MPLAYER - "Starting playback"
14:46:16-370| LX=MPLAYER-STDOUT = <vo_directx><ERROR>Your card doesn't support overlay|Opening video filter: [screenshot]|==========================================================================|Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family|libavcodec version 59.25.101 (internal)|[mpeg4 @ 00007ff75f9bf700]Requested frame threading with a custom get_buffer2() implementation which is not marked as thread safe. This is not supported anymore, make your callback thread-safe.|Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)|==========================================================================|ID_VIDEO_CODEC=ffodivx|ID_FILENAME=D:\Temp\Test\sparks (352 x 240).avi|ID_DEMUXER=avi|ID_VIDEO_FORMAT=DX50|ID_VIDEO_BITRATE=896928|ID_VIDEO_WIDTH=352|ID_VIDEO_HEIGHT=240|ID_VIDEO_FPS=29.967|ID_VIDEO_ASPECT=0.0000|ID_START_TIME=0.00|ID_LENGTH=10.44|ID_SEEKABLE=1|ID_CHAPTERS=0|Audio: no sound|Starting playback...|Could not find matching colorspace - retrying with -vf scale...|Opening video filter: [scale]|[swscaler @ 00007ff75fb27e40]bicubic scaler, from yuv420p to bgra using MMXEXT|VO: [directx] 160x109 => 160x109 BGRA [zoom]|[VD_FFMPEG] DRI failure.|
14:46:16-258| LX=MPLAYER-STDOUT = MPlayer sherpya-r38363+g4fbf3c828b-10-win32 (C) 2000-2022 MPlayer Team|Setting process priority: abovenormal||C:\Windows\fonts\verdana.ttf doesn't look like a bitmap font description, ignoring.|Cannot load bitmap font 'C:\Windows\fonts\verdana.ttf'.||Playing D:\Temp\Test\sparks (352 x 240).avi.|libavformat version 59.20.101 (internal)|AVI file format detected.|ID_VIDEO_ID=0|[aviheader] Video stream found, -vid 0|ID_AUDIO_ID=1|[aviheader] Audio stream found, -aid 1|VIDEO: [DX50] 352x240 24bpp 29.967 fps 896.9 kbps (109.5 kbyte/s)|
14:46:16-216| 1: MPLAYER - START = 3; Seek adjustment = -2|LX="C:\Program Files\AMT\AMT_Binaries\MPlayer-r38363_x64\AMT-MPlayer.exe" -vo directx -slave -identify -vf screenshot -msglevel all=5 -zoom -x 160 -y 109 -nokeepaspect -wid 526760 -nokeepaspect -monitorpixelaspect 1 -priority abovenormal -progbar-align 95 -nofs -nodr -double -noslices -font "C:\Windows\fonts\verdana.ttf" -subfont-autoscale 3 -subfont-osd-scale 4 -subfont-outline 1 -subfont-blur 1 -noautosub -colorkey 0 -input nodefault-bindings -noconsolecontrols -nofontconfig -nomouseinput -nosound -ao null -af volume=-200:0 -osdlevel 3 -lavdopts threads=12 "D:\Temp\Test\sparks (352 x 240).avi"
14:46:16-194| 1: FLUSH|LX=SUCCESS, current screenshot temp files successfully deleted
14:46:12-136| 1: SCREENSHOT - START|LX=screenshot|pause|
14:46:12-136| LX=MPLAYER-STDOUT = ANS_TIME_POSITION=2.7|ANS_PERCENT_POSITION=26|
14:46:12-107| LX=MPLAYER-STDOUT = [VD_FFMPEG] DRI failure.|
14:46:12-107| 1: SEEK = 0.5|LX=seek 0.5 1|get_time_pos|get_percent_pos|
14:46:12-104| MPLAYER restarted 2/3
14:46:12-104| 1: MPLAYER - "Starting playback"
14:46:12-104| LX=MPLAYER-STDOUT = <vo_directx><ERROR>Your card doesn't support overlay|Opening video filter: [screenshot]|==========================================================================|Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family|libavcodec version 59.25.101 (internal)|[mpeg4 @ 00007ff75f9bf700]Requested frame threading with a custom get_buffer2() implementation which is not marked as thread safe. This is not supported anymore, make your callback thread-safe.|Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)|==========================================================================|ID_VIDEO_CODEC=ffodivx|ID_FILENAME=D:\Temp\Test\sparks (352 x 240).avi|ID_DEMUXER=avi|ID_VIDEO_FORMAT=DX50|ID_VIDEO_BITRATE=896928|ID_VIDEO_WIDTH=352|ID_VIDEO_HEIGHT=240|ID_VIDEO_FPS=29.967|ID_VIDEO_ASPECT=0.0000|ID_START_TIME=0.00|ID_LENGTH=10.44|ID_SEEKABLE=1|ID_CHAPTERS=0|Audio: no sound|Starting playback...|Could not find matching colorspace - retrying with -vf scale...|Opening video filter: [scale]|[swscaler @ 00007ff75fb27e40]bicubic scaler, from yuv420p to bgra using MMXEXT|VO: [directx] 160x109 => 160x109 BGRA [zoom]|
14:46:12-008| LX=MPLAYER-STDOUT = MPlayer sherpya-r38363+g4fbf3c828b-10-win32 (C) 2000-2022 MPlayer Team|Setting process priority: abovenormal||C:\Windows\fonts\verdana.ttf doesn't look like a bitmap font description, ignoring.|Cannot load bitmap font 'C:\Windows\fonts\verdana.ttf'.||Playing D:\Temp\Test\sparks (352 x 240).avi.|libavformat version 59.20.101 (internal)|AVI file format detected.|ID_VIDEO_ID=0|[aviheader] Video stream found, -vid 0|ID_AUDIO_ID=1|[aviheader] Audio stream found, -aid 1|VIDEO: [DX50] 352x240 24bpp 29.967 fps 896.9 kbps (109.5 kbyte/s)|
14:46:11-965| 1: MPLAYER - START = 2; Seek adjustment = -1|LX="C:\Program Files\AMT\AMT_Binaries\MPlayer-r38363_x64\AMT-MPlayer.exe" -vo directx -slave -identify -vf screenshot -msglevel all=5 -zoom -x 160 -y 109 -nokeepaspect -wid 526760 -nokeepaspect -monitorpixelaspect 1 -priority abovenormal -progbar-align 95 -nofs -nodr -double -noslices -font "C:\Windows\fonts\verdana.ttf" -subfont-autoscale 3 -subfont-osd-scale 4 -subfont-outline 1 -subfont-blur 1 -noautosub -colorkey 0 -input nodefault-bindings -noconsolecontrols -nofontconfig -nomouseinput -nosound -ao null -af volume=-200:0 -osdlevel 3 -lavdopts threads=12 "D:\Temp\Test\sparks (352 x 240).avi"
14:46:11-944| 1: FLUSH|LX=SUCCESS, current screenshot temp files successfully deleted
14:46:09-883| 1: SCREENSHOT - START|LX=screenshot|pause|
14:46:09-883| LX=MPLAYER-STDOUT = ANS_TIME_POSITION=2.7|ANS_PERCENT_POSITION=26|
14:46:09-855| LX=MPLAYER-STDOUT = [VD_FFMPEG] DRI failure.|
14:46:09-855| 1: SEEK = 1.5|LX=seek 1.5 1|get_time_pos|get_percent_pos|
14:46:09-852| 1: MPLAYER - "Starting playback"
14:46:09-851| LX=MPLAYER-STDOUT = <vo_directx><ERROR>Your card doesn't support overlay|Opening video filter: [screenshot]|==========================================================================|Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family|libavcodec version 59.25.101 (internal)|[mpeg4 @ 00007ff75f9bf700]Requested frame threading with a custom get_buffer2() implementation which is not marked as thread safe. This is not supported anymore, make your callback thread-safe.|Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)|==========================================================================|ID_VIDEO_CODEC=ffodivx|ID_FILENAME=D:\Temp\Test\sparks (352 x 240).avi|ID_DEMUXER=avi|ID_VIDEO_FORMAT=DX50|ID_VIDEO_BITRATE=896928|ID_VIDEO_WIDTH=352|ID_VIDEO_HEIGHT=240|ID_VIDEO_FPS=29.967|ID_VIDEO_ASPECT=0.0000|ID_START_TIME=0.00|ID_LENGTH=10.44|ID_SEEKABLE=1|ID_CHAPTERS=0|Audio: no sound|Starting playback...|Could not find matching colorspace - retrying with -vf scale...|Opening video filter: [scale]|[swscaler @ 00007ff75fb27e40]bicubic scaler, from yuv420p to bgra using MMXEXT|VO: [directx] 160x109 => 160x109 BGRA [zoom]|
14:46:09-740| LX=MPLAYER-STDOUT = MPlayer sherpya-r38363+g4fbf3c828b-10-win32 (C) 2000-2022 MPlayer Team|Setting process priority: abovenormal||C:\Windows\fonts\verdana.ttf doesn't look like a bitmap font description, ignoring.|Cannot load bitmap font 'C:\Windows\fonts\verdana.ttf'.||Playing D:\Temp\Test\sparks (352 x 240).avi.|libavformat version 59.20.101 (internal)|AVI file format detected.|ID_VIDEO_ID=0|[aviheader] Video stream found, -vid 0|ID_AUDIO_ID=1|[aviheader] Audio stream found, -aid 1|VIDEO: [DX50] 352x240 24bpp 29.967 fps 896.9 kbps (109.5 kbyte/s)|
14:46:09-696| 1: MPLAYER - START = 1; Seek adjustment = 0|LX="C:\Program Files\AMT\AMT_Binaries\MPlayer-r38363_x64\AMT-MPlayer.exe" -vo directx -slave -identify -vf screenshot -msglevel all=5 -zoom -x 160 -y 109 -nokeepaspect -wid 526760 -nokeepaspect -monitorpixelaspect 1 -priority abovenormal -progbar-align 95 -nofs -nodr -double -noslices -font "C:\Windows\fonts\verdana.ttf" -subfont-autoscale 3 -subfont-osd-scale 4 -subfont-outline 1 -subfont-blur 1 -noautosub -colorkey 0 -input nodefault-bindings -noconsolecontrols -nofontconfig -nomouseinput -nosound -ao null -af volume=-200:0 -osdlevel 3 -lavdopts threads=12 "D:\Temp\Test\sparks (352 x 240).avi"
14:46:09-677| 1: FLUSH|LX=SUCCESS, current screenshot temp files successfully deleted
14:46:09-654| MPLAYER processing loop started - Filesize = 1.2MB; Amount of Shots = 33; Pictures per Row = 11; Pictures per Column = 3; Use Shortnames = False; Prepare fixed amount of screenshots = True; Pattern Time Priority = True; Duration in Seconds = 10
14:46:09-653| LX=Pre-Scaling of MPlayer output applied
14:46:09-653| LX=4-Finished|""
14:46:09-634| MEDIAINFO data extraction|LX=4-Start|Using MediaInfo on D:\Temp\Test\sparks (352 x 240).avi #4
14:46:09-628| FLUSH - SUCCESS|LX=Temp files deleted - Size = 0
14:46:09-100| #1-Output = "D:\Temp\Test\sparks (352 x 240).avi.jpg"
14:46:09-100| #1- Input = "D:\Temp\Test\sparks (352 x 240).avi"
14:46:09-100| ===============================
14:46:09-100| ===== Next File is #1
14:46:09-100| ===============================
14:46:09-092| FOOTER created|LX=C:\Users\PhotonBuddy\AppData\Roaming\AMT_Workdir\AMT_Graphics\amt_footer.png
14:46:08-672| LX=AMT - Auto-Movie-Thumbnailer - v13 - (2022-Nov-13)|3.3.16.1|1|X64|19043|C:\Program Files\AMT\AMT.exe|WIN_10|WIN32_NT|2560|12|Tahoma|Arial|Lucida Console|C:\Users\PhotonBuddy\AppData\Roaming\AMT_Workdir|1|1|C:\Program Files\AMT|1|C:\Program Files\AMT\AMT_Binaries\sqlite3.dll|1|C:\Program Files\AMT\AMT_Binaries\MPlayer-r38363_x64\AMT-MPlayer.exe|1|C:\Program Files\AMT\AMT_Binaries\ImageMagick-6.9.9-37-portable-Q16-x64\AMT-Convert.exe|1|C:\Program Files\AMT\AMT_Binaries\ImageMagick-6.9.9-37-portable-Q16-x64\AMT-Montage.exe|1|C:\Program Files\AMT\AMT_Binaries\MediaInfo_DLL_22.09\AMT-MediaInfo.dll|1|C:\Program Files\AMT\AMT_Binaries\exiftool-11.73\AMT-ExifTool.exe|1
14:46:08-671| STARTED Processing Cycle - 2022-11-22, 14:46:08

Hope this helps.

Link to comment
Share on other sites

Thanks for reporting. The pop-up is related to the "Show Notification when finished" or "When finished - Shutdown" checkboxes.

When either is checked, my custom _msgbox function makes the default AutoIt window visible (what it shouldn't). Fixed in next version to come.

With the movie not thumbnailing, feel free to share a sample movie and I'll take a look. My guess is it's related to the movie, either it's too short with too few keyframes, or it's somehow corrupted so that MPlayer can't play it or seek in it correctly.

Link to comment
Share on other sites

v13 > v14

  • Fixed tray password set by default
  • Fixed error on “Show notification…” or “When finished…”
  • Added success/failure messages to AMT Drag & Drop Interface

Installer & Source are available at

http://www.amt.cc or https://funk.eu/amt/

Enjoy :) ...

Link to comment
Share on other sites

  • KaFu changed the title to AMT - Auto-Movie-Thumbnailer [Updated 2022-Nov-26]
  • 1 month later...

I want to report a problem to you

Forgive me for using Google Translate, I am a non-English user, if the title of the video is very long and has a lot of words. The title of the thumbnail will not automatically wrap, and if I make the font too large, it will not wrap. I hope you can correct this mistake.
In the current epidemic situation, I wish you good health.

Edited by Jos
Link to comment
Share on other sites

Hi 15097840527,

I see what you mean, but I'm not yet sure what to do about it.

- Wrapping the text is one possibility, but that will lead to different heights of the pictures instead of different width
- Trimming the text is another
- Or cutting the middle of the string until the length fits again

Generally this is something that will always occur if the font is just too large and the filename just too long. The easiest option is to reduce font size or trim filename length ;).

I'll think about a checkbox to trigger one of the three options above for the next release, but nothing with a quick solution.

Best Regards
Karsten

Link to comment
Share on other sites

1. I know that the software you make is mostly used to capture movie thumbnails, and the name of the movie may not be so long. But on YouTube, in order to attract more people to watch many videos, the video creator will use a very long name.
2. For the convenience of viewing thumbnails on mobile phones, I will make 1Ă—N thumbnails, but in that case only the attributes of the files will be displayed, and the names of the files cannot be fully displayed.
3. If I make 2+Ă—n thumbnails, basically the file name will be completely displayed, but in that case, the text in the title is very small on the mobile phone, and the thumbnails cannot be seen clearly.
4. This software Auto-Movie-Thumbnailer. In any case, the thumbnail will be generated according to the width of the file name, but if the video title is very long, the font will be very small because the title does not wrap, and the thumbnail should not be too small. Just try it and you will know.
5. In many cases, it is necessary to enlarge the characters of the video title and make the title wrap. This is indeed a very important requirement. Is your team planning to improve this requirement in the next version?

Link to comment
Share on other sites

  • 9 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...