Custom Query

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (142 - 144 of 3866)

Ticket Resolution Summary Owner Reporter
#3799 No Bug _ChooseFont (Canceling the dialog) suggestion. Dan_555
Description

Currently, when the _ChooseFont is called, and the font dialog is cancelled, the array is not created and @error is not set for it.

Testcode fails, if the fontdialog is cancelled, at the $font=$aF[2]:

Func SelFont()						;Select a font
	Local $aF = _ChooseFont($font)
	If @error > 0 Then
		$font = "System2"
	Else		
			$font = $aF[2]		
	EndIf

EndFunc   ;==>SelFont

My Suggestion would be to set the @error flag to a number higher than 0

There is a workaround code, to check if the array was created:

Func SelFont()						;Select a font
	Local $aF = _ChooseFont($font)
	If @error > 0 Then
		$font = "System2"
	Else
		if IsArray($af) then
			$font = $aF[2]
		Else
			$font = "System2"
		EndIf
	EndIf

EndFunc   ;==>SelFont

#3798 Fixed SciTE4AutoIt incompatibilty with SSE instruction set Jos Ant
Description

SciTE4AutoIt (version 19.1127.1402.0) crashes immediately.

Experience with other applications tells me this is because the editor's executable hasn't been compiled for compatibility with the SSE instruction set. (The chip in this case is an Intel Celeron, alias Coppermine-128.) Windows reports, "SciTE - a Scintilla based Text Editor modified by Jos f has encountered a problem and needs to close. We are sorry for the inconvenience."

The "Lite" version of SciTE packaged with AutoIt (version 3.3.14.5) works fine. This is my first time trying to use SciTE4AutoIt, so the issue may have been present for some time. Would really appreciate SSE instruction set-compatibility so I can take advantage of the configuration tool.

Here's a link to a similar ticket, although the issue there concerns compiled scripts rather than the editor itself.

https://www.autoitscript.com/trac/autoit/ticket/2576

#3797 No Bug PCRE update to recent PCRE-8.44 or even to PCRE2-10.36 mLipok
Description

In fact there was recently closed ticket: https://www.autoitscript.com/trac/autoit/ticket/3656

In fact @Melba23 said:

PCRE updated for 3.3.16.0

But even using recent Alpha version (candidate for Beta which include PCRE-8.41) .... AutoIt still have problem with this simple example:

#include <Array.au3>
#include <StringConstants.au3>

_Example(0, '(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)')

Func _Example($sTitle, $sPattern)
        Local $sText = _
                        'Dąbrowskiego43/45' & @CRLF & _
                        'Dąbrowskiego43/45' & @CRLF & _
                        'Kordeckiego1/11' & @CRLF & _
                        'Kordeckiego 1/11' & @CRLF & _
                        'm2/11' & @CRLF & _
                        'm2/12' & @CRLF & _
                        'p      3/12' & @CRLF & _
                        ''
        ConsoleWrite('>>>>>>>>>>> $sTitle = ' & $sTitle & @CRLF)
        Local $aTest = StringRegExp($sText, $sPattern, $STR_REGEXPARRAYGLOBALFULLMATCH)
        ConsoleWrite('! ---> @error=' & @error & '  @extended=' & @extended & @CRLF)
        If UBound($aTest) Then
                For $iOuter_id = 0 To UBound($aTest) - 1
                        ConsoleWrite('MATCH ' & $iOuter_id + 1 & @CRLF)
                        ConsoleWrite(_ArrayToString($aTest[$iOuter_id]) & @CRLF)
                Next
        EndIf
        ConsoleWrite('>>>>>>>>>>> END ' & @CRLF)
        ConsoleWrite(@CRLF)
        ConsoleWrite(@CRLF)
EndFunc   ;==>_Example

Proper behavior was saved be me in this link: https://regex101.com/r/C7h5ML/3

So please consider update to PCRE-8.44 or even switch to PCRE2-10.36 https://ftp.pcre.org/pub/pcre/

Edit: Of course, to the latest version available at the time of update, regardless of the branch.

Note: See TracQuery for help on using queries.