Modify

Opened 8 years ago

Closed 8 years ago

#2211 closed Bug (Duplicate)

Only one RichEdit control can be created

Reported by: MrCreatoR <mscreator@…> Owned by:
Milestone: Component: AutoIt
Version: 3.3.8.1 Severity: None
Keywords: RichEdit Cc:

Description

This problem caused by the strange change in 3.3.8.1 for _GUICtrlRichEdit_Create function:

If Not _WinAPI_IsClassName($hWnd, $_GRE_sRTFClassName) Then Return SetError(1, 0, 0)

In previous versions it was different (wright(?)):

If Not IsHwnd($hWnd) Then Return SetError(1, 0, 0)

Why this change?
Because of this, now we can't create more than one RichEdit controls.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by BrewManNH

This has been fixed in the latest beta, see ticket 2187. In 3.3.8.1, just delete that line or modify it to what's in the new beta version.

Version 0, edited 8 years ago by BrewManNH (next)

comment:2 Changed 8 years ago by trancexx

  • Resolution set to Duplicate
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.