Modify

Opened 10 years ago

Closed 6 years ago

#1024 closed Bug (Fixed)

GUICtrlSetTip for tabitems sets incorrectly in certain situations

Reported by: Lazycat Owned by: Jon
Milestone: 3.3.9.16 Component: AutoIt
Version: 3.3.1.1 Severity: None
Keywords: Cc:

Description

For example, we have a tab with three tabitems. Setting single tips to second and following tabitems have strange behaviour.

$Form1 = GUICreate("Form1", 633, 454, 192, 114)
$Tab1 = GUICtrlCreateTab(184, 152, 289, 193)
GUICtrlSetTip(-1, "Tab Tip")
$TabItem1 = GUICtrlCreateTabItem("TabItem 1")
;GUICtrlSetTip(-1, "TabItem 1 Tip")
$TabItem2 = GUICtrlCreateTabItem("TabItem 2")
;GUICtrlSetTip(-1, "TabItem 2 Tip")
$TabItem3 = GUICtrlCreateTabItem("TabItem 3")
GUICtrlSetTip(-1, "TabItem 3 Tip")
GUICtrlCreateTabItem("")
  1. If you set single tip to only first tabitem - all ok, only first tabitem have a tip.
  2. If you set single tip to second or third tabitem, then all previous tabitems have the same tip (this wrong, code above show this).
  3. But if you set first and third tabs, then second tab have not tip, as expected.

So, problem appear only when first tabitem have not tip set.

Also, when single tip is set to any tabitem, global tab tip not showing anymore on other tabs. Maybe this by design, though.

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by Jpm

It looks like the tip for tabitem is working only if they are defined just after the tabitem creation and also the tip for first tabitem must be defined (with "" if you don't want one).
The global tab tip is destroyed when a tabitem tip is set.
That the best I can understand on how the MSDN API are working.
I intend to document it.

comment:2 Changed 10 years ago by Jpm

  • Owner set to admin
  • Status changed from new to assigned

comment:3 Changed 6 years ago by Jon

  • Resolution set to Rejected
  • Status changed from assigned to closed

comment:4 Changed 6 years ago by Jon

  • Resolution Rejected deleted
  • Status changed from closed to reopened

comment:5 Changed 6 years ago by Jon

  • Milestone set to 3.3.9.16
  • Owner changed from admin to Jon
  • Resolution set to Fixed
  • Status changed from reopened to closed

Fixed by revision [8426] in version: 3.3.9.16

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.