Modify

Opened 10 years ago

Closed 10 years ago

#1043 closed Bug (Works For Me)

ClipPut Function bug or limitation

Reported by: sistemas@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: clipboard ClipPut setclipboard Cc:

Description

If you put more than 127 characters into clipboard, this function fail and the clipboard is clear.

I don't know why but I try with a string with {TAB},{CR}, and {LF} characters in this string.
I try with beta version 3.3.1.1 and I have the same problem.

I don't know if this is a new limitation. But I think that the clipboard function must support 65535 chars at least.

But with version 3.2.12.1 this work fine and you can put into clipboard text with more than 127 characters.
So I must to put back the 3.2.12.1 version until this problem is fixed.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by sistemas@…

I must to add that this happen with the 32bits version of the dll: AutoItX3.dll
Running under Windows 2003 R2 SP2 server.

If this can help...

Regards,

Ricky

comment:2 Changed 10 years ago by Jpm

can you put a script that reproduce the problem.
Not sure if you speak of a script .au3 or the use of AutoItX3.dll which is very different.
Thanks for the help

comment:3 Changed 10 years ago by Valik

  • Resolution set to Works For Me
  • Status changed from new to closed

The following test script works fine. I get the results I expect. Closing as works for me.

#cs
This is some gibberish just to pad the length of the file.

A few newlines.



The following line has some tabs:
		text 		tabs		text



And that's enough padding.  Yay.
#ce

Local $sText = FileRead(@ScriptFullPath)
ClipPut($sText)
ConsoleWrite("Native test - Input length: " & StringLen($sText) & "; Clipboard length: " & StringLen(ClipGet()) & @CRLF)
ClipPut("")	; Clear to ensure results do not bleed over.

Local $oAutoItX = ObjCreate("AutoItX3.Control")
$oAutoItX.ClipPut($sText)
ConsoleWrite("AutoItX test - Input length: " & StringLen($sText) & "; Clipboard length: " & StringLen($oAutoItX.ClipGet()) & @CRLF)

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.