Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1067 closed Bug (No Bug)

Unsigned structure "uint64" work as signed "int64"

Reported by: amel27 Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: uint64 Cc:

Description

$t1 = DllStructCreate("uint;uint")
$t2 = DllStructCreate("uint64", DllStructGetPtr($t1))

DllStructSetData($t1, 1, -1)
DllStructSetData($t1, 2, -1)

ConsoleWrite(DllStructGetData($t1, 1) &@CRLF)
ConsoleWrite(DllStructGetData($t1, 2) &@CRLF)
ConsoleWrite(DllStructGetData($t2, 1) &@CRLF)

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

AutoIt only displays signed numbers. It does not display unsigned numbers. It is not a bug.

comment:2 follow-up: Changed 10 years ago by amel27

Thanks for comment. Is it right only fo 64-bit numbers?.. 32-bit unsigned display correctly!

comment:3 in reply to: ↑ 2 Changed 10 years ago by Valik

Replying to amel27:

Thanks for comment. Is it right only fo 64-bit numbers?.. 32-bit unsigned display correctly!

32-bit unsigned are being displayed as 64-bit signed.

comment:4 Changed 10 years ago by amel27

I understand, Thx!

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.