Modify

Opened 11 years ago

Closed 11 years ago

#108 closed Bug (Fixed)

IE.AU3 _IEAttach windowtitle using not existing registry entry

Reported by: junkew@… Owned by: Gary
Milestone: 3.2.11.11 Component: Standard UDFs
Version: 3.2.10.0 Severity: Blocking
Keywords: Cc:

Description

within _IEAttach when searching on windowtitle a registry entry is read which by default does not exist and as such $s_tmp is empty

$s_tmp = RegRead("HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\", "Window Title")

Whereas actually after - in windows title is Windows Internet Explorer

$s_tmp = $o_window.name is a better match for whats needed

code becomes

Case "windowtitle"
;$s_tmp = RegRead("HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\", "Window Title")
	$s_tmp = $o_window.name
	If StringInStr($o_window.document.title & " - " & $s_tmp, $s_string) > 0 Then
		SetError($_IEStatus_Success)
		Return $o_window
	EndIf

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 11 years ago by Dale Hohm <DaleHohm@…>

I need more information please.

What version of Windows and IE are you running?

.name is certainly NOT a valid way to approach this issue. the name attribute is used to name frames and windows (as in <a href="url" target="name">

The value I retrieve from the registry is a suffix that IE appends to the document title to construct the window title.

I can see how I ought not to be adding " - " to the document title if that registry value is missing or blank, but perhaps you can tell me what your window title looks like and the associated document title it represents.

Dale

comment:2 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Closing due to lack of activity.

comment:3 in reply to: ↑ 1 Changed 11 years ago by anonymous

  • Resolution No Bug deleted
  • Status changed from closed to reopened

Replying to Dale Hohm <DaleHohm@msn.com>:
Dutch Windows 2000 version
Internet Explorer version 7 (7.0.5730.11)

Title shown when I read this issue
#108 (IE.AU3 _IEAttach windowtitle using not existing registry entry) – AutoIt – Trac - Windows Internet Explorer

comment:4 Changed 11 years ago by DaleHohm

Thanks for the version information.

I found a Microsoft KB on this: http://support.microsoft.com/kb/176497

When the registry key is missing, the default value is documented to be "Microsoft Internet Explorer". In fact, that the KB is incorrect and it is "Microsoft Internet Explorer" with some versions of IE/Windows and "Windows Internet Explorer" with others.

Some more researched required.

Dale

comment:5 Changed 11 years ago by Valik

This is trivial to solve. Just look for the registry key and use that data if it's found. If it's not found, use the following regular expression:
"(?:Microsoft)|(?:Windows) Internet Explorer"
That will match either "Microsoft Internet Explorer" or "Windows Internet Explorer". No complex OS/IE version complications.

comment:6 follow-up: Changed 11 years ago by Valik

  • Severity set to Blocking

comment:7 in reply to: ↑ 6 ; follow-up: Changed 11 years ago by DaleHohm@…

Replying to Valik:
I like the suggestion Valik. I was tooling around figuring out under exactly what version combinations of OS and IE the label changes. Sidestepping the issue is smarter.

Fix TBS shortly.

Dale

comment:8 in reply to: ↑ 7 Changed 11 years ago by Dale.Hohm@…

Fix submitted to Gary in IE.au3 V2.4-1

Dale

comment:9 Changed 11 years ago by Gary

  • Milestone set to 3.2.11.11
  • Resolution set to Fixed
  • Status changed from reopened to closed

Fixed in version: 3.2.11.11

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Gary.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.