Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1089 closed Bug (No Bug)

#AutoIt3Wrapper_Run_Tidy=y, tidy also activated at run-script instant.

Reported by: anonymous Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: Other Severity: None
Keywords: AutoIt3Wrapper tidy Cc:

Description

when the line '#AutoIt3Wrapper_Run_Tidy=y' is added to a script.
Tidy is also run, when you just run[F5] the script from scite4autoit.

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Jos

Correct, that is the way it is supposed to work.
So what do you think the bug is in this case?

Jos

comment:2 Changed 10 years ago by anonymous

I Figured it was not default behavior because:
1) The Scite side effect of a document-reload/revert after running tidy. loosing the documents current folding status.
+) #AutoIt3Wrapper_Run_Tidy was added after changing the compile-settings,(ctrl-f7).
+) Reading 'compilation' in help as. only when you compile or build a exe or au3 file.

Think if Tidy was mentioned in the 'AutoIt3Wrapper will perform the following tasks for you when wrapping AutoIt3 (Run):' section in the AutoIt3Wrapper help. I probably just would have disabled the '*_run_tidy' line and taking it as intended behavior.

comment:3 Changed 10 years ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

It is the default behavior.

Jos

comment:4 Changed 10 years ago by TicketCleanup

  • Version set to Other

Automatic ticket cleanup.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.