Modify

Opened 12 years ago

Closed 12 years ago

#113 closed Bug (No Bug)

_ArrayDelete(StringSplit,..)

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: _ArrayDelete, StringSplit Cc:

Description

Compiler issue:

StringSplit returns an array, but _ArrayDelete does not recognize it.

$aStack = _ArrayDelete(StringSplit(StringMid($sStack,2),$sDelim,1),0)

PS. Probably applies to other _Array functions also.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to nobug
  • Status changed from new to closed

This is not a bug. The _Array functions take the array by reference, not by value. That means you must pass a variable. The documentation in the beta version appears to correctly show you must pass ByRef so I'm resolving this as no bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.