Modify

Opened 10 years ago

Closed 10 years ago

#1160 closed Bug (No Bug)

GuictrlcreatePic not displaying over ListView in Win7

Reported by: anonymous Owned by: Jon
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: Blocking
Keywords: Cc:

Description

Using Windows 7 RC the image will not display over a listview control. Works fine when running on XP. I don't have Vista to test with.

;ListView with Pic overview test
#include <GUIConstantsEx.au3>

$hGui = GUICreate("ListView Pic test", 400, 600)
$hLV = GUICtrlCreateListView("Test|One", 100, 10, 300, 590)
GUICtrlCreatePic(".\Web\Img_Small.jpg", 60, 300, 0, 0)
GUICtrlSetState(-1, $GUI_ONTOP)
GUISetState()

While 1
	$msg = GUIGetMsg()
	If $msg = $GUI_EVENT_CLOSE Then ExitLoop
WEnd

Attachments (0)

Change History (7)

comment:1 Changed 10 years ago by Jpm

I don't have access to Windows 7. It would be better that you repproduce under the RTM release.
I can just say that it is working under Vista

comment:2 Changed 10 years ago by danielkza

Just confirming it's not an issue in OP's machine: I can see the same behavior in Win7 RC too. It works fine on my Vista laptop, though.

comment:3 Changed 10 years ago by Jpm

  • Owner set to Jos
  • Status changed from new to assigned

comment:4 Changed 10 years ago by Valik

  • Severity changed from None to Blocking

comment:5 Changed 10 years ago by Jon

Works on windows 7 when run without visual styles. Almost certainly a Win7 bug/change.

comment:6 Changed 10 years ago by Jpm

  • Owner changed from Jos to Jon

comment:7 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from assigned to closed

This is not a bug, just incomplete code. The ListView requires $WS_CLIPSIBLINGS so the image can be drawn over it. This example should work on all versions of Windows:

;ListView with Pic overview test
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>

$hGui = GUICreate("ListView Pic test", 400, 600)
$hLV = GUICtrlCreateListView("Test|One", 100, 10, 300, 590, $WS_CLIPSIBLINGS)
GUICtrlCreatePic(".\Web\Img_Small.jpg", 60, 300, 0, 0)
GUICtrlSetState(-1, $GUI_ONTOP)
GUISetState()

While 1
	$msg = GUIGetMsg()
	If $msg = $GUI_EVENT_CLOSE Then ExitLoop
WEnd

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.