Modify

Opened 10 years ago

Closed 7 years ago

#1172 closed Feature Request (Rejected)

.NET controls in beta 3.3.1.1

Reported by: arthur@… Owned by: Jon
Milestone: Component: AutoIt
Version: Severity: None
Keywords: Cc:

Description

Great job in getting WM_GETCONTROLNAME into the system!

.NET names are not always unique in the application you are automating. I tried to use INSTANCE and it does not work.

I used the zfisherdrums script and added a few things you might want to add.
1) Enabled (IsEnabled works on the object)
2) Visible (IsVisible works on the object)
3) CLASSNN contains (Sometimes the non-unique .net control is more then one type of object)

I’d love a way to know if my specified object is not unique; maybe return an array of handles?

The .NET Name on an Edit control might pull up a handle that is not the real objects editable child.

Thank you for all the great work on AutoIt.

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by Jpm

  • Type changed from Bug to Feature Request

I move it to Feature request as it is not a Bug ...

comment:2 Changed 10 years ago by TicketCleanup

  • Version 3.3.1.1 deleted

Automatic ticket cleanup.

comment:3 Changed 10 years ago by Jpm

Using NAME and INSTANCE as been added to 3.3.1.5

comment:4 Changed 10 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

comment:5 Changed 7 years ago by trancexx

  • Resolution set to Rejected
  • Status changed from assigned to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.