Modify

Opened 10 years ago

Closed 10 years ago

#1176 closed Bug (Fixed)

FileSetAttrib with recurse mode 1 not continue when file not found in subfolder

Reported by: MrCreatoR <mscreator@…> Owned by: Jpm
Milestone: 3.3.1.2 Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: FileSetAttrib, recursive, folder, file Cc:

Description

Hi,

The problem is that when we set attributes using recursive mode, and one of the files are missing in some subfolder, then FileSetAttrib does not continue to next files, it's just stops and return 0.

If Not FileSetAttrib(@ScriptDir & "\Test\test.txt", "+H", 1) Then
	MsgBox(4096, "Error", "Problem setting attributes.")
EndIf

Folders/files structure:

.\Test\test.txt
.\Test\Subfolder
.\Test\Subfolder\Subfolder\Test.txt

Now here for the last file «Test\Subfolder\Subfolder\Test.txt» the attributes are not set.

While the console attrib.exe program does not stops, it's set attributes for all the files it can (it skips the problematic files).

If it's not a bug and it's designed like that (why?), then i think at least this should be mentioned in the help file.

Thanks.

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Jpm

  • Milestone set to 3.3.1.2
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.3.1.2

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.