Modify

Opened 10 years ago

Closed 10 years ago

#1254 closed Bug (No Bug)

_WeekNumberISO and GUICtrlCreateMonthCal return different weeknumbers for same day

Reported by: Jimblack@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

I suspect _WeekNumberISO function is 'off by 1' since it returns a week number 1 greater than GUICtrlCreateMonthCal. This would result in 53 weeks in this year instead of 52. this is in 3.3.0.0 and 3.3.1.4.

Attachments (1)

Test_WeekNumber.au3 (713 bytes) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by blackja@…

I realized I put my name not my email address - sorry

comment:2 Changed 10 years ago by Jpm

From ISO standpoint the week 53 exists. I don't know if we are in a year as such.
Jos our ISO expert will answer.

comment:3 Changed 10 years ago by Jos

I get for both week 44 and here http://en.wikipedia.org/wiki/ISO_week_date you can find info about the ISO weeknr which can be 52.

Jos

comment:4 Changed 10 years ago by JimBlack

Thanks for your wikipedia link. I understand now. This is not a bug, this is misuse of function. I will write my own UDF to calculate the NON-ISO week number since I could not find one in Autoit. Thanks for your help.

comment:5 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.