Modify

Opened 10 years ago

Closed 10 years ago

#1305 closed Bug (No Bug)

GUISetFont, GUICtrlCreateTreeViewItem, korean language combination bug

Reported by: xyz33 <flash8@…> Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

If you use the korean language with a treeview (GUICtrlCreateTreeViewItem) and use a GUI font (GUISetFont) then whatever parameter you use the text cannot be shown.

Example script with UCS-2 Big Endian Encoding:

#include <GUIConstants.au3>

GuiCreate("test")

GUISetFont(8, 300, 0, "Verdana"); <- if you comment this out than it works

$TreeView = GUICtrlCreateTreeView(50, 50, 150, 40)
GUICtrlCreateTreeViewItem("korean 업데이트", $TreeView)
GUICtrlCreateTreeViewItem("chinese 出碎片整理", $TreeView)

GUISetState ()

While 1
    $msg = GuiGetMsg()
    If $msg = $GUI_EVENT_CLOSE Then
        ExitLoop
	EndIf
WEnd
Exit

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. The font you choose must contain Chinese and Korean characters in order for it to know what to render. Presumably the default font you have configured contains those characters. When you change to a different font that doesn't contain those characters... then the non-Latin characters can't be rendered.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.