Modify

Opened 10 years ago

Closed 10 years ago

#1342 closed Bug (Duplicate)

DllStructCreate does not accept variable names with underscore

Reported by: thomas.baglin@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: dllstructcreate underscore Cc:

Description

$dllstruct=dllstructcreate("int titi_1")
consolewrite("@error reported with underscore=" & @error & @CRLF)
$dllstruct=dllstructcreate("int titi")
consolewrite("@error reported without underscore=" & @error & @CRLF)

The above script returns error 2/"There is an unknown Data Type in the string passed" and not in the second case.

Hoping I am not wasting your time :-)
Tom

Attachments (0)

Change History (1)

comment:1 in reply to: ↑ description Changed 10 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

Replying to thomas.baglin@…:

Hoping I am not wasting your time :-)

You are because you:

  • Didn't check the issue tracker to see it's already been reported.
  • Didn't test with the latest beta to see that it's already been fixed.

Closing as duplicate of #1321.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.