Modify

Opened 10 years ago

Closed 10 years ago

#1424 closed Bug (No Bug)

GUICtrlCreateListView: $LVS_EX_BORDERSELECT fails.

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.4.0 Severity: None
Keywords: ListView BORDERSELECT Cc:

Description

#include <ListviewConstants.au3>
#include <GUIConstantsEx.au3>

Global $vTmp, $iWidth = 200, $iHeight = $iWidth
GUICreate('title', $iWidth, $iHeight)
ConsoleWrite('$LVS_EX_BORDERSELECT = 0x' & Hex($LVS_EX_BORDERSELECT) & @CRLF)

$vTmp = GUICtrlCreateListView('a|b|c', 0, 0, $iWidth, $iHeight, -1, $LVS_EX_BORDERSELECT)
If @error Then Exit 999

;~ $vTmp = GUICtrlCreateListView('a|b|c', 0, 0, $iWidth, $iHeight, -1, $LVS_EX_GRIDLINES)
;~ If @error Then Exit 888
;~ GUISetState()
;~ Do
;~ Until GUIGetMsg() = $GUI_EVENT_CLOSE

Exit 0

$LVS_EX_BORDERSELECT being the only one that fails of ListView Extended Styles.
(Language:0409 Keyboard:00000409 OS:WIN_XP/Service Pack 3 CPU:X86 OS:X86)

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. As best I can tell $LVS_EX_BORDERSELECT is only valid when using $LVS_ICON. However, you can't specify $LVS_ICON at creation time with the AutoIt-native controls. Try using the UDF-version.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.