Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1427 closed Bug (No Bug)

RegWite REG_BINARY wites data to registry that cannot read by other application

Reported by: grabalife@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.3.2 Severity: None
Keywords: Cc:

Description

This command worked fine in v3.2.12.0
RegWrite("
" & $device & "\HKLM\SOFTWARE\SOMETHING\Default", "Password", "REG_BINARY", "DBD83CFD727A1458")

Result with v3.2.12.0
[HKEY_LOCAL_MACHINE\SOMETHING\Default]
"Password"=hex:db,d8,3c,fd,72,7a,14,58

Result with V3.3.3.2 and V3.3.4.0
[HKEY_LOCAL_MACHINE\SOMETHING\Default]
"Password"=hex:44,42,44,38,33,43,46,44,37,32,37,41,31,34,35,38

New behaviour of RegWrite for binary string does not produce good results. Values written by 3.3.2 and 3.3.4 are not correct for other application (not written in AutoIT) to read and are ignored.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by ProgAndy

You do not understand the change in the RegWrite function. A 'binary string' is a string beginning with 0x and then containing an even number of the characters 0123456789ABCDEF

So the RegWrite mus be:
RegWrite("...", "...", "REG_BINARY", "0xDBD83CFD727A1458")
Better style is to use an explicit Binary-cinversion:
RegWrite("...", "...", "REG_BINARY", Binary("0xDBD83CFD727A1458"))

THIS IS NO BUG.

comment:2 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

comment:3 Changed 10 years ago by anonymous

Thanks, appreciate the explanation. I was thrown by the fact it worked previously and then didn't and there was nothing I could see in the help file to explain what I was doing wrong. Thanks again.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.